Security Advisory Critical: flash-plugin security update

Advisory: RHSA-2017:0934-1
Type: Security Advisory
Severity: Critical
Issued on: 2017-04-12
Last updated on: 2017-04-12
Affected Products: Red Hat Enterprise Linux Desktop Supplementary (v. 6)
Red Hat Enterprise Linux Server Supplementary (v. 6)
Red Hat Enterprise Linux Workstation Supplementary (v. 6)
CVEs (cve.mitre.org): CVE-2017-3058
CVE-2017-3059
CVE-2017-3060
CVE-2017-3061
CVE-2017-3062
CVE-2017-3063
CVE-2017-3064

Details

An update for flash-plugin is now available for Red Hat Enterprise Linux 6
Supplementary.

Red Hat Product Security has rated this update as having a security impact of
Critical. A Common Vulnerability Scoring System (CVSS) base score, which gives a
detailed severity rating, is available for each vulnerability from the CVE
link(s) in the References section.

The flash-plugin package contains a Mozilla Firefox compatible Adobe Flash
Player web browser plug-in.

This update upgrades Flash Player to version 25.0.0.148.

Security Fix(es):

* This update fixes multiple vulnerabilities in Adobe Flash Player. These
vulnerabilities, detailed in the Adobe Security Bulletin listed in the
References section, could allow an attacker to create a specially crafted SWF
file that would cause flash-plugin to crash, execute arbitrary code, or disclose
sensitive information when the victim loaded a page containing the malicious SWF
content. (CVE-2017-3058, CVE-2017-3059, CVE-2017-3060, CVE-2017-3061,
CVE-2017-3062, CVE-2017-3063, CVE-2017-3064)


Solution

For details on how to apply this update, which includes the changes described in
this advisory, refer to:

https://access.redhat.com/articles/11258

Updated packages

Red Hat Enterprise Linux Desktop Supplementary (v. 6)

IA-32:
flash-plugin-25.0.0.148-1.el6_9.i686.rpm
File outdated by:  RHSA-2017:1439
    MD5: 00d9e43648a897f6854805f7b82b7c9f
SHA-256: 74bf6f9a40d40b0f4123972fd9130df1a64755bab18283ced579231bf5333dbb
 
x86_64:
flash-plugin-25.0.0.148-1.el6_9.i686.rpm
File outdated by:  RHSA-2017:1439
    MD5: 00d9e43648a897f6854805f7b82b7c9f
SHA-256: 74bf6f9a40d40b0f4123972fd9130df1a64755bab18283ced579231bf5333dbb
 
Red Hat Enterprise Linux Server Supplementary (v. 6)

IA-32:
flash-plugin-25.0.0.148-1.el6_9.i686.rpm
File outdated by:  RHSA-2017:1439
    MD5: 00d9e43648a897f6854805f7b82b7c9f
SHA-256: 74bf6f9a40d40b0f4123972fd9130df1a64755bab18283ced579231bf5333dbb
 
x86_64:
flash-plugin-25.0.0.148-1.el6_9.i686.rpm
File outdated by:  RHSA-2017:1439
    MD5: 00d9e43648a897f6854805f7b82b7c9f
SHA-256: 74bf6f9a40d40b0f4123972fd9130df1a64755bab18283ced579231bf5333dbb
 
Red Hat Enterprise Linux Workstation Supplementary (v. 6)

IA-32:
flash-plugin-25.0.0.148-1.el6_9.i686.rpm
File outdated by:  RHSA-2017:1439
    MD5: 00d9e43648a897f6854805f7b82b7c9f
SHA-256: 74bf6f9a40d40b0f4123972fd9130df1a64755bab18283ced579231bf5333dbb
 
x86_64:
flash-plugin-25.0.0.148-1.el6_9.i686.rpm
File outdated by:  RHSA-2017:1439
    MD5: 00d9e43648a897f6854805f7b82b7c9f
SHA-256: 74bf6f9a40d40b0f4123972fd9130df1a64755bab18283ced579231bf5333dbb
 
(The unlinked packages above are only available from the Red Hat Network)

Bugs fixed (see bugzilla for more information)

1441308 - CVE-2017-3058 CVE-2017-3059 CVE-2017-3060 CVE-2017-3061 CVE-2017-3062 CVE-2017-3063 CVE-2017-3064 flash-plugin: multiple code execution issues fixed in APSB17-10


References



These packages are GPG signed by Red Hat for security. Our key and details on how to verify the signature are available from:
https://www.redhat.com/security/team/key/#package

The Red Hat security contact is secalert@redhat.com. More contact details at http://www.redhat.com/security/team/contact/