Security Advisory Moderate: python-django-horizon security and bug fix update

Advisory: RHSA-2014:0365-1
Type: Security Advisory
Severity: Moderate
Issued on: 2014-04-03
Last updated on: 2014-04-03
Affected Products: Red Hat OpenStack 3.0
CVEs ( CVE-2013-6858


Updated python-django-horizon packages that fix one security issue and
several bugs are now available for Red Hat Enterprise Linux OpenStack
Platform 3.0.

The Red Hat Security Response Team has rated this update as having Moderate
security impact. A Common Vulnerability Scoring System (CVSS) base score,
which gives a detailed severity rating, is available from the CVE link in
the References section.

OpenStack Dashboard (horizon) provides administrators and users a graphical
interface to access, provision and automate cloud-based resources.
The dashboard allows cloud administrators to get an overall view of the
size and state of the cloud and it provides end-users a self-service portal
to provision their own resources within the limits set by administrators.

A flaw was found in the way OpenStack Dashboard sanitized the Instance Name
string. By embedding HTML tags in an Instance Name, a remote attacker could
use this flaw to execute a script within a victim's browser, resulting in a
cross-site scripting (XSS) attack. Note that only setups using OpenStack
Dashboard were affected. (CVE-2013-6858)

The python-django-horizon packages have been upgraded to upstream version
2013.1.5, which provides a number of bug fixes over the previous version.

All python-django-horizon users are advised to upgrade to these updated
packages, which correct these issues.


Before applying this update, make sure all previously released errata
relevant to your system have been applied.

This update is available via the Red Hat Network. Details on how to
use the Red Hat Network to apply this update are available at

Updated packages

Red Hat OpenStack 3.0

python-django-horizon-2013.1.5-1.el6ost.src.rpm     MD5: 275ba16e238a501916cfeab6728c9475
SHA-256: 25b04cc5e1b69437c21fce21a49d1391ca33027af8afdc7c105bd56ecf6f969b
openstack-dashboard-2013.1.5-1.el6ost.noarch.rpm     MD5: 4e77541d6f8cb92e7c23c60db5a949af
SHA-256: cab20de3f261f1d5571050d94031055c6b619ad67de7fa55382660612f461b77
python-django-horizon-2013.1.5-1.el6ost.noarch.rpm     MD5: 45b69b8be5a9522ce37b444045d2ed82
SHA-256: 9dea64bad9c1f6e4c2a384f79bd9e410952a053d3252c5e1260c31378c5a4637
python-django-horizon-doc-2013.1.5-1.el6ost.noarch.rpm     MD5: d8900c00ad31a15b5863d612984ea125
SHA-256: 9bcbc5145ad6b87da62823358e6943bad98e6a1e71a87692d7829038d08a7297
(The unlinked packages above are only available from the Red Hat Network)

Bugs fixed (see bugzilla for more information)

1034153 - CVE-2013-6858 openstack: horizon multiple XSS vulnerabilities.


These packages are GPG signed by Red Hat for security. Our key and details on how to verify the signature are available from:

The Red Hat security contact is More contact details at