Skip to navigation

Security Advisory Moderate: python-keystoneclient security and bug fix update

Advisory: RHSA-2013:0944-1
Type: Security Advisory
Severity: Moderate
Issued on: 2013-06-12
Last updated on: 2013-06-12
Affected Products: Red Hat OpenStack 3.0
CVEs (cve.mitre.org): CVE-2013-2104

Details

Updated python-keystoneclient packages that fix one security issue and
multiple bugs are now available for Red Hat OpenStack 3.0 (Grizzly)
Preview.

The Red Hat Security Response Team has rated this update as having moderate
security impact. A Common Vulnerability Scoring System (CVSS) base score,
which gives a detailed severity rating, is available from the CVE link in
the References section.

Python-keystoneclient is the client library and command line utility for
interacting with the OpenStack identity API.

A flaw in Keystone allowed an attacker with access to the web and network
interfaces of services utilizing python-keystoneclient (such as Nova,
Cinder, Swift, Glance, and so on) to continue using PKI tokens that had
expired. This would allow the attacker to continue using the PKI tokens
despite the PKI tokens being expired, giving them continued access to
OpenStack services. (CVE-2013-2104)

This issue was discovered by Eoghan Glynn of Red Hat.

This update also fixes a number of bugs in python-keystoneclient.

All users of Red Hat OpenStack 3.0 (Grizzly) Preview are advised to install
these updated packages.


Solution

Before applying this update, make sure all previously-released errata
relevant to your system have been applied.

This update is available via the Red Hat Network. Details on how to
use the Red Hat Network to apply this update are available at
https://access.redhat.com/knowledge/articles/11258

Updated packages

Red Hat OpenStack 3.0

SRPMS:
python-keystoneclient-0.2.3-2.el6ost.src.rpm
File outdated by:  RHBA-2013:1510
    MD5: a3f2c5567318deb2dccc08b8765847cb
SHA-256: a4168dacb92562089a19c883cd4af027a31b513c9c6a52b660e9296828834037
 
x86_64:
python-keystoneclient-0.2.3-2.el6ost.noarch.rpm
File outdated by:  RHBA-2013:1510
    MD5: eb8acb1e4f375207341cad8e0fc22870
SHA-256: 04c4ed188597520cdbe6fdd6c444dfa6b7fd6549ad518b86e2f14f4ca8164424
python-keystoneclient-doc-0.2.3-2.el6ost.noarch.rpm
File outdated by:  RHBA-2013:1510
    MD5: e17a3bbac07086f419bd2486fc90da15
SHA-256: 478d3ee2dfa6fdedd3e5af78e5a3e6b9585e4b6ff3be6764c79045198e62812d
 
(The unlinked packages above are only available from the Red Hat Network)

Bugs fixed (see bugzilla for more information)

904351 - Provide keystone man page for the command line interface.
928558 - add support for Swift cache in authtoken m/w
965852 - CVE-2013-2104 OpenStack Keystone: Missing expiration check in Keystone PKI token validation


References



These packages are GPG signed by Red Hat for security. Our key and details on how to verify the signature are available from:
https://www.redhat.com/security/team/key/#package

The Red Hat security contact is secalert@redhat.com. More contact details at http://www.redhat.com/security/team/contact/