Skip to navigation

Security Advisory Moderate: postgresql security update

Advisory: RHSA-2012:1264-1
Type: Security Advisory
Severity: Moderate
Issued on: 2012-09-13
Last updated on: 2012-09-13
Affected Products: RHEL Desktop Workstation (v. 5 client)
Red Hat Enterprise Linux (v. 5 server)
Red Hat Enterprise Linux Desktop (v. 5 client)
CVEs (cve.mitre.org): CVE-2012-3488

Details

Updated postgresql packages that fix one security issue are now available
for Red Hat Enterprise Linux 5.

The Red Hat Security Response Team has rated this update as having moderate
security impact. A Common Vulnerability Scoring System (CVSS) base score,
which gives a detailed severity rating, is available from the CVE link in
the References section.

PostgreSQL is an advanced object-relational database management system
(DBMS).

It was found that the optional PostgreSQL xml2 contrib module allowed local
files and remote URLs to be read and written to with the privileges of the
database server when parsing Extensible Stylesheet Language Transformations
(XSLT). An unprivileged database user could use this flaw to read and write
to local files (such as the database's configuration files) and remote URLs
they would otherwise not have access to by issuing a specially-crafted SQL
query. (CVE-2012-3488)

Red Hat would like to thank the PostgreSQL project for reporting this
issue. Upstream acknowledges Peter Eisentraut as the original reporter.

All PostgreSQL users are advised to upgrade to these updated packages,
which contain a backported patch to correct this issue. If the postgresql
service is running, it will be automatically restarted after installing
this update.


Solution

Before applying this update, make sure all previously-released errata
relevant to your system have been applied.

This update is available via the Red Hat Network. Details on how to
use the Red Hat Network to apply this update are available at
https://access.redhat.com/knowledge/articles/11258

Updated packages

RHEL Desktop Workstation (v. 5 client)

SRPMS:
postgresql-8.1.23-6.el5_8.src.rpm
File outdated by:  RHSA-2014:0249
    MD5: 067038c6be8a6472ffc31d5060009fd7
SHA-256: ce36e34f8e150ddf56b1bcb47400c2b12078ed59c8c515a449b253aeab346e3f
 
IA-32:
postgresql-debuginfo-8.1.23-6.el5_8.i386.rpm
File outdated by:  RHSA-2014:0249
    MD5: 48f0bb26265ff114ed72389caeb678a9
SHA-256: db22ea9f4947f0e8aa13b36fed5a12227e8271390d8c6f8aa94f81d7bbaee25a
postgresql-devel-8.1.23-6.el5_8.i386.rpm
File outdated by:  RHSA-2014:0249
    MD5: 96d7b71c01a19a162c5fda973435a9cd
SHA-256: e962819e29f3bb091d95a78181b450ee35901478799dca6c8558a2601b8f6bae
postgresql-pl-8.1.23-6.el5_8.i386.rpm
File outdated by:  RHSA-2014:0249
    MD5: 8e7cd9e5cf5eaef06f92685658e5d845
SHA-256: 984c0ed76cd1d117eec2c4983995e3ab943a0d7a3b85dd70a2f598ced9c587d7
postgresql-server-8.1.23-6.el5_8.i386.rpm
File outdated by:  RHSA-2014:0249
    MD5: aba870b037deaf6cbba53dee7140bb15
SHA-256: 074136166d73b25f054841adcf6b1adb0a8074bff15fb4b05ac365bec9f418c2
postgresql-test-8.1.23-6.el5_8.i386.rpm
File outdated by:  RHSA-2014:0249
    MD5: 2726b660f081e83e3614fb241e91cf2e
SHA-256: e1e8b0214c5ae489a670e24c3ec96c2099ae5ac71cd78ecc1757562ed9178c0d
 
x86_64:
postgresql-debuginfo-8.1.23-6.el5_8.i386.rpm
File outdated by:  RHSA-2014:0249
    MD5: 48f0bb26265ff114ed72389caeb678a9
SHA-256: db22ea9f4947f0e8aa13b36fed5a12227e8271390d8c6f8aa94f81d7bbaee25a
postgresql-debuginfo-8.1.23-6.el5_8.x86_64.rpm
File outdated by:  RHSA-2014:0249
    MD5: 4301b962685c6ca63cdddc44edfd4858
SHA-256: 8e60660fe570614b830d9059365d1fbe4fe0d7abe5a6a830daf21f2fae4cdc8e
postgresql-devel-8.1.23-6.el5_8.i386.rpm
File outdated by:  RHSA-2014:0249
    MD5: 96d7b71c01a19a162c5fda973435a9cd
SHA-256: e962819e29f3bb091d95a78181b450ee35901478799dca6c8558a2601b8f6bae
postgresql-devel-8.1.23-6.el5_8.x86_64.rpm
File outdated by:  RHSA-2014:0249
    MD5: 58b82371cf14ce3cd82712f8b9197b91
SHA-256: 49067edcb0426c9332f0024fd434af05b041da32fc3fbe61d8960fbd9a2e4925
postgresql-pl-8.1.23-6.el5_8.x86_64.rpm
File outdated by:  RHSA-2014:0249
    MD5: 880d9456ca742eacc4b171cef2df1481
SHA-256: 6c7dc11a041e4a846caed3b8dc16bd9c9cb0cca35b7cd391266fc373e98b641f
postgresql-server-8.1.23-6.el5_8.x86_64.rpm
File outdated by:  RHSA-2014:0249
    MD5: 5935176bd31ae3213ceac007dbd31cef
SHA-256: 29e734f11b86ea96fe78bf9c7b5a137a53a126bef523bc7a8a5289be6e04ebd5
postgresql-test-8.1.23-6.el5_8.x86_64.rpm
File outdated by:  RHSA-2014:0249
    MD5: 6bae7617c0bf51e8179cc27cce74c82a
SHA-256: 7a02b6b3d1598ae6947e4bdf4f6ea8389b745b0b2d2db20cebc6180a7df3684e
 
Red Hat Enterprise Linux (v. 5 server)

SRPMS:
postgresql-8.1.23-6.el5_8.src.rpm
File outdated by:  RHSA-2014:0249
    MD5: 067038c6be8a6472ffc31d5060009fd7
SHA-256: ce36e34f8e150ddf56b1bcb47400c2b12078ed59c8c515a449b253aeab346e3f
 
IA-32:
postgresql-8.1.23-6.el5_8.i386.rpm
File outdated by:  RHSA-2014:0249
    MD5: 6cb0243169866d687b2ed9e8c4ea936c
SHA-256: 70ad01bc3d7c0140a24b4f59bc0425ccb87b2c519791ba91d3912d2b99318d7c
postgresql-contrib-8.1.23-6.el5_8.i386.rpm
File outdated by:  RHSA-2014:0249
    MD5: 84d3ef3a8b1d440af0e1fcb321b4ec74
SHA-256: 15fe8bfb1fb1276516f9796ebdf007a2c3554ecbf941c7d16d2d8456fe71e55d
postgresql-debuginfo-8.1.23-6.el5_8.i386.rpm
File outdated by:  RHSA-2014:0249
    MD5: 48f0bb26265ff114ed72389caeb678a9
SHA-256: db22ea9f4947f0e8aa13b36fed5a12227e8271390d8c6f8aa94f81d7bbaee25a
postgresql-devel-8.1.23-6.el5_8.i386.rpm
File outdated by:  RHSA-2014:0249
    MD5: 96d7b71c01a19a162c5fda973435a9cd
SHA-256: e962819e29f3bb091d95a78181b450ee35901478799dca6c8558a2601b8f6bae
postgresql-docs-8.1.23-6.el5_8.i386.rpm
File outdated by:  RHSA-2014:0249
    MD5: 64dc9b6d896a67cd55822e7116a3e519
SHA-256: 680430823bd5a42cf4986de2aac48e67392c476d7bc197376f9cd487cfc08a05
postgresql-libs-8.1.23-6.el5_8.i386.rpm
File outdated by:  RHSA-2014:0249
    MD5: 9a3d8fc3b5f4d6e9c9a4151dc8826d3a
SHA-256: a11845366e85b89dd7060f2c3f789b14ee234379fe099fc1ed0943ace6f9798a
postgresql-pl-8.1.23-6.el5_8.i386.rpm
File outdated by:  RHSA-2014:0249
    MD5: 8e7cd9e5cf5eaef06f92685658e5d845
SHA-256: 984c0ed76cd1d117eec2c4983995e3ab943a0d7a3b85dd70a2f598ced9c587d7
postgresql-python-8.1.23-6.el5_8.i386.rpm
File outdated by:  RHSA-2014:0249
    MD5: ef72835cf8a872f74e621802bb945712
SHA-256: dece9e511e62b1b02fa6ab65eec250bde69fa417f7e250af9c705a7f307f7370
postgresql-server-8.1.23-6.el5_8.i386.rpm
File outdated by:  RHSA-2014:0249
    MD5: aba870b037deaf6cbba53dee7140bb15
SHA-256: 074136166d73b25f054841adcf6b1adb0a8074bff15fb4b05ac365bec9f418c2
postgresql-tcl-8.1.23-6.el5_8.i386.rpm
File outdated by:  RHSA-2014:0249
    MD5: e80c04936f85648adb76695c2683eb88
SHA-256: db538dfa22873e8f27dae8deecd133736c2c9a4a538aecb5abcc368697db0d5f
postgresql-test-8.1.23-6.el5_8.i386.rpm
File outdated by:  RHSA-2014:0249
    MD5: 2726b660f081e83e3614fb241e91cf2e
SHA-256: e1e8b0214c5ae489a670e24c3ec96c2099ae5ac71cd78ecc1757562ed9178c0d
 
IA-64:
postgresql-8.1.23-6.el5_8.ia64.rpm
File outdated by:  RHSA-2014:0249
    MD5: 97e24db9ccac3bc085e1b27c2d30e51a
SHA-256: c2257ed3d52f6e713d52d7ba93d640675cf85a7159bab094588e7dc9dead2cc5
postgresql-contrib-8.1.23-6.el5_8.ia64.rpm
File outdated by:  RHSA-2014:0249
    MD5: 9c41b3e417169f9effbf7fb22bbc4477
SHA-256: ea35ae0d13babea717ac0a2a95a4d72b21e7d868cde081d336828b5c8658a2da
postgresql-debuginfo-8.1.23-6.el5_8.i386.rpm
File outdated by:  RHSA-2014:0249
    MD5: 48f0bb26265ff114ed72389caeb678a9
SHA-256: db22ea9f4947f0e8aa13b36fed5a12227e8271390d8c6f8aa94f81d7bbaee25a
postgresql-debuginfo-8.1.23-6.el5_8.ia64.rpm
File outdated by:  RHSA-2014:0249
    MD5: 211c54df2d8630d27da1b3d33c069908
SHA-256: e045a66318a3cfd19b2b912e02d685210bc7eb66a9b9f313a1ecc0c97a851531
postgresql-devel-8.1.23-6.el5_8.ia64.rpm
File outdated by:  RHSA-2014:0249
    MD5: 007cb855343cba47728132afe674b43a
SHA-256: 55cbe38422d65856d66e381b1aaa78ea7e41cddd2d26ef71cb4b7d60ff16c0b2
postgresql-docs-8.1.23-6.el5_8.ia64.rpm
File outdated by:  RHSA-2014:0249
    MD5: 3cfe59052c835402fc8ecd14ad898996
SHA-256: cc73d33ecf2a5bd9927731b8e0a372f3c502a8c7c0c7991dfc91e328dbb82962
postgresql-libs-8.1.23-6.el5_8.i386.rpm
File outdated by:  RHSA-2014:0249
    MD5: 9a3d8fc3b5f4d6e9c9a4151dc8826d3a
SHA-256: a11845366e85b89dd7060f2c3f789b14ee234379fe099fc1ed0943ace6f9798a
postgresql-libs-8.1.23-6.el5_8.ia64.rpm
File outdated by:  RHSA-2014:0249
    MD5: e2f29dab124e1f06f970ff64aa43e530
SHA-256: 032de9cb17d77e1b401698abb5a70da64ba1536afb352e2f0d51fe5e8b838c17
postgresql-pl-8.1.23-6.el5_8.ia64.rpm
File outdated by:  RHSA-2014:0249
    MD5: f9c1f4991e1d5def6d11e6397b94dc6c
SHA-256: d61cef4f5f2d062ce5b115aecc7335ccec078528a4151b8237fed2837efc8b1f
postgresql-python-8.1.23-6.el5_8.ia64.rpm
File outdated by:  RHSA-2014:0249
    MD5: b0c02726a4821a2a34438ef237aae7b0
SHA-256: 966848d89db840f1808d0dccb0b6e187db34f7d5e9e6dbc0c2a9f38e70019a5b
postgresql-server-8.1.23-6.el5_8.ia64.rpm
File outdated by:  RHSA-2014:0249
    MD5: 14e7e572d6898d64d97fb8f08fb05ab0
SHA-256: 46b4b2b124ce811ef18b671eeb87d0b2ebbc8ef5c65712565c6dfa0cd23b6eb4
postgresql-tcl-8.1.23-6.el5_8.ia64.rpm
File outdated by:  RHSA-2014:0249
    MD5: c9899f27f989d4029639bbe4069a6f94
SHA-256: 56dd0cb5fc5153679fa1e9d1c94b4d483b26919eee2ff90d14a76a0e3ff4f02e
postgresql-test-8.1.23-6.el5_8.ia64.rpm
File outdated by:  RHSA-2014:0249
    MD5: b8d26753951ed52241e5ceca05c355f4
SHA-256: f7caafdd841520b5371bd71a9e7c2b22144b5d7faa806deb3b55c77cffcdce85
 
PPC:
postgresql-8.1.23-6.el5_8.ppc.rpm
File outdated by:  RHSA-2014:0249
    MD5: 73359cad5bcef526ec417780d09d801f
SHA-256: 38c1699362bef413c679fabf19265d0bc5d81fa28556011a122015db0ac858bc
postgresql-8.1.23-6.el5_8.ppc64.rpm
File outdated by:  RHSA-2014:0249
    MD5: 805913e21c601b530f0aa9bbf01da28d
SHA-256: a24770237ae2fcc0f3c2afcc7d813552b9e35cb26663f8772e61652b9faeeabb
postgresql-contrib-8.1.23-6.el5_8.ppc.rpm
File outdated by:  RHSA-2014:0249
    MD5: 36aa7e639b1c640e83d9c3ff721cc150
SHA-256: 385a70019b03957528aa441e56fc3059ea644fef77e75c5b83e13a3d37181c34
postgresql-debuginfo-8.1.23-6.el5_8.ppc.rpm
File outdated by:  RHSA-2014:0249
    MD5: 151ee93a26d70ac283493d497a62a49a
SHA-256: 8095754bbe6accfa9064e099c0f9766224f964b9ba0df150deaacc6cc2040154
postgresql-debuginfo-8.1.23-6.el5_8.ppc64.rpm
File outdated by:  RHSA-2014:0249
    MD5: dbaf573f37dcfed569f62c6162114f21
SHA-256: 4876b1e1a4fbc1e89b96f07951a742f69ee6de4d2ad912856e794f6e559ea81a
postgresql-devel-8.1.23-6.el5_8.ppc.rpm
File outdated by:  RHSA-2014:0249
    MD5: 29310e6103de77b77773ba3cdd1c2a01
SHA-256: 9e3b2dbb71b9166c2c7684243fbc244763e7ceb4a2b08b6fefc68623e8c5e2e5
postgresql-devel-8.1.23-6.el5_8.ppc64.rpm
File outdated by:  RHSA-2014:0249
    MD5: a2623b95e184563953f372d547336eaf
SHA-256: 67323b8a74d12d19a3146cb2b53738260525a0aca347890a11b120be89e6a7bc
postgresql-docs-8.1.23-6.el5_8.ppc.rpm
File outdated by:  RHSA-2014:0249
    MD5: 7dce880ea579930f06a601c363894b51
SHA-256: 3ac9bc2469fb5de73d1505f1d7f66f471ecde32dab5129974b4c5caf3dda3087
postgresql-libs-8.1.23-6.el5_8.ppc.rpm
File outdated by:  RHSA-2014:0249
    MD5: 1bb2897380ea1a0f01bd9e3dfaef25b8
SHA-256: f95af11234aaf72f24b0e63a77e02555c789f65a539f9db7c391c526beaada0b
postgresql-libs-8.1.23-6.el5_8.ppc64.rpm
File outdated by:  RHSA-2014:0249
    MD5: 4011e5f2635efc1236106db241fdb2cc
SHA-256: d12b08e82aa15b2bcd28cf21888cd11a78d599d95a90e1a9f06e99fbfcb43802
postgresql-pl-8.1.23-6.el5_8.ppc.rpm
File outdated by:  RHSA-2014:0249
    MD5: 076db365657f1818aa82f527712f62c1
SHA-256: 0961b71e4ba7b3e58af10f0dea0b96280247ce6f4fdbd3c614e16273c5b9e21c
postgresql-python-8.1.23-6.el5_8.ppc.rpm
File outdated by:  RHSA-2014:0249
    MD5: f3e9be0e23629091a70ef9a9e1262e18
SHA-256: c9440aae438a79566276176c3a9e0dfe0524e085f3ee5d9ab7fb7fb0e9a50798
postgresql-server-8.1.23-6.el5_8.ppc.rpm
File outdated by:  RHSA-2014:0249
    MD5: 49dbddbe09da29449d63b234fa232637
SHA-256: c34da3f0e7e3d475ca149ced7f0cf0f14080d3e9d7d9433ce4a1d95a441596d5
postgresql-tcl-8.1.23-6.el5_8.ppc.rpm
File outdated by:  RHSA-2014:0249
    MD5: 6836e99ad6827c03502b6c7d7a083ef4
SHA-256: 335f40622a378819d8dad7a03086590cccf743d6abfb57477b2b882ba8c380f3
postgresql-test-8.1.23-6.el5_8.ppc.rpm
File outdated by:  RHSA-2014:0249
    MD5: 8aa2b0fa792df0918f3b210ebb9d58e3
SHA-256: 15c1197e31848ed70f8d0cdf1f15b6abf6ebc628ef7e4f313070bf4f4aa082ed
 
s390x:
postgresql-8.1.23-6.el5_8.s390x.rpm
File outdated by:  RHSA-2014:0249
    MD5: 411eff08c4483e9d341f8bd5e5bbc2c5
SHA-256: c3072ae0e42aff4d0ebdfefc7461130badbfa118d67441db54f136e1f40577ac
postgresql-contrib-8.1.23-6.el5_8.s390x.rpm
File outdated by:  RHSA-2014:0249
    MD5: f9b445a530871668201fa9515a3ce704
SHA-256: 55d77882f0e0f53504ca4a303789d19ba0772fa2272eed4ef08f9c4dc49f74c0
postgresql-debuginfo-8.1.23-6.el5_8.s390.rpm
File outdated by:  RHSA-2014:0249
    MD5: 28f85df339a506fd91138302f8a08e23
SHA-256: e9d273daa4a2379de39c971dff4fccd5251a6a62d7519f088dfc03b20426fa7a
postgresql-debuginfo-8.1.23-6.el5_8.s390x.rpm
File outdated by:  RHSA-2014:0249
    MD5: 5779b469ae6c7bd2eb85f26bd05d25f6
SHA-256: 1b26becd60ec107888885bb2a3daa842478c726b0a4730babfc216542120f78e
postgresql-devel-8.1.23-6.el5_8.s390.rpm
File outdated by:  RHSA-2014:0249
    MD5: 0a7495e610f32aedb86412a382308f91
SHA-256: 1473a16c9d6cab3dd1adbdb6a6445337412535a84cb99a5bc8e91898c41fe081
postgresql-devel-8.1.23-6.el5_8.s390x.rpm
File outdated by:  RHSA-2014:0249
    MD5: 226e1f6bcc2775ffe507d5a72eaee132
SHA-256: 0170b97561913824278cfc2040e2177882095218e7f49fda85e296a88557172d
postgresql-docs-8.1.23-6.el5_8.s390x.rpm
File outdated by:  RHSA-2014:0249
    MD5: af5775809ffd72e6273b81cb1341feac
SHA-256: dffbc986144867d97b53f7e9516994fc51b155ecb0c5888a970f1ee472073c68
postgresql-libs-8.1.23-6.el5_8.s390.rpm
File outdated by:  RHSA-2014:0249
    MD5: df1e39bc69a588bd0fb5a426edab30c6
SHA-256: 2ecbbfdb1be3142ded84d92da9bccd39fb182b1e120ce5a7dc3c7e7731027c43
postgresql-libs-8.1.23-6.el5_8.s390x.rpm
File outdated by:  RHSA-2014:0249
    MD5: 07ba2e529e2521c304250e46cb8aa9f9
SHA-256: c5f090f6e4553973f2a928ca46a491b1d9cbfe9eba563dc861bd26ef131a964a
postgresql-pl-8.1.23-6.el5_8.s390x.rpm
File outdated by:  RHSA-2014:0249
    MD5: d34a64ee7b55ab63cce58546df250b56
SHA-256: 973ed7c5138e520997a38823939bfb331016de859ef3bd61464c62af6cbb042a
postgresql-python-8.1.23-6.el5_8.s390x.rpm
File outdated by:  RHSA-2014:0249
    MD5: 13f60c92294c88b1c8c0da457bcafc41
SHA-256: bf92005f19df9c4013c8a742d52acd8f8d2206caf9b6c76b9a4772b1dc824159
postgresql-server-8.1.23-6.el5_8.s390x.rpm
File outdated by:  RHSA-2014:0249
    MD5: 290567d1e2b88532941134cef2b2e609
SHA-256: 4071b62821663507109dc6d5f278e9d2371bb06a4267d3ab612d45f1aa5c599e
postgresql-tcl-8.1.23-6.el5_8.s390x.rpm
File outdated by:  RHSA-2014:0249
    MD5: 92761b4818b9f7598b511f6ff2c9ebad
SHA-256: f7cd894d1c0e1a138413212310741e12c9a798adbc8f10efd7185c18ee2df34e
postgresql-test-8.1.23-6.el5_8.s390x.rpm
File outdated by:  RHSA-2014:0249
    MD5: 4ba09047b4246d78a84875f87fcb84f6
SHA-256: 41f57aa9733ad4469c7c679ebeb56b5e48e75a79d5029345da634070480f66dc
 
x86_64:
postgresql-8.1.23-6.el5_8.x86_64.rpm
File outdated by:  RHSA-2014:0249
    MD5: bae6a68a161aec03b2e7c7830407dc2c
SHA-256: 9b8bd2e8ec1874776d3b4fe80460c68a8d7ca6ae2f6666758198fd2aac955ba3
postgresql-contrib-8.1.23-6.el5_8.x86_64.rpm
File outdated by:  RHSA-2014:0249
    MD5: 1ebe420d609690a339320bab0da60382
SHA-256: bec06dd2b88821b51c798d84f68b933d4ce3e88d4213ecb4444d6c816cca64ec
postgresql-debuginfo-8.1.23-6.el5_8.i386.rpm
File outdated by:  RHSA-2014:0249
    MD5: 48f0bb26265ff114ed72389caeb678a9
SHA-256: db22ea9f4947f0e8aa13b36fed5a12227e8271390d8c6f8aa94f81d7bbaee25a
postgresql-debuginfo-8.1.23-6.el5_8.x86_64.rpm
File outdated by:  RHSA-2014:0249
    MD5: 4301b962685c6ca63cdddc44edfd4858
SHA-256: 8e60660fe570614b830d9059365d1fbe4fe0d7abe5a6a830daf21f2fae4cdc8e
postgresql-devel-8.1.23-6.el5_8.i386.rpm
File outdated by:  RHSA-2014:0249
    MD5: 96d7b71c01a19a162c5fda973435a9cd
SHA-256: e962819e29f3bb091d95a78181b450ee35901478799dca6c8558a2601b8f6bae
postgresql-devel-8.1.23-6.el5_8.x86_64.rpm
File outdated by:  RHSA-2014:0249
    MD5: 58b82371cf14ce3cd82712f8b9197b91
SHA-256: 49067edcb0426c9332f0024fd434af05b041da32fc3fbe61d8960fbd9a2e4925
postgresql-docs-8.1.23-6.el5_8.x86_64.rpm
File outdated by:  RHSA-2014:0249
    MD5: 22266db50919c915e86d4f494826a4ec
SHA-256: f61cf698ef25a6727aec65fbd87296184e92f66f62386966a2adeccc1f627b69
postgresql-libs-8.1.23-6.el5_8.i386.rpm
File outdated by:  RHSA-2014:0249
    MD5: 9a3d8fc3b5f4d6e9c9a4151dc8826d3a
SHA-256: a11845366e85b89dd7060f2c3f789b14ee234379fe099fc1ed0943ace6f9798a
postgresql-libs-8.1.23-6.el5_8.x86_64.rpm
File outdated by:  RHSA-2014:0249
    MD5: 4a1c77805870bbcd900419ab20cf3b6e
SHA-256: 0f6465f3eaee8cdb4e2a6e0bd64ca41147e3ef1c5eb711b76e413eebef155056
postgresql-pl-8.1.23-6.el5_8.x86_64.rpm
File outdated by:  RHSA-2014:0249
    MD5: 880d9456ca742eacc4b171cef2df1481
SHA-256: 6c7dc11a041e4a846caed3b8dc16bd9c9cb0cca35b7cd391266fc373e98b641f
postgresql-python-8.1.23-6.el5_8.x86_64.rpm
File outdated by:  RHSA-2014:0249
    MD5: 3290ff5d1b07c74a07d46915562ebc62
SHA-256: 9521da10eac7c49c9716361b813f834da475021fb41b53c54a7e0da3c8524ee6
postgresql-server-8.1.23-6.el5_8.x86_64.rpm
File outdated by:  RHSA-2014:0249
    MD5: 5935176bd31ae3213ceac007dbd31cef
SHA-256: 29e734f11b86ea96fe78bf9c7b5a137a53a126bef523bc7a8a5289be6e04ebd5
postgresql-tcl-8.1.23-6.el5_8.x86_64.rpm
File outdated by:  RHSA-2014:0249
    MD5: 1da1a964ea65395478ace5526d988527
SHA-256: 7a95a69aae5dd350d936fa96c608dc505582e6c1ed3c7b18445e81051f6c0b04
postgresql-test-8.1.23-6.el5_8.x86_64.rpm
File outdated by:  RHSA-2014:0249
    MD5: 6bae7617c0bf51e8179cc27cce74c82a
SHA-256: 7a02b6b3d1598ae6947e4bdf4f6ea8389b745b0b2d2db20cebc6180a7df3684e
 
Red Hat Enterprise Linux Desktop (v. 5 client)

SRPMS:
postgresql-8.1.23-6.el5_8.src.rpm
File outdated by:  RHSA-2014:0249
    MD5: 067038c6be8a6472ffc31d5060009fd7
SHA-256: ce36e34f8e150ddf56b1bcb47400c2b12078ed59c8c515a449b253aeab346e3f
 
IA-32:
postgresql-8.1.23-6.el5_8.i386.rpm
File outdated by:  RHSA-2014:0249
    MD5: 6cb0243169866d687b2ed9e8c4ea936c
SHA-256: 70ad01bc3d7c0140a24b4f59bc0425ccb87b2c519791ba91d3912d2b99318d7c
postgresql-contrib-8.1.23-6.el5_8.i386.rpm
File outdated by:  RHSA-2014:0249
    MD5: 84d3ef3a8b1d440af0e1fcb321b4ec74
SHA-256: 15fe8bfb1fb1276516f9796ebdf007a2c3554ecbf941c7d16d2d8456fe71e55d
postgresql-debuginfo-8.1.23-6.el5_8.i386.rpm
File outdated by:  RHSA-2014:0249
    MD5: 48f0bb26265ff114ed72389caeb678a9
SHA-256: db22ea9f4947f0e8aa13b36fed5a12227e8271390d8c6f8aa94f81d7bbaee25a
postgresql-docs-8.1.23-6.el5_8.i386.rpm
File outdated by:  RHSA-2014:0249
    MD5: 64dc9b6d896a67cd55822e7116a3e519
SHA-256: 680430823bd5a42cf4986de2aac48e67392c476d7bc197376f9cd487cfc08a05
postgresql-libs-8.1.23-6.el5_8.i386.rpm
File outdated by:  RHSA-2014:0249
    MD5: 9a3d8fc3b5f4d6e9c9a4151dc8826d3a
SHA-256: a11845366e85b89dd7060f2c3f789b14ee234379fe099fc1ed0943ace6f9798a
postgresql-python-8.1.23-6.el5_8.i386.rpm
File outdated by:  RHSA-2014:0249
    MD5: ef72835cf8a872f74e621802bb945712
SHA-256: dece9e511e62b1b02fa6ab65eec250bde69fa417f7e250af9c705a7f307f7370
postgresql-tcl-8.1.23-6.el5_8.i386.rpm
File outdated by:  RHSA-2014:0249
    MD5: e80c04936f85648adb76695c2683eb88
SHA-256: db538dfa22873e8f27dae8deecd133736c2c9a4a538aecb5abcc368697db0d5f
 
x86_64:
postgresql-8.1.23-6.el5_8.x86_64.rpm
File outdated by:  RHSA-2014:0249
    MD5: bae6a68a161aec03b2e7c7830407dc2c
SHA-256: 9b8bd2e8ec1874776d3b4fe80460c68a8d7ca6ae2f6666758198fd2aac955ba3
postgresql-contrib-8.1.23-6.el5_8.x86_64.rpm
File outdated by:  RHSA-2014:0249
    MD5: 1ebe420d609690a339320bab0da60382
SHA-256: bec06dd2b88821b51c798d84f68b933d4ce3e88d4213ecb4444d6c816cca64ec
postgresql-debuginfo-8.1.23-6.el5_8.i386.rpm
File outdated by:  RHSA-2014:0249
    MD5: 48f0bb26265ff114ed72389caeb678a9
SHA-256: db22ea9f4947f0e8aa13b36fed5a12227e8271390d8c6f8aa94f81d7bbaee25a
postgresql-debuginfo-8.1.23-6.el5_8.x86_64.rpm
File outdated by:  RHSA-2014:0249
    MD5: 4301b962685c6ca63cdddc44edfd4858
SHA-256: 8e60660fe570614b830d9059365d1fbe4fe0d7abe5a6a830daf21f2fae4cdc8e
postgresql-docs-8.1.23-6.el5_8.x86_64.rpm
File outdated by:  RHSA-2014:0249
    MD5: 22266db50919c915e86d4f494826a4ec
SHA-256: f61cf698ef25a6727aec65fbd87296184e92f66f62386966a2adeccc1f627b69
postgresql-libs-8.1.23-6.el5_8.i386.rpm
File outdated by:  RHSA-2014:0249
    MD5: 9a3d8fc3b5f4d6e9c9a4151dc8826d3a
SHA-256: a11845366e85b89dd7060f2c3f789b14ee234379fe099fc1ed0943ace6f9798a
postgresql-libs-8.1.23-6.el5_8.x86_64.rpm
File outdated by:  RHSA-2014:0249
    MD5: 4a1c77805870bbcd900419ab20cf3b6e
SHA-256: 0f6465f3eaee8cdb4e2a6e0bd64ca41147e3ef1c5eb711b76e413eebef155056
postgresql-python-8.1.23-6.el5_8.x86_64.rpm
File outdated by:  RHSA-2014:0249
    MD5: 3290ff5d1b07c74a07d46915562ebc62
SHA-256: 9521da10eac7c49c9716361b813f834da475021fb41b53c54a7e0da3c8524ee6
postgresql-tcl-8.1.23-6.el5_8.x86_64.rpm
File outdated by:  RHSA-2014:0249
    MD5: 1da1a964ea65395478ace5526d988527
SHA-256: 7a95a69aae5dd350d936fa96c608dc505582e6c1ed3c7b18445e81051f6c0b04
 
(The unlinked packages above are only available from the Red Hat Network)

Bugs fixed (see bugzilla for more information)

849172 - CVE-2012-3488 postgresql (xml2 contrib module): XXE by applying XSL stylesheet to the document


References



These packages are GPG signed by Red Hat for security. Our key and details on how to verify the signature are available from:
https://www.redhat.com/security/team/key/#package

The Red Hat security contact is secalert@redhat.com. More contact details at http://www.redhat.com/security/team/contact/