Skip to navigation

Security Advisory Moderate: postgresql security update

Advisory: RHSA-2012:0677-1
Type: Security Advisory
Severity: Moderate
Issued on: 2012-05-21
Last updated on: 2012-05-21
Affected Products: RHEL Desktop Workstation (v. 5 client)
Red Hat Enterprise Linux (v. 5 server)
Red Hat Enterprise Linux Desktop (v. 5 client)
CVEs (cve.mitre.org): CVE-2012-0866
CVE-2012-0868

Details

Updated postgresql packages that fix two security issues are now available
for Red Hat Enterprise Linux 5.

The Red Hat Security Response Team has rated this update as having moderate
security impact. Common Vulnerability Scoring System (CVSS) base scores,
which give detailed severity ratings, are available for each vulnerability
from the CVE links in the References section.

PostgreSQL is an advanced object-relational database management system
(DBMS).

The pg_dump utility inserted object names literally into comments in the
SQL script it produces. An unprivileged database user could create an
object whose name includes a newline followed by an SQL command. This SQL
command might then be executed by a privileged user during later restore of
the backup dump, allowing privilege escalation. (CVE-2012-0868)

CREATE TRIGGER did not do a permissions check on the trigger function to
be called. This could possibly allow an authenticated database user to
call a privileged trigger function on data of their choosing.
(CVE-2012-0866)

All PostgreSQL users are advised to upgrade to these updated packages,
which contain backported patches to correct these issues. If the postgresql
service is running, it will be automatically restarted after installing
this update.


Solution

Before applying this update, make sure all previously-released errata
relevant to your system have been applied.

This update is available via the Red Hat Network. Details on how to
use the Red Hat Network to apply this update are available at
https://access.redhat.com/knowledge/articles/11258

Updated packages

RHEL Desktop Workstation (v. 5 client)

SRPMS:
postgresql-8.1.23-4.el5_8.src.rpm
File outdated by:  RHSA-2014:0249
    MD5: 83d99b771297e38f7b11c224867e32af
SHA-256: 30c900b9a80fa25f91d2d6faf29297cd0f38f399e8411c0385b23a5d91e41ccd
 
IA-32:
postgresql-debuginfo-8.1.23-4.el5_8.i386.rpm
File outdated by:  RHSA-2014:0249
    MD5: 1389ad5eda4e48fdff28c54433dd85d2
SHA-256: 8545c415706301d4c33558e644c5d84898096eb5d38db6a47af249ac3285d28f
postgresql-devel-8.1.23-4.el5_8.i386.rpm
File outdated by:  RHSA-2014:0249
    MD5: 82bbd49cacf7cd06059e18960c2c70fa
SHA-256: 3861bb0ba9781763e3ea7cba87eb2ee31485acec862cd9fbf9e7f4f1f8fdd856
postgresql-pl-8.1.23-4.el5_8.i386.rpm
File outdated by:  RHSA-2014:0249
    MD5: c85c4a888e24ba5cb326499d770bc75b
SHA-256: 9abd37bcbda25eea30448ee176c8bdb8b2b010bd0eeaf41aa2a1abfb8bd7d9d0
postgresql-server-8.1.23-4.el5_8.i386.rpm
File outdated by:  RHSA-2014:0249
    MD5: c718dc687b32d78408633187c05b23e3
SHA-256: 83f64311b4f591da651f53b8b7dbc6cc11d432500121579e97fab5ee39faa978
postgresql-test-8.1.23-4.el5_8.i386.rpm
File outdated by:  RHSA-2014:0249
    MD5: cdeff0107c17613bc28193bd2ea0243f
SHA-256: 29e5993ed07b3f2e5c92a4b56ae1bd321de5f396bd0afc69c27d242e26ba6dc9
 
x86_64:
postgresql-debuginfo-8.1.23-4.el5_8.i386.rpm
File outdated by:  RHSA-2014:0249
    MD5: 1389ad5eda4e48fdff28c54433dd85d2
SHA-256: 8545c415706301d4c33558e644c5d84898096eb5d38db6a47af249ac3285d28f
postgresql-debuginfo-8.1.23-4.el5_8.x86_64.rpm
File outdated by:  RHSA-2014:0249
    MD5: 9bf8f6fa0a788a33b7df0a92c8e62d7e
SHA-256: ee0850cf49b0cab3bbbfe996cf91c34ffff83a80eb3b4e38b5b9083d05edeece
postgresql-devel-8.1.23-4.el5_8.i386.rpm
File outdated by:  RHSA-2014:0249
    MD5: 82bbd49cacf7cd06059e18960c2c70fa
SHA-256: 3861bb0ba9781763e3ea7cba87eb2ee31485acec862cd9fbf9e7f4f1f8fdd856
postgresql-devel-8.1.23-4.el5_8.x86_64.rpm
File outdated by:  RHSA-2014:0249
    MD5: 2cb691c088e62633ceab6ad131574514
SHA-256: cf160d2f8d8286042452eb9465e61e806745ca0b694ab15851d0f6f0b0f1e62a
postgresql-pl-8.1.23-4.el5_8.x86_64.rpm
File outdated by:  RHSA-2014:0249
    MD5: 331bf511441f4984a65196b96e28dec9
SHA-256: 01deb3651624f021db8414279ddc45e212580a4f68401c5b7e22d4f350f59cea
postgresql-server-8.1.23-4.el5_8.x86_64.rpm
File outdated by:  RHSA-2014:0249
    MD5: e68f80314f313c0436ecf68a942f90ef
SHA-256: 2154338dbe5cae78343ed77bbf614ce47696a9f8c16523104f20c030e5d63a9b
postgresql-test-8.1.23-4.el5_8.x86_64.rpm
File outdated by:  RHSA-2014:0249
    MD5: f05fa2b48d5e655f1d6f276a8cb0d6c2
SHA-256: b6bc4fcc91c3cedf09d1da43745f43db38d144d1cd65ad9ff1c5afc330d242d8
 
Red Hat Enterprise Linux (v. 5 server)

SRPMS:
postgresql-8.1.23-4.el5_8.src.rpm
File outdated by:  RHSA-2014:0249
    MD5: 83d99b771297e38f7b11c224867e32af
SHA-256: 30c900b9a80fa25f91d2d6faf29297cd0f38f399e8411c0385b23a5d91e41ccd
 
IA-32:
postgresql-8.1.23-4.el5_8.i386.rpm
File outdated by:  RHSA-2014:0249
    MD5: 7765db16d0ee556838f6af67ba6ba9b5
SHA-256: 669e91d0022b9e1ec7d446acd3f9369902a414540df626e05f84d142010b6e66
postgresql-contrib-8.1.23-4.el5_8.i386.rpm
File outdated by:  RHSA-2014:0249
    MD5: d0e728b6bdb30aabacd1f320bab0101a
SHA-256: 668df39895816f917410138494f27aae712d0d4b1151a5d6a087b0e1cc11b885
postgresql-debuginfo-8.1.23-4.el5_8.i386.rpm
File outdated by:  RHSA-2014:0249
    MD5: 1389ad5eda4e48fdff28c54433dd85d2
SHA-256: 8545c415706301d4c33558e644c5d84898096eb5d38db6a47af249ac3285d28f
postgresql-devel-8.1.23-4.el5_8.i386.rpm
File outdated by:  RHSA-2014:0249
    MD5: 82bbd49cacf7cd06059e18960c2c70fa
SHA-256: 3861bb0ba9781763e3ea7cba87eb2ee31485acec862cd9fbf9e7f4f1f8fdd856
postgresql-docs-8.1.23-4.el5_8.i386.rpm
File outdated by:  RHSA-2014:0249
    MD5: 9413476ee35dc79b89ba9c24d1c54b66
SHA-256: b26419a52669bfd09ca1014e878c2be5db0fac53729c286a12f51439090ea7cd
postgresql-libs-8.1.23-4.el5_8.i386.rpm
File outdated by:  RHSA-2014:0249
    MD5: 8c4080bc18d35d32792786ad004202ab
SHA-256: ca00fd540d2398fdbdde99d3ddea8b4421028847f5875dea7de3cfa16c625450
postgresql-pl-8.1.23-4.el5_8.i386.rpm
File outdated by:  RHSA-2014:0249
    MD5: c85c4a888e24ba5cb326499d770bc75b
SHA-256: 9abd37bcbda25eea30448ee176c8bdb8b2b010bd0eeaf41aa2a1abfb8bd7d9d0
postgresql-python-8.1.23-4.el5_8.i386.rpm
File outdated by:  RHSA-2014:0249
    MD5: 81d2b15986e554dd453bfba8377cfc41
SHA-256: ed07739cf584757dbc78c384f49e088f83a7f0110cf94aeec70b470ea742bdfa
postgresql-server-8.1.23-4.el5_8.i386.rpm
File outdated by:  RHSA-2014:0249
    MD5: c718dc687b32d78408633187c05b23e3
SHA-256: 83f64311b4f591da651f53b8b7dbc6cc11d432500121579e97fab5ee39faa978
postgresql-tcl-8.1.23-4.el5_8.i386.rpm
File outdated by:  RHSA-2014:0249
    MD5: 2ec85bff9eeaf611a1e0a35f6ef83de8
SHA-256: a0aa46f27a02d0614a28bc5d89448afde6fe0f2b837c6998e71b261f32cdb8c0
postgresql-test-8.1.23-4.el5_8.i386.rpm
File outdated by:  RHSA-2014:0249
    MD5: cdeff0107c17613bc28193bd2ea0243f
SHA-256: 29e5993ed07b3f2e5c92a4b56ae1bd321de5f396bd0afc69c27d242e26ba6dc9
 
IA-64:
postgresql-8.1.23-4.el5_8.ia64.rpm
File outdated by:  RHSA-2014:0249
    MD5: 7c557e1ab4d55aa36825809caace6150
SHA-256: aaf06244bcdd07c045bd07106d2911ac3fe3b3f559da6a5d6c16111252d39b5d
postgresql-contrib-8.1.23-4.el5_8.ia64.rpm
File outdated by:  RHSA-2014:0249
    MD5: be63a6ef511f45f826ec3c3aff33e634
SHA-256: c673b2b451114ee2e3c649f8ef23436a3353ec263f3284e588ed1ff8d7cc494b
postgresql-debuginfo-8.1.23-4.el5_8.i386.rpm
File outdated by:  RHSA-2014:0249
    MD5: 1389ad5eda4e48fdff28c54433dd85d2
SHA-256: 8545c415706301d4c33558e644c5d84898096eb5d38db6a47af249ac3285d28f
postgresql-debuginfo-8.1.23-4.el5_8.ia64.rpm
File outdated by:  RHSA-2014:0249
    MD5: abceb8ed955494f2890e04dcdcd99a3b
SHA-256: be2a174b5cd7c3c104a609c3f528556a21ad4d2f19e95f0f4bde924045b7b5f2
postgresql-devel-8.1.23-4.el5_8.ia64.rpm
File outdated by:  RHSA-2014:0249
    MD5: c27aca7fded8118b99b820a8a2cb8c8a
SHA-256: 3671f3b9122ccea8bcfd7c4aadace941ce307f6b901a7aa20e2aa20c03b6dc9e
postgresql-docs-8.1.23-4.el5_8.ia64.rpm
File outdated by:  RHSA-2014:0249
    MD5: f252aea65f56027263c5f69d61cc20f1
SHA-256: 26f37cddd2d7bf8e684eae9804cda0fbc799c851174b74e6f7b93810d31c1a64
postgresql-libs-8.1.23-4.el5_8.i386.rpm
File outdated by:  RHSA-2014:0249
    MD5: 8c4080bc18d35d32792786ad004202ab
SHA-256: ca00fd540d2398fdbdde99d3ddea8b4421028847f5875dea7de3cfa16c625450
postgresql-libs-8.1.23-4.el5_8.ia64.rpm
File outdated by:  RHSA-2014:0249
    MD5: 842fbe2d1bca78928af0c2575d2a4a2e
SHA-256: fd6892366306f9a55a96fc2defad6cb3d17f8a02c3ac72dbcc486da791c35054
postgresql-pl-8.1.23-4.el5_8.ia64.rpm
File outdated by:  RHSA-2014:0249
    MD5: bfc46d7f594051c014953960f4616f50
SHA-256: 93f82ddd81756eea04712e0caedaf2765bd0d45f3d2fcd677985222eb6f449e4
postgresql-python-8.1.23-4.el5_8.ia64.rpm
File outdated by:  RHSA-2014:0249
    MD5: 5e68dd18d7abc3adaeb79341404858ed
SHA-256: 4ae3cef71a675cb691574db643beca5912fbb2095e82b1adfb52993c928c4e93
postgresql-server-8.1.23-4.el5_8.ia64.rpm
File outdated by:  RHSA-2014:0249
    MD5: 94a4905d81534de8e6d6a17155394534
SHA-256: 9c212ca43b36db165bf3fd74a2d89b81e61bf7e2593060dedeb9693ecd1e384a
postgresql-tcl-8.1.23-4.el5_8.ia64.rpm
File outdated by:  RHSA-2014:0249
    MD5: f14679dcf279b613f8ab1efeacd25228
SHA-256: 6384fc0a521d8c0ee1b0941b797716f4dab25a0905d3fad72acd9778be3789b8
postgresql-test-8.1.23-4.el5_8.ia64.rpm
File outdated by:  RHSA-2014:0249
    MD5: ed1a7c4a47fbcdf6f77bfc9bf8f4ea1b
SHA-256: 836eba669b44c428686ea86cb43d138f3e03c7ecc44499f7d2b04fdcb77c3b21
 
PPC:
postgresql-8.1.23-4.el5_8.ppc.rpm
File outdated by:  RHSA-2014:0249
    MD5: e85ec9059e120ba79916aba26e2fed34
SHA-256: 41379fe75b6a1c38f0910105cc91e48b9fa61488b032f1c3c41009cab2c20725
postgresql-8.1.23-4.el5_8.ppc64.rpm
File outdated by:  RHSA-2014:0249
    MD5: 05f1c14733c827836d3aa911b37f20d7
SHA-256: c60b72f7713fb3b2cf887aff237fc7994fafb5c45f0b2d7a9199c13667aa4fb5
postgresql-contrib-8.1.23-4.el5_8.ppc.rpm
File outdated by:  RHSA-2014:0249
    MD5: 63bf92bbe9c70d624177a713afb0d8f0
SHA-256: e27ce3d064a662467a91590fc284128ef746fdc95e766c9cf7c916fe73630088
postgresql-debuginfo-8.1.23-4.el5_8.ppc.rpm
File outdated by:  RHSA-2014:0249
    MD5: 0f7df17c19f1ff48179c323ddc3428f8
SHA-256: 51ccb6107c5b551606ff92a3fc1ae17faa487e74ce2ed6dd3cf2ba6a86d5ab37
postgresql-debuginfo-8.1.23-4.el5_8.ppc64.rpm
File outdated by:  RHSA-2014:0249
    MD5: e076ee5655d122fec94ac2e950f4f82d
SHA-256: 61328cdd065b572c518442fa8f8c7758153310b64192963c891b6b736db687c3
postgresql-devel-8.1.23-4.el5_8.ppc.rpm
File outdated by:  RHSA-2014:0249
    MD5: c5a19564e42fbaa1bacf5c44a9398b41
SHA-256: 94baa0e6041d19549f0fefc1dcd4594bd09b8b738ea65c40ae61183d7391ea7e
postgresql-devel-8.1.23-4.el5_8.ppc64.rpm
File outdated by:  RHSA-2014:0249
    MD5: c2feeac7b1ce9d79acdcd18430ea8336
SHA-256: aea400f56a7d16c5331a04a2622c91458269a01729832604eed138fe55e15c6d
postgresql-docs-8.1.23-4.el5_8.ppc.rpm
File outdated by:  RHSA-2014:0249
    MD5: 20b2b886cab8a0a4b63efb37c387d468
SHA-256: aa4c9e4f639e8662d702df867d79e62b0d4919f2d29b415bde4854a6dd43f7ac
postgresql-libs-8.1.23-4.el5_8.ppc.rpm
File outdated by:  RHSA-2014:0249
    MD5: db32757aabc28f98d60bad0c67642620
SHA-256: dc17ef079a0f448347da7fc54fb96f13c2d058f04f2e1b6b241c0eb549cbda85
postgresql-libs-8.1.23-4.el5_8.ppc64.rpm
File outdated by:  RHSA-2014:0249
    MD5: a91a37a28f13561e299f8bff8df5a485
SHA-256: f9fb6841dc41b488f8e20f7b111c16d058672878a7c45c19e079cc8685092a59
postgresql-pl-8.1.23-4.el5_8.ppc.rpm
File outdated by:  RHSA-2014:0249
    MD5: eb6ff2c13189ffae5fca1b3dfb6ff6f7
SHA-256: 909e233051aecd4a77c8b0e74771fbff83aad5852de1664e139bfba1a9b13b1e
postgresql-python-8.1.23-4.el5_8.ppc.rpm
File outdated by:  RHSA-2014:0249
    MD5: 330538c7532d42731d3d90ec9eb63885
SHA-256: 18c95d4099f6dbccd67e1ea94b02d563ec90659bd5ab819297b42f79fa9e53dc
postgresql-server-8.1.23-4.el5_8.ppc.rpm
File outdated by:  RHSA-2014:0249
    MD5: c1e3057ae21c54eff1751c43be586678
SHA-256: 15acad8e4adda49936052870ae005abeaeaf6f1f2e69f1cd728a3bbe81902f59
postgresql-tcl-8.1.23-4.el5_8.ppc.rpm
File outdated by:  RHSA-2014:0249
    MD5: fb4ab1f7df37d6faac7b11ccfd981abe
SHA-256: df6ce99724714ca43d8656dc3614957e015e91be6d9651baf71a754982c9bda4
postgresql-test-8.1.23-4.el5_8.ppc.rpm
File outdated by:  RHSA-2014:0249
    MD5: 84772caa78ba35f83bbbda42dbc06398
SHA-256: fcea287a36932b5e2d078ca5b9baed5f25dd3b053d61b80f5c8282ff665e0f32
 
s390x:
postgresql-8.1.23-4.el5_8.s390x.rpm
File outdated by:  RHSA-2014:0249
    MD5: d3b6dd083a9db6e013fcc8490882dd10
SHA-256: 62f675b214939c7e3ab7a242061724528b520cd7ff97b2aa5f79ab944d512594
postgresql-contrib-8.1.23-4.el5_8.s390x.rpm
File outdated by:  RHSA-2014:0249
    MD5: d6680f68785ffe2be94e08ed2b680a89
SHA-256: fe134fc92a442a966834e96ac580fd738173d034286abc90d12f802f8ea23d3b
postgresql-debuginfo-8.1.23-4.el5_8.s390.rpm
File outdated by:  RHSA-2014:0249
    MD5: da9b4ea1d7d3d359a3e55bbacb5bd8d3
SHA-256: 615ef667459f5a6aff4375a339edb5589f5c7a584a7886a4f30bd37298c67eab
postgresql-debuginfo-8.1.23-4.el5_8.s390x.rpm
File outdated by:  RHSA-2014:0249
    MD5: 472d8e7f3eded026ec8c4c2ed381e2b5
SHA-256: 1667427812ebbce16a11ca6391e4c86fd81b4e388a329d367e1ef4e9392d5618
postgresql-devel-8.1.23-4.el5_8.s390.rpm
File outdated by:  RHSA-2014:0249
    MD5: bef15e106a29d37b2f3c3c5c8dd78dda
SHA-256: 74bb7cec771fe407dc41be5c5133153949d2af2ed74a95c347528b2ee8f5d282
postgresql-devel-8.1.23-4.el5_8.s390x.rpm
File outdated by:  RHSA-2014:0249
    MD5: 4e7675edccc085df53461118b6d0b044
SHA-256: 6785197cd543d48e3eb86ba7450497353974464c588d4a6d9424752a0f2fce65
postgresql-docs-8.1.23-4.el5_8.s390x.rpm
File outdated by:  RHSA-2014:0249
    MD5: 59b5466ae44ffb5c433afcb13fb5260a
SHA-256: 3ad4bb1c4699d02a128dc212b756b53bd5f67fd9eef369f95b27040bfbf0a66f
postgresql-libs-8.1.23-4.el5_8.s390.rpm
File outdated by:  RHSA-2014:0249
    MD5: 498a5b4d41533191b93bb4cdb79b8cf5
SHA-256: a69de7dc36433f192d5ac26be8bf98130320b88b885e13eab8b6eeb59fb02c67
postgresql-libs-8.1.23-4.el5_8.s390x.rpm
File outdated by:  RHSA-2014:0249
    MD5: c76bb6063e5967e22b8f4fc7bdd1c152
SHA-256: f68d147b1012e68203becd2fcfb037050f206916fdafecf8c2d1d3a80b51f9c1
postgresql-pl-8.1.23-4.el5_8.s390x.rpm
File outdated by:  RHSA-2014:0249
    MD5: d3638bba3c366695badeab6d56ce2025
SHA-256: 263465deb649afe9ef8fc03ef9ad8f27c22e7add1132bfb94ed5044843300aa7
postgresql-python-8.1.23-4.el5_8.s390x.rpm
File outdated by:  RHSA-2014:0249
    MD5: ea639deae53057569a97a8d367aa81aa
SHA-256: f5e6e188867a8631afe30934162c38c912a9ec41ba4bf3666a3d6b4e59fff5ba
postgresql-server-8.1.23-4.el5_8.s390x.rpm
File outdated by:  RHSA-2014:0249
    MD5: 4ae9cb1e0db3d33f005d09d2f8b274f1
SHA-256: a42fd30d44a4ca695448e636cf2d20ebaa6c69979ccdb2b690c67618d52306b7
postgresql-tcl-8.1.23-4.el5_8.s390x.rpm
File outdated by:  RHSA-2014:0249
    MD5: 6b1f6fd5c338bade847649762d685ce9
SHA-256: ac50800d41986c9d1574c1da96452d996986c4ce67d58115d9f974151856efb9
postgresql-test-8.1.23-4.el5_8.s390x.rpm
File outdated by:  RHSA-2014:0249
    MD5: 8676adfca00f35e5d6e99001e4feb972
SHA-256: 5ebf62a91ea39b46dd470660a685449ab4944ccd79b50fa53933f988094bf0ac
 
x86_64:
postgresql-8.1.23-4.el5_8.x86_64.rpm
File outdated by:  RHSA-2014:0249
    MD5: 0b35c63e2de64a3912531c0ec99df932
SHA-256: ef96e73dbb92662a8663aef61459066d6328dede2d74e2c40e6cf4abef80bc27
postgresql-contrib-8.1.23-4.el5_8.x86_64.rpm
File outdated by:  RHSA-2014:0249
    MD5: 3c101503d6dc5a0d74296126c990c640
SHA-256: 2b19cdc0828e8759ed9070b481c58fe427b540fdc69c9710ddae0ff119830869
postgresql-debuginfo-8.1.23-4.el5_8.i386.rpm
File outdated by:  RHSA-2014:0249
    MD5: 1389ad5eda4e48fdff28c54433dd85d2
SHA-256: 8545c415706301d4c33558e644c5d84898096eb5d38db6a47af249ac3285d28f
postgresql-debuginfo-8.1.23-4.el5_8.x86_64.rpm
File outdated by:  RHSA-2014:0249
    MD5: 9bf8f6fa0a788a33b7df0a92c8e62d7e
SHA-256: ee0850cf49b0cab3bbbfe996cf91c34ffff83a80eb3b4e38b5b9083d05edeece
postgresql-devel-8.1.23-4.el5_8.i386.rpm
File outdated by:  RHSA-2014:0249
    MD5: 82bbd49cacf7cd06059e18960c2c70fa
SHA-256: 3861bb0ba9781763e3ea7cba87eb2ee31485acec862cd9fbf9e7f4f1f8fdd856
postgresql-devel-8.1.23-4.el5_8.x86_64.rpm
File outdated by:  RHSA-2014:0249
    MD5: 2cb691c088e62633ceab6ad131574514
SHA-256: cf160d2f8d8286042452eb9465e61e806745ca0b694ab15851d0f6f0b0f1e62a
postgresql-docs-8.1.23-4.el5_8.x86_64.rpm
File outdated by:  RHSA-2014:0249
    MD5: ef0e9856524c9b91daf4a203e897bb2b
SHA-256: 7e6bfe8a7a79a9d35b94afbc4f01b45a4b8680428229ab8975580ce997461f09
postgresql-libs-8.1.23-4.el5_8.i386.rpm
File outdated by:  RHSA-2014:0249
    MD5: 8c4080bc18d35d32792786ad004202ab
SHA-256: ca00fd540d2398fdbdde99d3ddea8b4421028847f5875dea7de3cfa16c625450
postgresql-libs-8.1.23-4.el5_8.x86_64.rpm
File outdated by:  RHSA-2014:0249
    MD5: ac105f43b427b026fa0fb12f7e6ab4a0
SHA-256: 2cd2052d49cd643e364dfce102c1e63b2e4f467d976d46fae723e3568c0f2c32
postgresql-pl-8.1.23-4.el5_8.x86_64.rpm
File outdated by:  RHSA-2014:0249
    MD5: 331bf511441f4984a65196b96e28dec9
SHA-256: 01deb3651624f021db8414279ddc45e212580a4f68401c5b7e22d4f350f59cea
postgresql-python-8.1.23-4.el5_8.x86_64.rpm
File outdated by:  RHSA-2014:0249
    MD5: 963a5eadf43cf106ed5f274516010548
SHA-256: 1667055f1f644c64f42465938ee935df143274d094ad98ead2e2fe2dc15bb82f
postgresql-server-8.1.23-4.el5_8.x86_64.rpm
File outdated by:  RHSA-2014:0249
    MD5: e68f80314f313c0436ecf68a942f90ef
SHA-256: 2154338dbe5cae78343ed77bbf614ce47696a9f8c16523104f20c030e5d63a9b
postgresql-tcl-8.1.23-4.el5_8.x86_64.rpm
File outdated by:  RHSA-2014:0249
    MD5: 76f303ac920870d91e9437dd2052e27e
SHA-256: 027358c6e2ea30996ad8385e38f66b33d2e91b03de924028f9d711ae17c9885b
postgresql-test-8.1.23-4.el5_8.x86_64.rpm
File outdated by:  RHSA-2014:0249
    MD5: f05fa2b48d5e655f1d6f276a8cb0d6c2
SHA-256: b6bc4fcc91c3cedf09d1da43745f43db38d144d1cd65ad9ff1c5afc330d242d8
 
Red Hat Enterprise Linux Desktop (v. 5 client)

SRPMS:
postgresql-8.1.23-4.el5_8.src.rpm
File outdated by:  RHSA-2014:0249
    MD5: 83d99b771297e38f7b11c224867e32af
SHA-256: 30c900b9a80fa25f91d2d6faf29297cd0f38f399e8411c0385b23a5d91e41ccd
 
IA-32:
postgresql-8.1.23-4.el5_8.i386.rpm
File outdated by:  RHSA-2014:0249
    MD5: 7765db16d0ee556838f6af67ba6ba9b5
SHA-256: 669e91d0022b9e1ec7d446acd3f9369902a414540df626e05f84d142010b6e66
postgresql-contrib-8.1.23-4.el5_8.i386.rpm
File outdated by:  RHSA-2014:0249
    MD5: d0e728b6bdb30aabacd1f320bab0101a
SHA-256: 668df39895816f917410138494f27aae712d0d4b1151a5d6a087b0e1cc11b885
postgresql-debuginfo-8.1.23-4.el5_8.i386.rpm
File outdated by:  RHSA-2014:0249
    MD5: 1389ad5eda4e48fdff28c54433dd85d2
SHA-256: 8545c415706301d4c33558e644c5d84898096eb5d38db6a47af249ac3285d28f
postgresql-docs-8.1.23-4.el5_8.i386.rpm
File outdated by:  RHSA-2014:0249
    MD5: 9413476ee35dc79b89ba9c24d1c54b66
SHA-256: b26419a52669bfd09ca1014e878c2be5db0fac53729c286a12f51439090ea7cd
postgresql-libs-8.1.23-4.el5_8.i386.rpm
File outdated by:  RHSA-2014:0249
    MD5: 8c4080bc18d35d32792786ad004202ab
SHA-256: ca00fd540d2398fdbdde99d3ddea8b4421028847f5875dea7de3cfa16c625450
postgresql-python-8.1.23-4.el5_8.i386.rpm
File outdated by:  RHSA-2014:0249
    MD5: 81d2b15986e554dd453bfba8377cfc41
SHA-256: ed07739cf584757dbc78c384f49e088f83a7f0110cf94aeec70b470ea742bdfa
postgresql-tcl-8.1.23-4.el5_8.i386.rpm
File outdated by:  RHSA-2014:0249
    MD5: 2ec85bff9eeaf611a1e0a35f6ef83de8
SHA-256: a0aa46f27a02d0614a28bc5d89448afde6fe0f2b837c6998e71b261f32cdb8c0
 
x86_64:
postgresql-8.1.23-4.el5_8.x86_64.rpm
File outdated by:  RHSA-2014:0249
    MD5: 0b35c63e2de64a3912531c0ec99df932
SHA-256: ef96e73dbb92662a8663aef61459066d6328dede2d74e2c40e6cf4abef80bc27
postgresql-contrib-8.1.23-4.el5_8.x86_64.rpm
File outdated by:  RHSA-2014:0249
    MD5: 3c101503d6dc5a0d74296126c990c640
SHA-256: 2b19cdc0828e8759ed9070b481c58fe427b540fdc69c9710ddae0ff119830869
postgresql-debuginfo-8.1.23-4.el5_8.i386.rpm
File outdated by:  RHSA-2014:0249
    MD5: 1389ad5eda4e48fdff28c54433dd85d2
SHA-256: 8545c415706301d4c33558e644c5d84898096eb5d38db6a47af249ac3285d28f
postgresql-debuginfo-8.1.23-4.el5_8.x86_64.rpm
File outdated by:  RHSA-2014:0249
    MD5: 9bf8f6fa0a788a33b7df0a92c8e62d7e
SHA-256: ee0850cf49b0cab3bbbfe996cf91c34ffff83a80eb3b4e38b5b9083d05edeece
postgresql-docs-8.1.23-4.el5_8.x86_64.rpm
File outdated by:  RHSA-2014:0249
    MD5: ef0e9856524c9b91daf4a203e897bb2b
SHA-256: 7e6bfe8a7a79a9d35b94afbc4f01b45a4b8680428229ab8975580ce997461f09
postgresql-libs-8.1.23-4.el5_8.i386.rpm
File outdated by:  RHSA-2014:0249
    MD5: 8c4080bc18d35d32792786ad004202ab
SHA-256: ca00fd540d2398fdbdde99d3ddea8b4421028847f5875dea7de3cfa16c625450
postgresql-libs-8.1.23-4.el5_8.x86_64.rpm
File outdated by:  RHSA-2014:0249
    MD5: ac105f43b427b026fa0fb12f7e6ab4a0
SHA-256: 2cd2052d49cd643e364dfce102c1e63b2e4f467d976d46fae723e3568c0f2c32
postgresql-python-8.1.23-4.el5_8.x86_64.rpm
File outdated by:  RHSA-2014:0249
    MD5: 963a5eadf43cf106ed5f274516010548
SHA-256: 1667055f1f644c64f42465938ee935df143274d094ad98ead2e2fe2dc15bb82f
postgresql-tcl-8.1.23-4.el5_8.x86_64.rpm
File outdated by:  RHSA-2014:0249
    MD5: 76f303ac920870d91e9437dd2052e27e
SHA-256: 027358c6e2ea30996ad8385e38f66b33d2e91b03de924028f9d711ae17c9885b
 
(The unlinked packages above are only available from the Red Hat Network)

Bugs fixed (see bugzilla for more information)

797222 - CVE-2012-0866 postgresql: Absent permission checks on trigger function to be called when creating a trigger
797917 - CVE-2012-0868 postgresql: SQL injection due unsanitized newline characters in object names


References



These packages are GPG signed by Red Hat for security. Our key and details on how to verify the signature are available from:
https://www.redhat.com/security/team/key/#package

The Red Hat security contact is secalert@redhat.com. More contact details at http://www.redhat.com/security/team/contact/