Skip to navigation

Security Advisory Low: python security, bug fix, and enhancement update

Advisory: RHSA-2011:0027-1
Type: Security Advisory
Severity: Low
Issued on: 2011-01-13
Last updated on: 2011-01-13
Affected Products: RHEL Desktop Workstation (v. 5 client)
Red Hat Enterprise Linux (v. 5 server)
Red Hat Enterprise Linux Desktop (v. 5 client)
CVEs (cve.mitre.org): CVE-2008-5983
CVE-2009-4134
CVE-2010-1449
CVE-2010-1450
CVE-2010-1634
CVE-2010-2089

Details

Updated python packages that fix multiple security issues, several bugs,
and add two enhancements are now available for Red Hat Enterprise Linux 5.

The Red Hat Security Response Team has rated this update as having low
security impact. Common Vulnerability Scoring System (CVSS) base scores,
which give detailed severity ratings, are available for each vulnerability
from the CVE links in the References section.

Python is an interpreted, interactive, object-oriented programming
language.

It was found that many applications embedding the Python interpreter did
not specify a valid full path to the script or application when calling the
PySys_SetArgv API function, which could result in the addition of the
current working directory to the module search path (sys.path). A local
attacker able to trick a victim into running such an application in an
attacker-controlled directory could use this flaw to execute code with the
victim's privileges. This update adds the PySys_SetArgvEx API. Developers
can modify their applications to use this new API, which sets sys.argv
without modifying sys.path. (CVE-2008-5983)

Multiple flaws were found in the Python rgbimg module. If an application
written in Python was using the rgbimg module and loaded a
specially-crafted SGI image file, it could cause the application to crash
or, possibly, execute arbitrary code with the privileges of the user
running the application. (CVE-2009-4134, CVE-2010-1449, CVE-2010-1450)

Multiple flaws were found in the Python audioop module. Supplying certain
inputs could cause the audioop module to crash or, possibly, execute
arbitrary code. (CVE-2010-1634, CVE-2010-2089)

This update also fixes the following bugs:

* When starting a child process from the subprocess module in Python 2.4,
the parent process could leak file descriptors if an error occurred. This
update resolves the issue. (BZ#609017)

* Prior to Python 2.7, programs that used "ulimit -n" to enable
communication with large numbers of subprocesses could still monitor only
1024 file descriptors at a time, which caused an exception:

ValueError: filedescriptor out of range in select()

This was due to the subprocess module using the "select" system call. The
module now uses the "poll" system call, removing this limitation.
(BZ#609020)

* Prior to Python 2.5, the tarfile module failed to unpack tar files if the
path was longer than 100 characters. This update backports the tarfile
module from Python 2.5 and the issue no longer occurs. (BZ#263401)

* The email module incorrectly implemented the logic for obtaining
attachment file names: the get_filename() fallback for using the deprecated
"name" parameter of the "Content-Type" header erroneously used the
"Content-Disposition" header. This update backports a fix from Python 2.6,
which resolves this issue. (BZ#644147)

* Prior to version 2.5, Python's optimized memory allocator never released
memory back to the system. The memory usage of a long-running Python
process would resemble a "high-water mark". This update backports a fix
from Python 2.5a1, which frees unused arenas, and adds a non-standard
sys._debugmallocstats() function, which prints diagnostic information to
stderr. Finally, when running under Valgrind, the optimized allocator is
deactivated, to allow more convenient debugging of Python memory usage
issues. (BZ#569093)

* The urllib and urllib2 modules ignored the no_proxy variable, which could
lead to programs such as "yum" erroneously accessing a proxy server for
URLs covered by a "no_proxy" exclusion. This update backports fixes of
urllib and urllib2, which respect the "no_proxy" variable, which fixes
these issues. (BZ#549372)

As well, this update adds the following enhancements:

* This update introduces a new python-libs package, subsuming the majority
of the content of the core python package. This makes both 32-bit and
64-bit Python libraries available on PowerPC systems. (BZ#625372)

* The python-libs.i386 package is now available for 64-bit Itanium with the
32-bit Itanium compatibility mode. (BZ#644761)

All Python users are advised to upgrade to these updated packages, which
contain backported patches to correct these issues and add these
enhancements.


Solution

Before applying this update, make sure all previously-released errata
relevant to your system have been applied.

This update is available via the Red Hat Network. Details on how to
use the Red Hat Network to apply this update are available at
http://kbase.redhat.com/faq/docs/DOC-11259

Updated packages

RHEL Desktop Workstation (v. 5 client)

IA-32:
python-devel-2.4.3-43.el5.i386.rpm
File outdated by:  RHBA-2013:0045
    MD5: ed32c454d72a6b6b94ed5b054a974539
SHA-256: 22836bc2ceee60305782cbfc00874d384598654ba87ecc1cc90f49c7255216d4
 
x86_64:
python-devel-2.4.3-43.el5.i386.rpm
File outdated by:  RHBA-2013:0045
    MD5: ed32c454d72a6b6b94ed5b054a974539
SHA-256: 22836bc2ceee60305782cbfc00874d384598654ba87ecc1cc90f49c7255216d4
python-devel-2.4.3-43.el5.x86_64.rpm
File outdated by:  RHBA-2013:0045
    MD5: 6e65fb71dfd4b964f3b79fb4727da6fa
SHA-256: 59c3f34c411dfbbbbd61dd63e51bc31c7740ccffe29b045f70bdb9b5c73a239d
 
Red Hat Enterprise Linux (v. 5 server)

IA-32:
python-2.4.3-43.el5.i386.rpm
File outdated by:  RHBA-2013:0045
    MD5: 8f387d581da7cc18aa7ffacf63d9099c
SHA-256: 570f15a428f02d598ff13228586a5f9b029a224418111aeb29ba0e8de17a1573
python-devel-2.4.3-43.el5.i386.rpm
File outdated by:  RHBA-2013:0045
    MD5: ed32c454d72a6b6b94ed5b054a974539
SHA-256: 22836bc2ceee60305782cbfc00874d384598654ba87ecc1cc90f49c7255216d4
python-libs-2.4.3-43.el5.i386.rpm
File outdated by:  RHBA-2013:0045
    MD5: 6673febcdf49dd600f73dd56d8afca42
SHA-256: adf775a639ce1c97aa66e67df779baacdf13fe6c3c796fa87996e3e915fc613d
python-tools-2.4.3-43.el5.i386.rpm
File outdated by:  RHBA-2013:0045
    MD5: 7db8aff92f669512c8c2a2fd6f3496b5
SHA-256: 8027f8cf99ea5646f94d33046e6f6e32b99b5b10e5944d63d40f5bbbe20d69b0
tkinter-2.4.3-43.el5.i386.rpm
File outdated by:  RHBA-2013:0045
    MD5: 58f99b31a1f5da74133dfb7e8bbd2eb3
SHA-256: 4e2f4db9844e2d258d4e7a921b352c955a6d5e7336367138c7b0ac16148ba65f
 
IA-64:
python-2.4.3-43.el5.ia64.rpm
File outdated by:  RHBA-2013:0045
    MD5: f4b6047ae52af8019278db02de1438b1
SHA-256: 3172f802d8b3e5ed166fdd7d70e7daab9084f6afe1b9fc2aa736d02cd57acbe0
python-devel-2.4.3-43.el5.ia64.rpm
File outdated by:  RHBA-2013:0045
    MD5: c45865442fc34cf3988fa1052a34a1e5
SHA-256: 93696926782abaa779962bc378dcf9698ebf606e54b6d3a6f5dd798ed4ff00bf
python-libs-2.4.3-43.el5.i386.rpm
File outdated by:  RHBA-2013:0045
    MD5: 6673febcdf49dd600f73dd56d8afca42
SHA-256: adf775a639ce1c97aa66e67df779baacdf13fe6c3c796fa87996e3e915fc613d
python-libs-2.4.3-43.el5.ia64.rpm
File outdated by:  RHBA-2013:0045
    MD5: aa4384da48f3f9ccc4d438c99d0b3d69
SHA-256: 5f97414a3d7014c5acd8a103177261fdbc1fc31e69953c819c6cdd0de71f374e
python-tools-2.4.3-43.el5.ia64.rpm
File outdated by:  RHBA-2013:0045
    MD5: 8250f7dc69c49f50aff07608e611b4cb
SHA-256: 0031eee7e5154243377da204a5d7800ad3e789138aaebf347f0ba088310bf5d9
tkinter-2.4.3-43.el5.ia64.rpm
File outdated by:  RHBA-2013:0045
    MD5: ff0e7be85c5568fee5f90879b2b879cf
SHA-256: a652c1b32f71bc6e69a88123a47b7b4e0120eb8f7fe8fe990d834a371d546712
 
PPC:
python-2.4.3-43.el5.ppc.rpm
File outdated by:  RHBA-2013:0045
    MD5: 304e7284c41da5fb51d4844b73a4b03e
SHA-256: 1ea102213e50f57c21f3642cea2058dc390dbdd1a8a326f24989a200ede36cc7
python-devel-2.4.3-43.el5.ppc.rpm
File outdated by:  RHBA-2013:0045
    MD5: f93d5143b20df5f853711ef176df9b20
SHA-256: c4feaba7f782bd378c993e0927a97939ea0407b40abe3e9f4eefeff545ed0e26
python-devel-2.4.3-43.el5.ppc64.rpm
File outdated by:  RHBA-2013:0045
    MD5: 07964dbf983038eaf986e129b5df09e3
SHA-256: 9d97c8c0eb5b46befd2303334bc957d74ffa0caac811a4627788690bea188313
python-libs-2.4.3-43.el5.ppc.rpm
File outdated by:  RHBA-2013:0045
    MD5: af9eb3a6f44a4d22e5e23e39b8f31696
SHA-256: b696f90b327d3acfc1b7a2b9003424e78799249a662908c57a97a7f7a8a1df1c
python-libs-2.4.3-43.el5.ppc64.rpm
File outdated by:  RHBA-2013:0045
    MD5: 8904f19e1c83369068672d9afce9d9c5
SHA-256: 483984d96be1b5a7795698512388698a3149bab17e4ae9d6c4524a4677b08c87
python-tools-2.4.3-43.el5.ppc.rpm
File outdated by:  RHBA-2013:0045
    MD5: bdb952423a2399980fcaa9e9189bb31d
SHA-256: 77eddfe1e210c02ccce5cd90a5e61677ba7c35a6935b22f4e6bd1aac43036563
tkinter-2.4.3-43.el5.ppc.rpm
File outdated by:  RHBA-2013:0045
    MD5: eff469e47abc0a9d4b591a114e11a1ef
SHA-256: 19fc97ec5302a089f807216d99c1ab3204e966517e67a8d8bf1e9bd3391f38ec
 
s390x:
python-2.4.3-43.el5.s390x.rpm
File outdated by:  RHBA-2013:0045
    MD5: 4367378a24b6d61739866219c4c4d78c
SHA-256: 03df933fd53fc7e5b53b411fe66cfc550a10895a078df155173dcd98d48935a2
python-devel-2.4.3-43.el5.s390.rpm
File outdated by:  RHBA-2013:0045
    MD5: 0c34ab00a6573c38e6da7eedd2538d8e
SHA-256: 75f10d34226de676a099b70b34fdc59195071654082f60780176b16191c10377
python-devel-2.4.3-43.el5.s390x.rpm
File outdated by:  RHBA-2013:0045
    MD5: e82f0bcd7d8677b3568a30d11eb01c03
SHA-256: f1895bc15461a7e778e7cf98a3effe1b57e24b354a511564a977f7d8ec47b202
python-libs-2.4.3-43.el5.s390x.rpm
File outdated by:  RHBA-2013:0045
    MD5: 9339894b47ec201dda363fe65338b00a
SHA-256: 094dc1172be48a7075060222519d7ccae62e995860bb16976e2bc38f72d7ef61
python-tools-2.4.3-43.el5.s390x.rpm
File outdated by:  RHBA-2013:0045
    MD5: a2eb6c961a32004212aa804903de012a
SHA-256: e18bb4eff2787155ae3a7d53b6b721a62abc7323a13abdc25f2fbf3fb00c972d
tkinter-2.4.3-43.el5.s390x.rpm
File outdated by:  RHBA-2013:0045
    MD5: c1a62505f8f2f99a09fd3c0bc23d0f8c
SHA-256: f706ae4051f38217cc526b94c36ac420f5ee16fdfb99be414ac2fed75001662b
 
x86_64:
python-2.4.3-43.el5.x86_64.rpm
File outdated by:  RHBA-2013:0045
    MD5: dd0877dba2c88e8b521a76e8f2427e46
SHA-256: d13efad156565d8c59e7c37f4e608a8b1c210dd6b9d8db6723a1e3210f80731e
python-devel-2.4.3-43.el5.i386.rpm
File outdated by:  RHBA-2013:0045
    MD5: ed32c454d72a6b6b94ed5b054a974539
SHA-256: 22836bc2ceee60305782cbfc00874d384598654ba87ecc1cc90f49c7255216d4
python-devel-2.4.3-43.el5.x86_64.rpm
File outdated by:  RHBA-2013:0045
    MD5: 6e65fb71dfd4b964f3b79fb4727da6fa
SHA-256: 59c3f34c411dfbbbbd61dd63e51bc31c7740ccffe29b045f70bdb9b5c73a239d
python-libs-2.4.3-43.el5.x86_64.rpm
File outdated by:  RHBA-2013:0045
    MD5: 241f582d14e6b829515c41ec0ef86aab
SHA-256: 2cde5807b521c6d5d8ae67dc06e86bd8809b61d3e70cc138eda9b864e83e4cb8
python-tools-2.4.3-43.el5.x86_64.rpm
File outdated by:  RHBA-2013:0045
    MD5: 528d036cf50578392bd1ed7ebde51182
SHA-256: ff29147e60eb588f0da2ea21c5d870e63b41076de53531277898e47ac1d292dd
tkinter-2.4.3-43.el5.x86_64.rpm
File outdated by:  RHBA-2013:0045
    MD5: dc30c22ce63cef82cf1e13bd4aae8d58
SHA-256: 69a71a6692ef44e0420395768cf0832581673694d291f33ce7d0108ec04321a4
 
Red Hat Enterprise Linux Desktop (v. 5 client)

IA-32:
python-2.4.3-43.el5.i386.rpm
File outdated by:  RHBA-2013:0045
    MD5: 8f387d581da7cc18aa7ffacf63d9099c
SHA-256: 570f15a428f02d598ff13228586a5f9b029a224418111aeb29ba0e8de17a1573
python-libs-2.4.3-43.el5.i386.rpm
File outdated by:  RHBA-2013:0045
    MD5: 6673febcdf49dd600f73dd56d8afca42
SHA-256: adf775a639ce1c97aa66e67df779baacdf13fe6c3c796fa87996e3e915fc613d
python-tools-2.4.3-43.el5.i386.rpm
File outdated by:  RHBA-2013:0045
    MD5: 7db8aff92f669512c8c2a2fd6f3496b5
SHA-256: 8027f8cf99ea5646f94d33046e6f6e32b99b5b10e5944d63d40f5bbbe20d69b0
tkinter-2.4.3-43.el5.i386.rpm
File outdated by:  RHBA-2013:0045
    MD5: 58f99b31a1f5da74133dfb7e8bbd2eb3
SHA-256: 4e2f4db9844e2d258d4e7a921b352c955a6d5e7336367138c7b0ac16148ba65f
 
x86_64:
python-2.4.3-43.el5.x86_64.rpm
File outdated by:  RHBA-2013:0045
    MD5: dd0877dba2c88e8b521a76e8f2427e46
SHA-256: d13efad156565d8c59e7c37f4e608a8b1c210dd6b9d8db6723a1e3210f80731e
python-libs-2.4.3-43.el5.x86_64.rpm
File outdated by:  RHBA-2013:0045
    MD5: 241f582d14e6b829515c41ec0ef86aab
SHA-256: 2cde5807b521c6d5d8ae67dc06e86bd8809b61d3e70cc138eda9b864e83e4cb8
python-tools-2.4.3-43.el5.x86_64.rpm
File outdated by:  RHBA-2013:0045
    MD5: 528d036cf50578392bd1ed7ebde51182
SHA-256: ff29147e60eb588f0da2ea21c5d870e63b41076de53531277898e47ac1d292dd
tkinter-2.4.3-43.el5.x86_64.rpm
File outdated by:  RHBA-2013:0045
    MD5: dc30c22ce63cef82cf1e13bd4aae8d58
SHA-256: 69a71a6692ef44e0420395768cf0832581673694d291f33ce7d0108ec04321a4
 
(The unlinked packages above are only available from the Red Hat Network)

Bugs fixed (see bugzilla for more information)

482814 - CVE-2008-5983 python: untrusted python modules search path
541698 - CVE-2009-4134 CVE-2010-1449 CVE-2010-1450 python: rgbimg: multiple security issues
569093 - Python 2.4's arena allocator does not release memory back to the system, leading to "high-water mark" memory usage
590690 - CVE-2010-1634 python: audioop: incorrect integer overflow checks
598197 - CVE-2010-2089 Python: Memory corruption in audioop module
609017 - subprocess leaves open fds on construction error
609020 - subprocess fails in select when descriptors are large
625372 - split python-libs subpackage
644147 - Patch for get_filename in email.message when content-disposition is missing
644761 - python-libs conflict on ia64 compatlayer


References



These packages are GPG signed by Red Hat for security. Our key and details on how to verify the signature are available from:
https://www.redhat.com/security/team/key/#package

The Red Hat security contact is secalert@redhat.com. More contact details at http://www.redhat.com/security/team/contact/