Skip to navigation

Security Advisory gnutls security update

Advisory: RHSA-2006:0680-4
Type: Security Advisory
Severity: Important
Issued on: 2006-09-14
Last updated on: 2006-09-14
Affected Products: Red Hat Desktop (v. 4)
Red Hat Enterprise Linux AS (v. 4)
Red Hat Enterprise Linux ES (v. 4)
Red Hat Enterprise Linux WS (v. 4)
CVEs (cve.mitre.org): CVE-2006-4790

Details

Updated gnutls packages that fix a security issue are now available for Red
Hat Enterprise Linux 4.

This update has been rated as having important security impact by the Red
Hat Security Response Team.

The GnuTLS Library provides support for cryptographic algorithms and
protocols such as TLS. GnuTLS includes libtasn1, a library developed for
ASN.1 structures management that includes DER encoding and decoding.

Daniel Bleichenbacher recently described an attack on PKCS #1 v1.5
signatures. Where an RSA key with exponent 3 is used it may be possible for
an attacker to forge a PKCS #1 v1.5 signature that would be incorrectly
verified by implementations that do not check for excess data in the RSA
exponentiation result of the signature.

The core GnuTLS team discovered that GnuTLS is vulnerable to a variant of
the Bleichenbacker attack. This issue affects applications that use GnuTLS
to verify X.509 certificates as well as other uses of PKCS #1 v1.5.
(CVE-2006-4790)

In Red Hat Enterprise Linux 4, the GnuTLS library is only used by the
Evolution client when connecting to an Exchange server or when publishing
calendar information to a WebDAV server.

Users are advised to upgrade to these updated packages, which contain a
backported patch from the GnuTLS maintainers to correct this issue.


Solution

Before applying this update, make sure all previously released errata
relevant to your system have been applied.

This update is available via Red Hat Network. To use Red Hat Network,
launch the Red Hat Update Agent with the following command:

up2date

This will start an interactive process that will result in the appropriate
RPMs being upgraded on your system.

Updated packages

Red Hat Desktop (v. 4)

SRPMS:
gnutls-1.0.20-3.2.3.src.rpm
File outdated by:  RHSA-2010:0167
    MD5: 60106ff0a4fcc6bdfab8d262c1157469
 
IA-32:
gnutls-1.0.20-3.2.3.i386.rpm
File outdated by:  RHSA-2010:0167
    MD5: f749e542a24f251e6dc2603c9cce1402
gnutls-devel-1.0.20-3.2.3.i386.rpm
File outdated by:  RHSA-2010:0167
    MD5: 60cb9b56ffab6fc8ec9df1f53c82da51
 
x86_64:
gnutls-1.0.20-3.2.3.i386.rpm
File outdated by:  RHSA-2010:0167
    MD5: f749e542a24f251e6dc2603c9cce1402
gnutls-1.0.20-3.2.3.x86_64.rpm
File outdated by:  RHSA-2010:0167
    MD5: 9f3f2b568ba75803f9d7b75385310877
gnutls-devel-1.0.20-3.2.3.x86_64.rpm
File outdated by:  RHSA-2010:0167
    MD5: 6917afed0d2c314879b52ce4138b47fc
 
Red Hat Enterprise Linux AS (v. 4)

SRPMS:
gnutls-1.0.20-3.2.3.src.rpm
File outdated by:  RHSA-2010:0167
    MD5: 60106ff0a4fcc6bdfab8d262c1157469
 
IA-32:
gnutls-1.0.20-3.2.3.i386.rpm
File outdated by:  RHSA-2010:0167
    MD5: f749e542a24f251e6dc2603c9cce1402
gnutls-devel-1.0.20-3.2.3.i386.rpm
File outdated by:  RHSA-2010:0167
    MD5: 60cb9b56ffab6fc8ec9df1f53c82da51
 
IA-64:
gnutls-1.0.20-3.2.3.i386.rpm
File outdated by:  RHSA-2010:0167
    MD5: f749e542a24f251e6dc2603c9cce1402
gnutls-1.0.20-3.2.3.ia64.rpm
File outdated by:  RHSA-2010:0167
    MD5: 84cec28ca548482b2409eba04bc5cc2a
gnutls-devel-1.0.20-3.2.3.ia64.rpm
File outdated by:  RHSA-2010:0167
    MD5: fd378955aa68beb8b695f54a5b96e32a
 
PPC:
gnutls-1.0.20-3.2.3.ppc.rpm
File outdated by:  RHSA-2010:0167
    MD5: 5fe6d74ce6a3cba718f73727c15da477
gnutls-1.0.20-3.2.3.ppc64.rpm
File outdated by:  RHSA-2010:0167
    MD5: d80d9c580e4f9fb2618d507ebcd04cd4
gnutls-devel-1.0.20-3.2.3.ppc.rpm
File outdated by:  RHSA-2010:0167
    MD5: 38d15bbdbc6bfa0a42c59af2c4721800
 
s390:
gnutls-1.0.20-3.2.3.s390.rpm
File outdated by:  RHSA-2010:0167
    MD5: 0d492813efdd04c1857a070c3365b603
gnutls-devel-1.0.20-3.2.3.s390.rpm
File outdated by:  RHSA-2010:0167
    MD5: 48ee2a6d838bdb54a8965af9e2a4a2d5
 
s390x:
gnutls-1.0.20-3.2.3.s390.rpm
File outdated by:  RHSA-2010:0167
    MD5: 0d492813efdd04c1857a070c3365b603
gnutls-1.0.20-3.2.3.s390x.rpm
File outdated by:  RHSA-2010:0167
    MD5: b2c8606d60365818d5e80d32ea654679
gnutls-devel-1.0.20-3.2.3.s390x.rpm
File outdated by:  RHSA-2010:0167
    MD5: c9ea3c076c05e4c54ce9b85bfceb916d
 
x86_64:
gnutls-1.0.20-3.2.3.i386.rpm
File outdated by:  RHSA-2010:0167
    MD5: f749e542a24f251e6dc2603c9cce1402
gnutls-1.0.20-3.2.3.x86_64.rpm
File outdated by:  RHSA-2010:0167
    MD5: 9f3f2b568ba75803f9d7b75385310877
gnutls-devel-1.0.20-3.2.3.x86_64.rpm
File outdated by:  RHSA-2010:0167
    MD5: 6917afed0d2c314879b52ce4138b47fc
 
Red Hat Enterprise Linux ES (v. 4)

SRPMS:
gnutls-1.0.20-3.2.3.src.rpm
File outdated by:  RHSA-2010:0167
    MD5: 60106ff0a4fcc6bdfab8d262c1157469
 
IA-32:
gnutls-1.0.20-3.2.3.i386.rpm
File outdated by:  RHSA-2010:0167
    MD5: f749e542a24f251e6dc2603c9cce1402
gnutls-devel-1.0.20-3.2.3.i386.rpm
File outdated by:  RHSA-2010:0167
    MD5: 60cb9b56ffab6fc8ec9df1f53c82da51
 
IA-64:
gnutls-1.0.20-3.2.3.i386.rpm
File outdated by:  RHSA-2010:0167
    MD5: f749e542a24f251e6dc2603c9cce1402
gnutls-1.0.20-3.2.3.ia64.rpm
File outdated by:  RHSA-2010:0167
    MD5: 84cec28ca548482b2409eba04bc5cc2a
gnutls-devel-1.0.20-3.2.3.ia64.rpm
File outdated by:  RHSA-2010:0167
    MD5: fd378955aa68beb8b695f54a5b96e32a
 
x86_64:
gnutls-1.0.20-3.2.3.i386.rpm
File outdated by:  RHSA-2010:0167
    MD5: f749e542a24f251e6dc2603c9cce1402
gnutls-1.0.20-3.2.3.x86_64.rpm
File outdated by:  RHSA-2010:0167
    MD5: 9f3f2b568ba75803f9d7b75385310877
gnutls-devel-1.0.20-3.2.3.x86_64.rpm
File outdated by:  RHSA-2010:0167
    MD5: 6917afed0d2c314879b52ce4138b47fc
 
Red Hat Enterprise Linux WS (v. 4)

SRPMS:
gnutls-1.0.20-3.2.3.src.rpm
File outdated by:  RHSA-2010:0167
    MD5: 60106ff0a4fcc6bdfab8d262c1157469
 
IA-32:
gnutls-1.0.20-3.2.3.i386.rpm
File outdated by:  RHSA-2010:0167
    MD5: f749e542a24f251e6dc2603c9cce1402
gnutls-devel-1.0.20-3.2.3.i386.rpm
File outdated by:  RHSA-2010:0167
    MD5: 60cb9b56ffab6fc8ec9df1f53c82da51
 
IA-64:
gnutls-1.0.20-3.2.3.i386.rpm
File outdated by:  RHSA-2010:0167
    MD5: f749e542a24f251e6dc2603c9cce1402
gnutls-1.0.20-3.2.3.ia64.rpm
File outdated by:  RHSA-2010:0167
    MD5: 84cec28ca548482b2409eba04bc5cc2a
gnutls-devel-1.0.20-3.2.3.ia64.rpm
File outdated by:  RHSA-2010:0167
    MD5: fd378955aa68beb8b695f54a5b96e32a
 
x86_64:
gnutls-1.0.20-3.2.3.i386.rpm
File outdated by:  RHSA-2010:0167
    MD5: f749e542a24f251e6dc2603c9cce1402
gnutls-1.0.20-3.2.3.x86_64.rpm
File outdated by:  RHSA-2010:0167
    MD5: 9f3f2b568ba75803f9d7b75385310877
gnutls-devel-1.0.20-3.2.3.x86_64.rpm
File outdated by:  RHSA-2010:0167
    MD5: 6917afed0d2c314879b52ce4138b47fc
 
(The unlinked packages above are only available from the Red Hat Network)

Bugs fixed (see bugzilla for more information)

206411 - CVE-2006-4790 RSA forgery affects gnutls


References



These packages are GPG signed by Red Hat for security. Our key and details on how to verify the signature are available from:
https://www.redhat.com/security/team/key/#package

The Red Hat security contact is secalert@redhat.com. More contact details at http://www.redhat.com/security/team/contact/