Skip to navigation

Security Advisory squirrelmail security update

Advisory: RHSA-2006:0547-5
Type: Security Advisory
Severity: Moderate
Issued on: 2006-07-03
Last updated on: 2006-07-03
Affected Products: Red Hat Desktop (v. 3)
Red Hat Desktop (v. 4)
Red Hat Enterprise Linux AS (v. 3)
Red Hat Enterprise Linux AS (v. 4)
Red Hat Enterprise Linux ES (v. 3)
Red Hat Enterprise Linux ES (v. 4)
Red Hat Enterprise Linux WS (v. 3)
Red Hat Enterprise Linux WS (v. 4)
CVEs (cve.mitre.org): CVE-2006-2842

Details

An updated squirrelmail package that fixes a local file disclosure flaw is
now available.

This update has been rated as having moderate security impact by the Red
Hat Security Response Team.

SquirrelMail is a standards-based webmail package written in PHP4.

A local file disclosure flaw was found in the way SquirrelMail loads
plugins. In SquirrelMail 1.4.6 or earlier, if register_globals is on and
magic_quotes_gpc is off, it became possible for an unauthenticated remote
user to view the contents of arbitrary local files the web server has
read-access to. This configuration is neither default nor safe, and
configuring PHP with the register_globals set on is dangerous and not
recommended. (CVE-2006-2842)

Users of SquirrelMail should upgrade to this erratum package, which
contains a backported patch to correct this issue.


Solution

Before applying this update, make sure all previously released errata
relevant to your system have been applied.

This update is available via Red Hat Network. To use Red Hat Network,
launch the Red Hat Update Agent with the following command:

up2date

This will start an interactive process that will result in the appropriate
RPMs being upgraded on your system.

Updated packages

Red Hat Desktop (v. 3)

IA-32:
squirrelmail-1.4.6-7.el3.noarch.rpm
File outdated by:  RHSA-2009:1490
    MD5: 47b5a0299a8e709af48cc45e95c9591a
 
x86_64:
squirrelmail-1.4.6-7.el3.noarch.rpm
File outdated by:  RHSA-2009:1490
    MD5: 47b5a0299a8e709af48cc45e95c9591a
 
Red Hat Desktop (v. 4)

IA-32:
squirrelmail-1.4.6-7.el4.noarch.rpm
File outdated by:  RHSA-2012:0103
    MD5: fda560d56eea306af1bbbf2aff442e6a
 
x86_64:
squirrelmail-1.4.6-7.el4.noarch.rpm
File outdated by:  RHSA-2012:0103
    MD5: fda560d56eea306af1bbbf2aff442e6a
 
Red Hat Enterprise Linux AS (v. 3)

IA-32:
squirrelmail-1.4.6-7.el3.noarch.rpm
File outdated by:  RHSA-2009:1490
    MD5: 47b5a0299a8e709af48cc45e95c9591a
 
IA-64:
squirrelmail-1.4.6-7.el3.noarch.rpm
File outdated by:  RHSA-2009:1490
    MD5: 47b5a0299a8e709af48cc45e95c9591a
 
PPC:
squirrelmail-1.4.6-7.el3.noarch.rpm
File outdated by:  RHSA-2009:1490
    MD5: 47b5a0299a8e709af48cc45e95c9591a
 
s390:
squirrelmail-1.4.6-7.el3.noarch.rpm
File outdated by:  RHSA-2009:1490
    MD5: 47b5a0299a8e709af48cc45e95c9591a
 
s390x:
squirrelmail-1.4.6-7.el3.noarch.rpm
File outdated by:  RHSA-2009:1490
    MD5: 47b5a0299a8e709af48cc45e95c9591a
 
x86_64:
squirrelmail-1.4.6-7.el3.noarch.rpm
File outdated by:  RHSA-2009:1490
    MD5: 47b5a0299a8e709af48cc45e95c9591a
 
Red Hat Enterprise Linux AS (v. 4)

IA-32:
squirrelmail-1.4.6-7.el4.noarch.rpm
File outdated by:  RHSA-2012:0103
    MD5: fda560d56eea306af1bbbf2aff442e6a
 
IA-64:
squirrelmail-1.4.6-7.el4.noarch.rpm
File outdated by:  RHSA-2012:0103
    MD5: fda560d56eea306af1bbbf2aff442e6a
 
PPC:
squirrelmail-1.4.6-7.el4.noarch.rpm
File outdated by:  RHSA-2012:0103
    MD5: fda560d56eea306af1bbbf2aff442e6a
 
s390:
squirrelmail-1.4.6-7.el4.noarch.rpm
File outdated by:  RHSA-2012:0103
    MD5: fda560d56eea306af1bbbf2aff442e6a
 
s390x:
squirrelmail-1.4.6-7.el4.noarch.rpm
File outdated by:  RHSA-2012:0103
    MD5: fda560d56eea306af1bbbf2aff442e6a
 
x86_64:
squirrelmail-1.4.6-7.el4.noarch.rpm
File outdated by:  RHSA-2012:0103
    MD5: fda560d56eea306af1bbbf2aff442e6a
 
Red Hat Enterprise Linux ES (v. 3)

IA-32:
squirrelmail-1.4.6-7.el3.noarch.rpm
File outdated by:  RHSA-2009:1490
    MD5: 47b5a0299a8e709af48cc45e95c9591a
 
IA-64:
squirrelmail-1.4.6-7.el3.noarch.rpm
File outdated by:  RHSA-2009:1490
    MD5: 47b5a0299a8e709af48cc45e95c9591a
 
x86_64:
squirrelmail-1.4.6-7.el3.noarch.rpm
File outdated by:  RHSA-2009:1490
    MD5: 47b5a0299a8e709af48cc45e95c9591a
 
Red Hat Enterprise Linux ES (v. 4)

IA-32:
squirrelmail-1.4.6-7.el4.noarch.rpm
File outdated by:  RHSA-2012:0103
    MD5: fda560d56eea306af1bbbf2aff442e6a
 
IA-64:
squirrelmail-1.4.6-7.el4.noarch.rpm
File outdated by:  RHSA-2012:0103
    MD5: fda560d56eea306af1bbbf2aff442e6a
 
x86_64:
squirrelmail-1.4.6-7.el4.noarch.rpm
File outdated by:  RHSA-2012:0103
    MD5: fda560d56eea306af1bbbf2aff442e6a
 
Red Hat Enterprise Linux WS (v. 3)

IA-32:
squirrelmail-1.4.6-7.el3.noarch.rpm
File outdated by:  RHSA-2009:1490
    MD5: 47b5a0299a8e709af48cc45e95c9591a
 
IA-64:
squirrelmail-1.4.6-7.el3.noarch.rpm
File outdated by:  RHSA-2009:1490
    MD5: 47b5a0299a8e709af48cc45e95c9591a
 
x86_64:
squirrelmail-1.4.6-7.el3.noarch.rpm
File outdated by:  RHSA-2009:1490
    MD5: 47b5a0299a8e709af48cc45e95c9591a
 
Red Hat Enterprise Linux WS (v. 4)

IA-32:
squirrelmail-1.4.6-7.el4.noarch.rpm
File outdated by:  RHSA-2012:0103
    MD5: fda560d56eea306af1bbbf2aff442e6a
 
IA-64:
squirrelmail-1.4.6-7.el4.noarch.rpm
File outdated by:  RHSA-2012:0103
    MD5: fda560d56eea306af1bbbf2aff442e6a
 
x86_64:
squirrelmail-1.4.6-7.el4.noarch.rpm
File outdated by:  RHSA-2012:0103
    MD5: fda560d56eea306af1bbbf2aff442e6a
 
(The unlinked packages above are only available from the Red Hat Network)

Bugs fixed (see bugzilla for more information)

194283 - CVE-2006-2842 Squirrelmail file inclusion


References



These packages are GPG signed by Red Hat for security. Our key and details on how to verify the signature are available from:
https://www.redhat.com/security/team/key/#package

The Red Hat security contact is secalert@redhat.com. More contact details at http://www.redhat.com/security/team/contact/