Skip to navigation

Security Advisory mod_ssl security update

Advisory: RHSA-2005:773-3
Type: Security Advisory
Severity: Important
Issued on: 2005-09-15
Last updated on: 2005-09-15
Affected Products: Red Hat Enterprise Linux AS (v. 2.1)
Red Hat Enterprise Linux ES (v. 2.1)
Red Hat Enterprise Linux WS (v. 2.1)
Red Hat Linux Advanced Workstation 2.1 for the Itanium Processor
CVEs (cve.mitre.org): CVE-2005-2700

Details

An updated mod_ssl package for Apache that corrects a security issue is now
available.

This update has been rated as having important security impact by the Red
Hat Security Response Team.

The mod_ssl module provides strong cryptography for the Apache Web
server via the Secure Sockets Layer (SSL) and Transport Layer Security
(TLS) protocols.

A flaw was discovered in mod_ssl's handling of the "SSLVerifyClient"
directive. This flaw occurs if a virtual host is configured
using "SSLVerifyClient optional" and a directive "SSLVerifyClient
required" is set for a specific location. For servers configured in this
fashion, an attacker may be able to access resources that should otherwise
be protected, by not supplying a client certificate when connecting. The
Common Vulnerabilities and Exposures project assigned the name
CAN-2005-2700 to this issue.

Users of mod_ssl should upgrade to this updated package, which contains a
backported patch to correct this issue.


Solution

Before applying this update, make sure all previously released errata
relevant to your system have been applied.

This update is available via Red Hat Network. To use Red Hat Network,
launch the Red Hat Update Agent with the following command:

up2date

This will start an interactive process that will result in the appropriate
RPMs being upgraded on your system.

Updated packages

Red Hat Enterprise Linux AS (v. 2.1)

SRPMS:
ftp://updates.redhat.com/rhn/repository/NULL/mod_ssl/2.8.12-8/SRPMS/mod_ssl-2.8.12-8.src.rpm
Missing file
    MD5: 70c9491a26f4192159f0874a415f32f4
 
IA-32:
ftp://updates.redhat.com/rhn/repository/NULL/mod_ssl/2.8.12-8/i386/mod_ssl-2.8.12-8.i386.rpm
Missing file
    MD5: a8b75736c811bd68b755505e156e4904
 
IA-64:
ftp://updates.redhat.com/rhn/repository/NULL/mod_ssl/2.8.12-8/ia64/mod_ssl-2.8.12-8.ia64.rpm
Missing file
    MD5: b24dc850c203e5c354773b07a6c19a5a
 
Red Hat Enterprise Linux ES (v. 2.1)

SRPMS:
ftp://updates.redhat.com/rhn/repository/NULL/mod_ssl/2.8.12-8/SRPMS/mod_ssl-2.8.12-8.src.rpm
Missing file
    MD5: 70c9491a26f4192159f0874a415f32f4
 
IA-32:
ftp://updates.redhat.com/rhn/repository/NULL/mod_ssl/2.8.12-8/i386/mod_ssl-2.8.12-8.i386.rpm
Missing file
    MD5: a8b75736c811bd68b755505e156e4904
 
Red Hat Enterprise Linux WS (v. 2.1)

SRPMS:
ftp://updates.redhat.com/rhn/repository/NULL/mod_ssl/2.8.12-8/SRPMS/mod_ssl-2.8.12-8.src.rpm
Missing file
    MD5: 70c9491a26f4192159f0874a415f32f4
 
IA-32:
ftp://updates.redhat.com/rhn/repository/NULL/mod_ssl/2.8.12-8/i386/mod_ssl-2.8.12-8.i386.rpm
Missing file
    MD5: a8b75736c811bd68b755505e156e4904
 
Red Hat Linux Advanced Workstation 2.1 for the Itanium Processor

SRPMS:
ftp://updates.redhat.com/rhn/repository/NULL/mod_ssl/2.8.12-8/SRPMS/mod_ssl-2.8.12-8.src.rpm
Missing file
    MD5: 70c9491a26f4192159f0874a415f32f4
 
IA-64:
ftp://updates.redhat.com/rhn/repository/NULL/mod_ssl/2.8.12-8/ia64/mod_ssl-2.8.12-8.ia64.rpm
Missing file
    MD5: b24dc850c203e5c354773b07a6c19a5a
 

Bugs fixed (see bugzilla for more information)

167195 - CAN-2005-2700 SSLVerifyClient flaw


References



These packages are GPG signed by Red Hat for security. Our key and details on how to verify the signature are available from:
https://www.redhat.com/security/team/key/#package

The Red Hat security contact is secalert@redhat.com. More contact details at http://www.redhat.com/security/team/contact/