Skip to navigation

Security Advisory vim security update

Advisory: RHSA-2005:745-10
Type: Security Advisory
Severity: Low
Issued on: 2005-08-22
Last updated on: 2005-08-22
Affected Products: Red Hat Desktop (v. 3)
Red Hat Desktop (v. 4)
Red Hat Enterprise Linux AS (v. 2.1)
Red Hat Enterprise Linux AS (v. 3)
Red Hat Enterprise Linux AS (v. 4)
Red Hat Enterprise Linux ES (v. 2.1)
Red Hat Enterprise Linux ES (v. 3)
Red Hat Enterprise Linux ES (v. 4)
Red Hat Enterprise Linux WS (v. 2.1)
Red Hat Enterprise Linux WS (v. 3)
Red Hat Enterprise Linux WS (v. 4)
Red Hat Linux Advanced Workstation 2.1 for the Itanium Processor
CVEs (cve.mitre.org): CVE-2005-2368

Details

Updated vim packages that fix a security issue are now available.

This update has been rated as having low security impact by the Red Hat
Security Response Team.

VIM (VIsual editor iMproved) is a version of the vi editor.

A bug was found in the way VIM processes modelines. If a user with
modelines enabled opens a text file with a carefully crafted modeline,
arbitrary commands may be executed as the user running VIM. The Common
Vulnerabilities and Exposures project has assigned the name CAN-2005-2368
to this issue.

Users of VIM are advised to upgrade to these updated packages, which
resolve this issue.


Solution

Before applying this update, make sure all previously released errata
relevant to your system have been applied.

This update is available via Red Hat Network. To use Red Hat Network,
launch the Red Hat Update Agent with the following command:

up2date

This will start an interactive process that will result in the
appropriate RPMs being upgraded on your system.

Updated packages

Red Hat Desktop (v. 3)

SRPMS:
vim-6.3.046-0.30E.4.src.rpm
File outdated by:  RHSA-2008:0617
    MD5: b641243591379284dac93099ecf5d97d
 
IA-32:
vim-X11-6.3.046-0.30E.4.i386.rpm
File outdated by:  RHSA-2008:0617
    MD5: 62a9c4c046c7ca958b0b6904261dfb0e
vim-common-6.3.046-0.30E.4.i386.rpm
File outdated by:  RHSA-2008:0617
    MD5: 4696813b685d6afd35be1496978e7dbe
vim-enhanced-6.3.046-0.30E.4.i386.rpm
File outdated by:  RHSA-2008:0617
    MD5: 91335f3fe94955e8214df17e5c90083f
vim-minimal-6.3.046-0.30E.4.i386.rpm
File outdated by:  RHSA-2008:0617
    MD5: 44b31284599dea17971d04d69831f8fb
 
x86_64:
vim-X11-6.3.046-0.30E.4.x86_64.rpm
File outdated by:  RHSA-2008:0617
    MD5: f486ae74052fd72b3232e03c6d04892d
vim-common-6.3.046-0.30E.4.x86_64.rpm
File outdated by:  RHSA-2008:0617
    MD5: 0ba8572080b6337f494cea32402b8770
vim-enhanced-6.3.046-0.30E.4.x86_64.rpm
File outdated by:  RHSA-2008:0617
    MD5: 023d6e760c0ed69bb4d266ac9e95c5aa
vim-minimal-6.3.046-0.30E.4.x86_64.rpm
File outdated by:  RHSA-2008:0617
    MD5: dbda6a6fa0e3fb84b656d7bbedf589d9
 
Red Hat Desktop (v. 4)

SRPMS:
vim-6.3.046-0.40E.7.src.rpm
File outdated by:  RHBA-2009:0039
    MD5: 998b74b81555dd0de71aff94af5974bc
 
IA-32:
vim-X11-6.3.046-0.40E.7.i386.rpm
File outdated by:  RHBA-2009:0039
    MD5: 4b5da36806ad3797360adc3bdcdb228e
vim-common-6.3.046-0.40E.7.i386.rpm
File outdated by:  RHBA-2009:0039
    MD5: 6318e32a59fbb384b134bb7374c55b86
vim-enhanced-6.3.046-0.40E.7.i386.rpm
File outdated by:  RHBA-2009:0039
    MD5: 1f22c28d6d856ece02748167a9369f6d
vim-minimal-6.3.046-0.40E.7.i386.rpm
File outdated by:  RHBA-2009:0039
    MD5: 206c32710b4bc504c2be35b4b5ecf127
 
x86_64:
vim-X11-6.3.046-0.40E.7.x86_64.rpm
File outdated by:  RHBA-2009:0039
    MD5: ebd79be3473d17260d4facd9509a73e6
vim-common-6.3.046-0.40E.7.x86_64.rpm
File outdated by:  RHBA-2009:0039
    MD5: 7d2ae388363aaa07f110739706b13599
vim-enhanced-6.3.046-0.40E.7.x86_64.rpm
File outdated by:  RHBA-2009:0039
    MD5: c8057314de1c5e21bf34cf064b512964
vim-minimal-6.3.046-0.40E.7.x86_64.rpm
File outdated by:  RHBA-2009:0039
    MD5: 271b29bbb88eb5b453d9a70c3207338a
 
Red Hat Enterprise Linux AS (v. 2.1)

SRPMS:
vim-6.0-7.22.src.rpm
File outdated by:  RHSA-2008:0618
    MD5: 719114adb0832e14e2e88e6ff83a6ffe
 
IA-32:
vim-X11-6.0-7.22.i386.rpm
File outdated by:  RHSA-2008:0618
    MD5: 104bac9feab3d01ea8925c0481f0804f
vim-common-6.0-7.22.i386.rpm
File outdated by:  RHSA-2008:0618
    MD5: 99ee9e8ff887b9478b2fa8395edc2c6a
vim-enhanced-6.0-7.22.i386.rpm
File outdated by:  RHSA-2008:0618
    MD5: 27bfb5ae7f01b5d33100d0c71c1b18ce
vim-minimal-6.0-7.22.i386.rpm
File outdated by:  RHSA-2008:0618
    MD5: 16abf305958e4491998f58de45703b79
 
IA-64:
vim-X11-6.0-7.22.ia64.rpm
File outdated by:  RHSA-2008:0618
    MD5: a59088f23c02c6f9d52d4d630a38eda6
vim-common-6.0-7.22.ia64.rpm
File outdated by:  RHSA-2008:0618
    MD5: eec185f945687b4e40ab7bf531de6229
vim-enhanced-6.0-7.22.ia64.rpm
File outdated by:  RHSA-2008:0618
    MD5: bd90b0f4c9b28ed43ba28acd2f8a312f
vim-minimal-6.0-7.22.ia64.rpm
File outdated by:  RHSA-2008:0618
    MD5: 54578b4ca37bad8ff0a3be7a4b654d0c
 
Red Hat Enterprise Linux AS (v. 3)

SRPMS:
vim-6.3.046-0.30E.4.src.rpm
File outdated by:  RHSA-2008:0617
    MD5: b641243591379284dac93099ecf5d97d
 
IA-32:
vim-X11-6.3.046-0.30E.4.i386.rpm
File outdated by:  RHSA-2008:0617
    MD5: 62a9c4c046c7ca958b0b6904261dfb0e
vim-common-6.3.046-0.30E.4.i386.rpm
File outdated by:  RHSA-2008:0617
    MD5: 4696813b685d6afd35be1496978e7dbe
vim-enhanced-6.3.046-0.30E.4.i386.rpm
File outdated by:  RHSA-2008:0617
    MD5: 91335f3fe94955e8214df17e5c90083f
vim-minimal-6.3.046-0.30E.4.i386.rpm
File outdated by:  RHSA-2008:0617
    MD5: 44b31284599dea17971d04d69831f8fb
 
IA-64:
vim-X11-6.3.046-0.30E.4.ia64.rpm
File outdated by:  RHSA-2008:0617
    MD5: 6f9589a9d973060b71f642cf727e2f58
vim-common-6.3.046-0.30E.4.ia64.rpm
File outdated by:  RHSA-2008:0617
    MD5: 2ceba89647f26fdf8c7e893d8bfa7e8d
vim-enhanced-6.3.046-0.30E.4.ia64.rpm
File outdated by:  RHSA-2008:0617
    MD5: 73c566459e7e8de46cc6f19431a57b2c
vim-minimal-6.3.046-0.30E.4.ia64.rpm
File outdated by:  RHSA-2008:0617
    MD5: 8087a713fd9d3cdbf1074926519166d5
 
PPC:
vim-X11-6.3.046-0.30E.4.ppc.rpm
File outdated by:  RHSA-2008:0617
    MD5: 813ffad3b98f8c892b8c5903e4d27d2e
vim-common-6.3.046-0.30E.4.ppc.rpm
File outdated by:  RHSA-2008:0617
    MD5: 5c2ca151372e51d5a20b10cce19890bf
vim-enhanced-6.3.046-0.30E.4.ppc.rpm
File outdated by:  RHSA-2008:0617
    MD5: 221fe7968c756a0f00072421aaf30158
vim-minimal-6.3.046-0.30E.4.ppc.rpm
File outdated by:  RHSA-2008:0617
    MD5: fb5741c3b749ca84ecdb09d211d5898b
 
s390:
vim-X11-6.3.046-0.30E.4.s390.rpm
File outdated by:  RHSA-2008:0617
    MD5: 65d7f40c16974dd9072100f1f1f7d1d1
vim-common-6.3.046-0.30E.4.s390.rpm
File outdated by:  RHSA-2008:0617
    MD5: 2d48d6be2667ad5ec03e06700c945175
vim-enhanced-6.3.046-0.30E.4.s390.rpm
File outdated by:  RHSA-2008:0617
    MD5: ce22307cf11d8426505791ca6d233cb6
vim-minimal-6.3.046-0.30E.4.s390.rpm
File outdated by:  RHSA-2008:0617
    MD5: a4a0e10883721dc72b1febf19bd89c6c
 
s390x:
vim-X11-6.3.046-0.30E.4.s390x.rpm
File outdated by:  RHSA-2008:0617
    MD5: 5547916eb79a26e110fa4c684f4112e6
vim-common-6.3.046-0.30E.4.s390x.rpm
File outdated by:  RHSA-2008:0617
    MD5: b345578932db26bff59472a8bab31d4a
vim-enhanced-6.3.046-0.30E.4.s390x.rpm
File outdated by:  RHSA-2008:0617
    MD5: ddedf5962c2e1564b5a819e8d2e07b90
vim-minimal-6.3.046-0.30E.4.s390x.rpm
File outdated by:  RHSA-2008:0617
    MD5: b2a44ba8b8211147931a652e10780b15
 
x86_64:
vim-X11-6.3.046-0.30E.4.x86_64.rpm
File outdated by:  RHSA-2008:0617
    MD5: f486ae74052fd72b3232e03c6d04892d
vim-common-6.3.046-0.30E.4.x86_64.rpm
File outdated by:  RHSA-2008:0617
    MD5: 0ba8572080b6337f494cea32402b8770
vim-enhanced-6.3.046-0.30E.4.x86_64.rpm
File outdated by:  RHSA-2008:0617
    MD5: 023d6e760c0ed69bb4d266ac9e95c5aa
vim-minimal-6.3.046-0.30E.4.x86_64.rpm
File outdated by:  RHSA-2008:0617
    MD5: dbda6a6fa0e3fb84b656d7bbedf589d9
 
Red Hat Enterprise Linux AS (v. 4)

SRPMS:
vim-6.3.046-0.40E.7.src.rpm
File outdated by:  RHBA-2009:0039
    MD5: 998b74b81555dd0de71aff94af5974bc
 
IA-32:
vim-X11-6.3.046-0.40E.7.i386.rpm
File outdated by:  RHBA-2009:0039
    MD5: 4b5da36806ad3797360adc3bdcdb228e
vim-common-6.3.046-0.40E.7.i386.rpm
File outdated by:  RHBA-2009:0039
    MD5: 6318e32a59fbb384b134bb7374c55b86
vim-enhanced-6.3.046-0.40E.7.i386.rpm
File outdated by:  RHBA-2009:0039
    MD5: 1f22c28d6d856ece02748167a9369f6d
vim-minimal-6.3.046-0.40E.7.i386.rpm
File outdated by:  RHBA-2009:0039
    MD5: 206c32710b4bc504c2be35b4b5ecf127
 
IA-64:
vim-X11-6.3.046-0.40E.7.ia64.rpm
File outdated by:  RHBA-2009:0039
    MD5: ef7404bd22dbd423098bf698e6ecb26a
vim-common-6.3.046-0.40E.7.ia64.rpm
File outdated by:  RHBA-2009:0039
    MD5: ad363dd68e1b7a17124c9fb53366b4c2
vim-enhanced-6.3.046-0.40E.7.ia64.rpm
File outdated by:  RHBA-2009:0039
    MD5: f51bfd05a709cf238a8cc7ded20486cb
vim-minimal-6.3.046-0.40E.7.ia64.rpm
File outdated by:  RHBA-2009:0039
    MD5: 16d524482f33edb3330e1e7be7e2b5ac
 
PPC:
vim-X11-6.3.046-0.40E.7.ppc.rpm
File outdated by:  RHBA-2009:0039
    MD5: 5ad278b1e5491d8e8c972e9a77a58255
vim-common-6.3.046-0.40E.7.ppc.rpm
File outdated by:  RHBA-2009:0039
    MD5: 1db40dd090924c092f2de2e3a6feb92e
vim-enhanced-6.3.046-0.40E.7.ppc.rpm
File outdated by:  RHBA-2009:0039
    MD5: 68a488570856102b877df40c21d9533d
vim-minimal-6.3.046-0.40E.7.ppc.rpm
File outdated by:  RHBA-2009:0039
    MD5: 0100e370d117ee4f3519a0082be21797
 
s390:
vim-X11-6.3.046-0.40E.7.s390.rpm
File outdated by:  RHBA-2009:0039
    MD5: 71667bd231b7e487dfa358f6778a3e4b
vim-common-6.3.046-0.40E.7.s390.rpm
File outdated by:  RHBA-2009:0039
    MD5: a84d5604e9d2774ad021433a56194a94
vim-enhanced-6.3.046-0.40E.7.s390.rpm
File outdated by:  RHBA-2009:0039
    MD5: 9f71ff6c9a67e6274d9001852a3c8b19
vim-minimal-6.3.046-0.40E.7.s390.rpm
File outdated by:  RHBA-2009:0039
    MD5: 171d74ca135383894c1ed0beb01c8c1e
 
s390x:
vim-X11-6.3.046-0.40E.7.s390x.rpm
File outdated by:  RHBA-2009:0039
    MD5: fa609585aa9e1560d54b06aeefc9719a
vim-common-6.3.046-0.40E.7.s390x.rpm
File outdated by:  RHBA-2009:0039
    MD5: 4c76afa7473c9b84af1b4c02969fa931
vim-enhanced-6.3.046-0.40E.7.s390x.rpm
File outdated by:  RHBA-2009:0039
    MD5: 879bddaefa444fc0ae4fb1b44aa93869
vim-minimal-6.3.046-0.40E.7.s390x.rpm
File outdated by:  RHBA-2009:0039
    MD5: 51b8c7371ea60611350746b9e5ac68ea
 
x86_64:
vim-X11-6.3.046-0.40E.7.x86_64.rpm
File outdated by:  RHBA-2009:0039
    MD5: ebd79be3473d17260d4facd9509a73e6
vim-common-6.3.046-0.40E.7.x86_64.rpm
File outdated by:  RHBA-2009:0039
    MD5: 7d2ae388363aaa07f110739706b13599
vim-enhanced-6.3.046-0.40E.7.x86_64.rpm
File outdated by:  RHBA-2009:0039
    MD5: c8057314de1c5e21bf34cf064b512964
vim-minimal-6.3.046-0.40E.7.x86_64.rpm
File outdated by:  RHBA-2009:0039
    MD5: 271b29bbb88eb5b453d9a70c3207338a
 
Red Hat Enterprise Linux ES (v. 2.1)

SRPMS:
vim-6.0-7.22.src.rpm
File outdated by:  RHSA-2008:0618
    MD5: 719114adb0832e14e2e88e6ff83a6ffe
 
IA-32:
vim-X11-6.0-7.22.i386.rpm
File outdated by:  RHSA-2008:0618
    MD5: 104bac9feab3d01ea8925c0481f0804f
vim-common-6.0-7.22.i386.rpm
File outdated by:  RHSA-2008:0618
    MD5: 99ee9e8ff887b9478b2fa8395edc2c6a
vim-enhanced-6.0-7.22.i386.rpm
File outdated by:  RHSA-2008:0618
    MD5: 27bfb5ae7f01b5d33100d0c71c1b18ce
vim-minimal-6.0-7.22.i386.rpm
File outdated by:  RHSA-2008:0618
    MD5: 16abf305958e4491998f58de45703b79
 
Red Hat Enterprise Linux ES (v. 3)

SRPMS:
vim-6.3.046-0.30E.4.src.rpm
File outdated by:  RHSA-2008:0617
    MD5: b641243591379284dac93099ecf5d97d
 
IA-32:
vim-X11-6.3.046-0.30E.4.i386.rpm
File outdated by:  RHSA-2008:0617
    MD5: 62a9c4c046c7ca958b0b6904261dfb0e
vim-common-6.3.046-0.30E.4.i386.rpm
File outdated by:  RHSA-2008:0617
    MD5: 4696813b685d6afd35be1496978e7dbe
vim-enhanced-6.3.046-0.30E.4.i386.rpm
File outdated by:  RHSA-2008:0617
    MD5: 91335f3fe94955e8214df17e5c90083f
vim-minimal-6.3.046-0.30E.4.i386.rpm
File outdated by:  RHSA-2008:0617
    MD5: 44b31284599dea17971d04d69831f8fb
 
IA-64:
vim-X11-6.3.046-0.30E.4.ia64.rpm
File outdated by:  RHSA-2008:0617
    MD5: 6f9589a9d973060b71f642cf727e2f58
vim-common-6.3.046-0.30E.4.ia64.rpm
File outdated by:  RHSA-2008:0617
    MD5: 2ceba89647f26fdf8c7e893d8bfa7e8d
vim-enhanced-6.3.046-0.30E.4.ia64.rpm
File outdated by:  RHSA-2008:0617
    MD5: 73c566459e7e8de46cc6f19431a57b2c
vim-minimal-6.3.046-0.30E.4.ia64.rpm
File outdated by:  RHSA-2008:0617
    MD5: 8087a713fd9d3cdbf1074926519166d5
 
x86_64:
vim-X11-6.3.046-0.30E.4.x86_64.rpm
File outdated by:  RHSA-2008:0617
    MD5: f486ae74052fd72b3232e03c6d04892d
vim-common-6.3.046-0.30E.4.x86_64.rpm
File outdated by:  RHSA-2008:0617
    MD5: 0ba8572080b6337f494cea32402b8770
vim-enhanced-6.3.046-0.30E.4.x86_64.rpm
File outdated by:  RHSA-2008:0617
    MD5: 023d6e760c0ed69bb4d266ac9e95c5aa
vim-minimal-6.3.046-0.30E.4.x86_64.rpm
File outdated by:  RHSA-2008:0617
    MD5: dbda6a6fa0e3fb84b656d7bbedf589d9
 
Red Hat Enterprise Linux ES (v. 4)

SRPMS:
vim-6.3.046-0.40E.7.src.rpm
File outdated by:  RHBA-2009:0039
    MD5: 998b74b81555dd0de71aff94af5974bc
 
IA-32:
vim-X11-6.3.046-0.40E.7.i386.rpm
File outdated by:  RHBA-2009:0039
    MD5: 4b5da36806ad3797360adc3bdcdb228e
vim-common-6.3.046-0.40E.7.i386.rpm
File outdated by:  RHBA-2009:0039
    MD5: 6318e32a59fbb384b134bb7374c55b86
vim-enhanced-6.3.046-0.40E.7.i386.rpm
File outdated by:  RHBA-2009:0039
    MD5: 1f22c28d6d856ece02748167a9369f6d
vim-minimal-6.3.046-0.40E.7.i386.rpm
File outdated by:  RHBA-2009:0039
    MD5: 206c32710b4bc504c2be35b4b5ecf127
 
IA-64:
vim-X11-6.3.046-0.40E.7.ia64.rpm
File outdated by:  RHBA-2009:0039
    MD5: ef7404bd22dbd423098bf698e6ecb26a
vim-common-6.3.046-0.40E.7.ia64.rpm
File outdated by:  RHBA-2009:0039
    MD5: ad363dd68e1b7a17124c9fb53366b4c2
vim-enhanced-6.3.046-0.40E.7.ia64.rpm
File outdated by:  RHBA-2009:0039
    MD5: f51bfd05a709cf238a8cc7ded20486cb
vim-minimal-6.3.046-0.40E.7.ia64.rpm
File outdated by:  RHBA-2009:0039
    MD5: 16d524482f33edb3330e1e7be7e2b5ac
 
x86_64:
vim-X11-6.3.046-0.40E.7.x86_64.rpm
File outdated by:  RHBA-2009:0039
    MD5: ebd79be3473d17260d4facd9509a73e6
vim-common-6.3.046-0.40E.7.x86_64.rpm
File outdated by:  RHBA-2009:0039
    MD5: 7d2ae388363aaa07f110739706b13599
vim-enhanced-6.3.046-0.40E.7.x86_64.rpm
File outdated by:  RHBA-2009:0039
    MD5: c8057314de1c5e21bf34cf064b512964
vim-minimal-6.3.046-0.40E.7.x86_64.rpm
File outdated by:  RHBA-2009:0039
    MD5: 271b29bbb88eb5b453d9a70c3207338a
 
Red Hat Enterprise Linux WS (v. 2.1)

SRPMS:
vim-6.0-7.22.src.rpm
File outdated by:  RHSA-2008:0618
    MD5: 719114adb0832e14e2e88e6ff83a6ffe
 
IA-32:
vim-X11-6.0-7.22.i386.rpm
File outdated by:  RHSA-2008:0618
    MD5: 104bac9feab3d01ea8925c0481f0804f
vim-common-6.0-7.22.i386.rpm
File outdated by:  RHSA-2008:0618
    MD5: 99ee9e8ff887b9478b2fa8395edc2c6a
vim-enhanced-6.0-7.22.i386.rpm
File outdated by:  RHSA-2008:0618
    MD5: 27bfb5ae7f01b5d33100d0c71c1b18ce
vim-minimal-6.0-7.22.i386.rpm
File outdated by:  RHSA-2008:0618
    MD5: 16abf305958e4491998f58de45703b79
 
Red Hat Enterprise Linux WS (v. 3)

SRPMS:
vim-6.3.046-0.30E.4.src.rpm
File outdated by:  RHSA-2008:0617
    MD5: b641243591379284dac93099ecf5d97d
 
IA-32:
vim-X11-6.3.046-0.30E.4.i386.rpm
File outdated by:  RHSA-2008:0617
    MD5: 62a9c4c046c7ca958b0b6904261dfb0e
vim-common-6.3.046-0.30E.4.i386.rpm
File outdated by:  RHSA-2008:0617
    MD5: 4696813b685d6afd35be1496978e7dbe
vim-enhanced-6.3.046-0.30E.4.i386.rpm
File outdated by:  RHSA-2008:0617
    MD5: 91335f3fe94955e8214df17e5c90083f
vim-minimal-6.3.046-0.30E.4.i386.rpm
File outdated by:  RHSA-2008:0617
    MD5: 44b31284599dea17971d04d69831f8fb
 
IA-64:
vim-X11-6.3.046-0.30E.4.ia64.rpm
File outdated by:  RHSA-2008:0617
    MD5: 6f9589a9d973060b71f642cf727e2f58
vim-common-6.3.046-0.30E.4.ia64.rpm
File outdated by:  RHSA-2008:0617
    MD5: 2ceba89647f26fdf8c7e893d8bfa7e8d
vim-enhanced-6.3.046-0.30E.4.ia64.rpm
File outdated by:  RHSA-2008:0617
    MD5: 73c566459e7e8de46cc6f19431a57b2c
vim-minimal-6.3.046-0.30E.4.ia64.rpm
File outdated by:  RHSA-2008:0617
    MD5: 8087a713fd9d3cdbf1074926519166d5
 
x86_64:
vim-X11-6.3.046-0.30E.4.x86_64.rpm
File outdated by:  RHSA-2008:0617
    MD5: f486ae74052fd72b3232e03c6d04892d
vim-common-6.3.046-0.30E.4.x86_64.rpm
File outdated by:  RHSA-2008:0617
    MD5: 0ba8572080b6337f494cea32402b8770
vim-enhanced-6.3.046-0.30E.4.x86_64.rpm
File outdated by:  RHSA-2008:0617
    MD5: 023d6e760c0ed69bb4d266ac9e95c5aa
vim-minimal-6.3.046-0.30E.4.x86_64.rpm
File outdated by:  RHSA-2008:0617
    MD5: dbda6a6fa0e3fb84b656d7bbedf589d9
 
Red Hat Enterprise Linux WS (v. 4)

SRPMS:
vim-6.3.046-0.40E.7.src.rpm
File outdated by:  RHBA-2009:0039
    MD5: 998b74b81555dd0de71aff94af5974bc
 
IA-32:
vim-X11-6.3.046-0.40E.7.i386.rpm
File outdated by:  RHBA-2009:0039
    MD5: 4b5da36806ad3797360adc3bdcdb228e
vim-common-6.3.046-0.40E.7.i386.rpm
File outdated by:  RHBA-2009:0039
    MD5: 6318e32a59fbb384b134bb7374c55b86
vim-enhanced-6.3.046-0.40E.7.i386.rpm
File outdated by:  RHBA-2009:0039
    MD5: 1f22c28d6d856ece02748167a9369f6d
vim-minimal-6.3.046-0.40E.7.i386.rpm
File outdated by:  RHBA-2009:0039
    MD5: 206c32710b4bc504c2be35b4b5ecf127
 
IA-64:
vim-X11-6.3.046-0.40E.7.ia64.rpm
File outdated by:  RHBA-2009:0039
    MD5: ef7404bd22dbd423098bf698e6ecb26a
vim-common-6.3.046-0.40E.7.ia64.rpm
File outdated by:  RHBA-2009:0039
    MD5: ad363dd68e1b7a17124c9fb53366b4c2
vim-enhanced-6.3.046-0.40E.7.ia64.rpm
File outdated by:  RHBA-2009:0039
    MD5: f51bfd05a709cf238a8cc7ded20486cb
vim-minimal-6.3.046-0.40E.7.ia64.rpm
File outdated by:  RHBA-2009:0039
    MD5: 16d524482f33edb3330e1e7be7e2b5ac
 
x86_64:
vim-X11-6.3.046-0.40E.7.x86_64.rpm
File outdated by:  RHBA-2009:0039
    MD5: ebd79be3473d17260d4facd9509a73e6
vim-common-6.3.046-0.40E.7.x86_64.rpm
File outdated by:  RHBA-2009:0039
    MD5: 7d2ae388363aaa07f110739706b13599
vim-enhanced-6.3.046-0.40E.7.x86_64.rpm
File outdated by:  RHBA-2009:0039
    MD5: c8057314de1c5e21bf34cf064b512964
vim-minimal-6.3.046-0.40E.7.x86_64.rpm
File outdated by:  RHBA-2009:0039
    MD5: 271b29bbb88eb5b453d9a70c3207338a
 
Red Hat Linux Advanced Workstation 2.1 for the Itanium Processor

SRPMS:
vim-6.0-7.22.src.rpm
File outdated by:  RHSA-2008:0618
    MD5: 719114adb0832e14e2e88e6ff83a6ffe
 
IA-64:
vim-X11-6.0-7.22.ia64.rpm
File outdated by:  RHSA-2008:0618
    MD5: a59088f23c02c6f9d52d4d630a38eda6
vim-common-6.0-7.22.ia64.rpm
File outdated by:  RHSA-2008:0618
    MD5: eec185f945687b4e40ab7bf531de6229
vim-enhanced-6.0-7.22.ia64.rpm
File outdated by:  RHSA-2008:0618
    MD5: bd90b0f4c9b28ed43ba28acd2f8a312f
vim-minimal-6.0-7.22.ia64.rpm
File outdated by:  RHSA-2008:0618
    MD5: 54578b4ca37bad8ff0a3be7a4b654d0c
 
(The unlinked packages above are only available from the Red Hat Network)

Bugs fixed (see bugzilla for more information)

164279 - CAN-2005-2368 vim modeline arbitrary command execution


References


Keywords

modeline, security, vim


These packages are GPG signed by Red Hat for security. Our key and details on how to verify the signature are available from:
https://www.redhat.com/security/team/key/#package

The Red Hat security contact is secalert@redhat.com. More contact details at http://www.redhat.com/security/team/contact/