Skip to navigation

Security Advisory mailman security update

Advisory: RHSA-2005:235-05
Type: Security Advisory
Severity: Important
Issued on: 2005-03-21
Last updated on: 2005-03-21
Affected Products: Red Hat Desktop (v. 3)
Red Hat Desktop (v. 4)
Red Hat Enterprise Linux AS (v. 3)
Red Hat Enterprise Linux AS (v. 4)
Red Hat Enterprise Linux ES (v. 3)
Red Hat Enterprise Linux ES (v. 4)
Red Hat Enterprise Linux WS (v. 3)
Red Hat Enterprise Linux WS (v. 4)
CVEs (cve.mitre.org): CVE-2004-1177

Details

An updated mailman package that corrects a cross-site scripting flaw is now
available.

This update has been rated as having important security impact by the Red
Hat Security Response Team.

Mailman manages electronic mail discussion and e-newsletter lists.

A cross-site scripting (XSS) flaw in the driver script of mailman prior to
version 2.1.5 could allow remote attackers to execute scripts as other web
users. The Common Vulnerabilities and Exposures project (cve.mitre.org)
has assigned the name CAN-2004-1177 to this issue.

Users of mailman should update to this erratum package, which corrects this
issue by turning on STEALTH_MODE by default and using Utils.websafe() to
quote the html.


Solution

Before applying this update, make sure that all previously-released
errata relevant to your system have been applied. Use Red Hat
Network to download and update your packages. To launch the Red Hat
Update Agent, use the following command:

up2date

For information on how to install packages manually, refer to the
following Web page for the System Administration or Customization
guide specific to your system:

http://www.redhat.com/docs/manuals/enterprise/

Updated packages

Red Hat Desktop (v. 3)

IA-32:
mailman-2.1.5-25.rhel3.i386.rpm
File outdated by:  RHBA-2007:0464
    MD5: 6c052b1a07bfdec09756ee58be0e4c56
 
x86_64:
mailman-2.1.5-25.rhel3.x86_64.rpm
File outdated by:  RHBA-2007:0464
    MD5: 1a3ca7f170accc1a9747ef78b8ad0006
 
Red Hat Desktop (v. 4)

IA-32:
mailman-2.1.5-33.rhel4.i386.rpm
File outdated by:  RHSA-2011:0307
    MD5: 97e1cbd6ec4f6099def5ed95f072d603
 
x86_64:
mailman-2.1.5-33.rhel4.x86_64.rpm
File outdated by:  RHSA-2011:0307
    MD5: 97a3e1f38866b40d06b2226e0901fc45
 
Red Hat Enterprise Linux AS (v. 3)

IA-32:
mailman-2.1.5-25.rhel3.i386.rpm
File outdated by:  RHBA-2007:0464
    MD5: 6c052b1a07bfdec09756ee58be0e4c56
 
IA-64:
mailman-2.1.5-25.rhel3.ia64.rpm
File outdated by:  RHBA-2007:0464
    MD5: 41cbca1ff68fa89f87f6686aaf57f229
 
PPC:
mailman-2.1.5-25.rhel3.ppc.rpm
File outdated by:  RHBA-2007:0464
    MD5: d1b78c0297714110557d5e24af03b1e0
 
s390:
mailman-2.1.5-25.rhel3.s390.rpm
File outdated by:  RHBA-2007:0464
    MD5: 475bdfee1a9c0f1580d5c62c9fa0f71d
 
s390x:
mailman-2.1.5-25.rhel3.s390x.rpm
File outdated by:  RHBA-2007:0464
    MD5: f59fd25effa4d958730b1c778d47a4c6
 
x86_64:
mailman-2.1.5-25.rhel3.x86_64.rpm
File outdated by:  RHBA-2007:0464
    MD5: 1a3ca7f170accc1a9747ef78b8ad0006
 
Red Hat Enterprise Linux AS (v. 4)

IA-32:
mailman-2.1.5-33.rhel4.i386.rpm
File outdated by:  RHSA-2011:0307
    MD5: 97e1cbd6ec4f6099def5ed95f072d603
 
IA-64:
mailman-2.1.5-33.rhel4.ia64.rpm
File outdated by:  RHSA-2011:0307
    MD5: 0fde6fa6ab37f8ae0031e53d62615c8c
 
PPC:
mailman-2.1.5-33.rhel4.ppc.rpm
File outdated by:  RHSA-2011:0307
    MD5: 376ec413afbc6d85ab268bdbab811b79
 
s390:
mailman-2.1.5-33.rhel4.s390.rpm
File outdated by:  RHSA-2011:0307
    MD5: 79bda3c10f6204e47c36c8372956602a
 
s390x:
mailman-2.1.5-33.rhel4.s390x.rpm
File outdated by:  RHSA-2011:0307
    MD5: e1746fc732cbb29a0df14db5a7e88f0a
 
x86_64:
mailman-2.1.5-33.rhel4.x86_64.rpm
File outdated by:  RHSA-2011:0307
    MD5: 97a3e1f38866b40d06b2226e0901fc45
 
Red Hat Enterprise Linux ES (v. 3)

IA-32:
mailman-2.1.5-25.rhel3.i386.rpm
File outdated by:  RHBA-2007:0464
    MD5: 6c052b1a07bfdec09756ee58be0e4c56
 
IA-64:
mailman-2.1.5-25.rhel3.ia64.rpm
File outdated by:  RHBA-2007:0464
    MD5: 41cbca1ff68fa89f87f6686aaf57f229
 
x86_64:
mailman-2.1.5-25.rhel3.x86_64.rpm
File outdated by:  RHBA-2007:0464
    MD5: 1a3ca7f170accc1a9747ef78b8ad0006
 
Red Hat Enterprise Linux ES (v. 4)

IA-32:
mailman-2.1.5-33.rhel4.i386.rpm
File outdated by:  RHSA-2011:0307
    MD5: 97e1cbd6ec4f6099def5ed95f072d603
 
IA-64:
mailman-2.1.5-33.rhel4.ia64.rpm
File outdated by:  RHSA-2011:0307
    MD5: 0fde6fa6ab37f8ae0031e53d62615c8c
 
x86_64:
mailman-2.1.5-33.rhel4.x86_64.rpm
File outdated by:  RHSA-2011:0307
    MD5: 97a3e1f38866b40d06b2226e0901fc45
 
Red Hat Enterprise Linux WS (v. 3)

IA-32:
mailman-2.1.5-25.rhel3.i386.rpm
File outdated by:  RHBA-2007:0464
    MD5: 6c052b1a07bfdec09756ee58be0e4c56
 
IA-64:
mailman-2.1.5-25.rhel3.ia64.rpm
File outdated by:  RHBA-2007:0464
    MD5: 41cbca1ff68fa89f87f6686aaf57f229
 
x86_64:
mailman-2.1.5-25.rhel3.x86_64.rpm
File outdated by:  RHBA-2007:0464
    MD5: 1a3ca7f170accc1a9747ef78b8ad0006
 
Red Hat Enterprise Linux WS (v. 4)

IA-32:
mailman-2.1.5-33.rhel4.i386.rpm
File outdated by:  RHSA-2011:0307
    MD5: 97e1cbd6ec4f6099def5ed95f072d603
 
IA-64:
mailman-2.1.5-33.rhel4.ia64.rpm
File outdated by:  RHSA-2011:0307
    MD5: 0fde6fa6ab37f8ae0031e53d62615c8c
 
x86_64:
mailman-2.1.5-33.rhel4.x86_64.rpm
File outdated by:  RHSA-2011:0307
    MD5: 97a3e1f38866b40d06b2226e0901fc45
 
(The unlinked packages above are only available from the Red Hat Network)

Bugs fixed (see bugzilla for more information)

132750 - Mailman doesn't work with courier
142605 - init script doesn't use /var/lock/subsys
143008 - mailman logrotate has wrong location for mailmanctl
147833 - CAN-2004-1177 - mailman


References


Keywords

XSS


These packages are GPG signed by Red Hat for security. Our key and details on how to verify the signature are available from:
https://www.redhat.com/security/team/key/#package

The Red Hat security contact is secalert@redhat.com. More contact details at http://www.redhat.com/security/team/contact/