Skip to navigation

Security Advisory postgresql security update

Advisory: RHSA-2005:138-15
Type: Security Advisory
Severity: Important
Issued on: 2005-02-15
Last updated on: 2005-02-15
Affected Products: Red Hat Desktop (v. 4)
Red Hat Enterprise Linux AS (v. 4)
Red Hat Enterprise Linux ES (v. 4)
Red Hat Enterprise Linux WS (v. 4)
CVEs (cve.mitre.org): CVE-2005-0227
CVE-2005-0244
CVE-2005-0245
CVE-2005-0246
CVE-2005-0247

Details

Updated postresql packages that correct various security issues are now
available for Red Hat Enterprise Linux 4.

This update has been rated as having important security impact by the Red
Hat Security Response Team.

A flaw in the LOAD command in PostgreSQL was discovered. A local user
could use this flaw to load arbitrary shared libraries and therefore
execute arbitrary code, gaining the privileges of the PostgreSQL server.
The Common Vulnerabilities and Exposures project (cve.mitre.org) has
assigned the name CAN-2005-0227 to this issue.

A permission checking flaw in PostgreSQL was discovered. A local user
could bypass the EXECUTE permission check for functions by using the CREATE
AGGREGATE command. The Common Vulnerabilities and Exposures project
(cve.mitre.org) has assigned the name CAN-2005-0244 to this issue.

Multiple buffer overflows were found in PL/PgSQL. A database user who has
permissions to create plpgsql functions could trigger this flaw which could
lead to arbitrary code execution, gaining the privileges of the PostgreSQL
server. The Common Vulnerabilities and Exposures project (cve.mitre.org)
has assigned the names CAN-2005-0245 and CAN-2005-0247 to these issues.

A flaw in the integer aggregator (intagg) contrib module for PostgreSQL was
found. A user could create carefully crafted arrays and cause a denial of
service (crash). The Common Vulnerabilities and Exposures project
(cve.mitre.org) has assigned the name CAN-2005-0246 to this issue.

The update also fixes some minor problems, notably conflicts with SELinux.

Users of postgresql should update to these erratum packages that contain
patches and are not vulnerable to these issues.


Solution

Before applying this update, make sure that all previously-released
errata relevant to your system have been applied. Use Red Hat
Network to download and update your packages. To launch the Red Hat
Update Agent, use the following command:

up2date

For information on how to install packages manually, refer to the
following Web page for the System Administration or Customization
guide specific to your system:

http://www.redhat.com/docs/manuals/enterprise/

Updated packages

Red Hat Desktop (v. 4)

IA-32:
postgresql-7.4.7-2.RHEL4.1.i386.rpm
File outdated by:  RHSA-2011:1377
    MD5: 94d767f2f6ef199da85b02a329831df4
postgresql-contrib-7.4.7-2.RHEL4.1.i386.rpm
File outdated by:  RHSA-2011:1377
    MD5: 24d8c367ea671793886694acee47dd46
postgresql-devel-7.4.7-2.RHEL4.1.i386.rpm
File outdated by:  RHSA-2011:1377
    MD5: 97cf17eadcfa47e8a5935ef934ad80c1
postgresql-docs-7.4.7-2.RHEL4.1.i386.rpm
File outdated by:  RHSA-2011:1377
    MD5: 617ef0322d65637391f4a5ec829c0b48
postgresql-jdbc-7.4.7-2.RHEL4.1.i386.rpm
File outdated by:  RHSA-2011:1377
    MD5: a7290745d3b10152905c7a9b6e5d2303
postgresql-libs-7.4.7-2.RHEL4.1.i386.rpm
File outdated by:  RHSA-2011:1377
    MD5: fc57db8cf70d429f50f47de0de273a5d
postgresql-pl-7.4.7-2.RHEL4.1.i386.rpm
File outdated by:  RHSA-2011:1377
    MD5: 215a38538bac632bd75ea928f83c8dea
postgresql-python-7.4.7-2.RHEL4.1.i386.rpm
File outdated by:  RHSA-2011:1377
    MD5: 03f5055d27b62fce264aacb6871da359
postgresql-server-7.4.7-2.RHEL4.1.i386.rpm
File outdated by:  RHSA-2011:1377
    MD5: f595f6046a7b3f8edb58433670423000
postgresql-tcl-7.4.7-2.RHEL4.1.i386.rpm
File outdated by:  RHSA-2011:1377
    MD5: b11d6077c7eeeb024b52aa3e2d17bf33
postgresql-test-7.4.7-2.RHEL4.1.i386.rpm
File outdated by:  RHSA-2011:1377
    MD5: 21bbaa0275666e60f729ebafd1b09bd7
 
x86_64:
postgresql-7.4.7-2.RHEL4.1.x86_64.rpm
File outdated by:  RHSA-2011:1377
    MD5: 160c62ec767ff02044312f7ac8dedcb9
postgresql-contrib-7.4.7-2.RHEL4.1.x86_64.rpm
File outdated by:  RHSA-2011:1377
    MD5: 566bcbd048c537b1af7c1292c02a0b4a
postgresql-devel-7.4.7-2.RHEL4.1.x86_64.rpm
File outdated by:  RHSA-2011:1377
    MD5: e97a12835837cc113d5eafbd3cfe837a
postgresql-docs-7.4.7-2.RHEL4.1.x86_64.rpm
File outdated by:  RHSA-2011:1377
    MD5: 3f836c1c3dbdd9e9267666e3d469c009
postgresql-jdbc-7.4.7-2.RHEL4.1.x86_64.rpm
File outdated by:  RHSA-2011:1377
    MD5: bc4f32b5a6365cbf8fe19d18ee301584
postgresql-libs-7.4.7-2.RHEL4.1.i386.rpm
File outdated by:  RHSA-2011:1377
    MD5: fc57db8cf70d429f50f47de0de273a5d
postgresql-libs-7.4.7-2.RHEL4.1.x86_64.rpm
File outdated by:  RHSA-2011:1377
    MD5: 688d65282a1391f2188c356d88c21424
postgresql-pl-7.4.7-2.RHEL4.1.x86_64.rpm
File outdated by:  RHSA-2011:1377
    MD5: 811345247cc87ce5e29a68cf60119ac5
postgresql-python-7.4.7-2.RHEL4.1.x86_64.rpm
File outdated by:  RHSA-2011:1377
    MD5: 3fc8e7c2cfc2403227eacdc00f633dcb
postgresql-server-7.4.7-2.RHEL4.1.x86_64.rpm
File outdated by:  RHSA-2011:1377
    MD5: 86aff4b1ad4a271516ea5f4a67a716f3
postgresql-tcl-7.4.7-2.RHEL4.1.x86_64.rpm
File outdated by:  RHSA-2011:1377
    MD5: a8d738af14ae28007fa34594b3f93ca9
postgresql-test-7.4.7-2.RHEL4.1.x86_64.rpm
File outdated by:  RHSA-2011:1377
    MD5: d771483eb87fa3cf2b53585f99a95d57
 
Red Hat Enterprise Linux AS (v. 4)

IA-32:
postgresql-7.4.7-2.RHEL4.1.i386.rpm
File outdated by:  RHSA-2011:1377
    MD5: 94d767f2f6ef199da85b02a329831df4
postgresql-contrib-7.4.7-2.RHEL4.1.i386.rpm
File outdated by:  RHSA-2011:1377
    MD5: 24d8c367ea671793886694acee47dd46
postgresql-devel-7.4.7-2.RHEL4.1.i386.rpm
File outdated by:  RHSA-2011:1377
    MD5: 97cf17eadcfa47e8a5935ef934ad80c1
postgresql-docs-7.4.7-2.RHEL4.1.i386.rpm
File outdated by:  RHSA-2011:1377
    MD5: 617ef0322d65637391f4a5ec829c0b48
postgresql-jdbc-7.4.7-2.RHEL4.1.i386.rpm
File outdated by:  RHSA-2011:1377
    MD5: a7290745d3b10152905c7a9b6e5d2303
postgresql-libs-7.4.7-2.RHEL4.1.i386.rpm
File outdated by:  RHSA-2011:1377
    MD5: fc57db8cf70d429f50f47de0de273a5d
postgresql-pl-7.4.7-2.RHEL4.1.i386.rpm
File outdated by:  RHSA-2011:1377
    MD5: 215a38538bac632bd75ea928f83c8dea
postgresql-python-7.4.7-2.RHEL4.1.i386.rpm
File outdated by:  RHSA-2011:1377
    MD5: 03f5055d27b62fce264aacb6871da359
postgresql-server-7.4.7-2.RHEL4.1.i386.rpm
File outdated by:  RHSA-2011:1377
    MD5: f595f6046a7b3f8edb58433670423000
postgresql-tcl-7.4.7-2.RHEL4.1.i386.rpm
File outdated by:  RHSA-2011:1377
    MD5: b11d6077c7eeeb024b52aa3e2d17bf33
postgresql-test-7.4.7-2.RHEL4.1.i386.rpm
File outdated by:  RHSA-2011:1377
    MD5: 21bbaa0275666e60f729ebafd1b09bd7
 
IA-64:
postgresql-7.4.7-2.RHEL4.1.ia64.rpm
File outdated by:  RHSA-2011:1377
    MD5: 413493d8d89ddb33b71529f196cd8eeb
postgresql-contrib-7.4.7-2.RHEL4.1.ia64.rpm
File outdated by:  RHSA-2011:1377
    MD5: a429b5ccf6d1a3a72ef877d8937a1d38
postgresql-devel-7.4.7-2.RHEL4.1.ia64.rpm
File outdated by:  RHSA-2011:1377
    MD5: 3493f3559c39fbe7252646da33ba9612
postgresql-docs-7.4.7-2.RHEL4.1.ia64.rpm
File outdated by:  RHSA-2011:1377
    MD5: cfe7b3d303df0853d29293fda459f2ce
postgresql-jdbc-7.4.7-2.RHEL4.1.ia64.rpm
File outdated by:  RHSA-2011:1377
    MD5: c68a2c4dd41262805118c2a6d5f3bcdf
postgresql-libs-7.4.7-2.RHEL4.1.i386.rpm
File outdated by:  RHSA-2011:1377
    MD5: fc57db8cf70d429f50f47de0de273a5d
postgresql-libs-7.4.7-2.RHEL4.1.ia64.rpm
File outdated by:  RHSA-2011:1377
    MD5: 05574b6e2d668682fdf8b2615c377e1e
postgresql-pl-7.4.7-2.RHEL4.1.ia64.rpm
File outdated by:  RHSA-2011:1377
    MD5: 4fb94f23fab1495b66015b24ebb8ef84
postgresql-python-7.4.7-2.RHEL4.1.ia64.rpm
File outdated by:  RHSA-2011:1377
    MD5: 8dd8fe43a6aa7c2015e011b8daeb260b
postgresql-server-7.4.7-2.RHEL4.1.ia64.rpm
File outdated by:  RHSA-2011:1377
    MD5: bf72451ec862491282b438dfadfb621b
postgresql-tcl-7.4.7-2.RHEL4.1.ia64.rpm
File outdated by:  RHSA-2011:1377
    MD5: 3ff85543fdd87549364b43dc259073bb
postgresql-test-7.4.7-2.RHEL4.1.ia64.rpm
File outdated by:  RHSA-2011:1377
    MD5: 1a6659e0f87faadd4ddd7b04ca38b40e
 
PPC:
postgresql-7.4.7-2.RHEL4.1.ppc.rpm
File outdated by:  RHSA-2011:1377
    MD5: 28069c3cf0b64b60ed7cda8385428d21
postgresql-contrib-7.4.7-2.RHEL4.1.ppc.rpm
File outdated by:  RHSA-2011:1377
    MD5: 5a8fce1393a87d1145598816e3e59ebc
postgresql-devel-7.4.7-2.RHEL4.1.ppc.rpm
File outdated by:  RHSA-2011:1377
    MD5: 466949412bc1fd0562215700b865cb13
postgresql-docs-7.4.7-2.RHEL4.1.ppc.rpm
File outdated by:  RHSA-2011:1377
    MD5: 8cb56dd3587845c27bc7e069781c51cb
postgresql-jdbc-7.4.7-2.RHEL4.1.ppc.rpm
File outdated by:  RHSA-2011:1377
    MD5: c36b270aa3901ff81f8ff85dbcf73b24
postgresql-libs-7.4.7-2.RHEL4.1.ppc.rpm
File outdated by:  RHSA-2011:1377
    MD5: 6b1f843eece8de00649b14d5d26c5eee
postgresql-libs-7.4.7-2.RHEL4.1.ppc64.rpm
File outdated by:  RHSA-2011:1377
    MD5: bbc66b7ba8c115bc4c695f108f028896
postgresql-pl-7.4.7-2.RHEL4.1.ppc.rpm
File outdated by:  RHSA-2011:1377
    MD5: ad1e0bf7d9cbdb7572731e6cb28167e3
postgresql-python-7.4.7-2.RHEL4.1.ppc.rpm
File outdated by:  RHSA-2011:1377
    MD5: 879694c738be3084741bf2a451588c5f
postgresql-server-7.4.7-2.RHEL4.1.ppc.rpm
File outdated by:  RHSA-2011:1377
    MD5: b20480752175008f288b151ba8faa912
postgresql-tcl-7.4.7-2.RHEL4.1.ppc.rpm
File outdated by:  RHSA-2011:1377
    MD5: ac5d99ee20d5fc8c0d3aef5fb68daf21
postgresql-test-7.4.7-2.RHEL4.1.ppc.rpm
File outdated by:  RHSA-2011:1377
    MD5: 7eee8e20e25a42b5a2b634212480e3d7
 
s390:
postgresql-7.4.7-2.RHEL4.1.s390.rpm
File outdated by:  RHSA-2011:1377
    MD5: 561284e5fb73124623b6cd3c677fb29f
postgresql-contrib-7.4.7-2.RHEL4.1.s390.rpm
File outdated by:  RHSA-2011:1377
    MD5: d473ed1d448b44c19567f2d2ec8be404
postgresql-devel-7.4.7-2.RHEL4.1.s390.rpm
File outdated by:  RHSA-2011:1377
    MD5: 4fbd490194bb0892ad7a5c4f90311df5
postgresql-docs-7.4.7-2.RHEL4.1.s390.rpm
File outdated by:  RHSA-2011:1377
    MD5: 0a6691dd19025858f4a0bfbd0d4f8529
postgresql-jdbc-7.4.7-2.RHEL4.1.s390.rpm
File outdated by:  RHSA-2011:1377
    MD5: 457bf0a874ae3529085d9b16c254feed
postgresql-libs-7.4.7-2.RHEL4.1.s390.rpm
File outdated by:  RHSA-2011:1377
    MD5: 476ed4d0d0b1ee2510cfca96628391e0
postgresql-pl-7.4.7-2.RHEL4.1.s390.rpm
File outdated by:  RHSA-2011:1377
    MD5: 20966510599cb51fea0842ac46350b8b
postgresql-python-7.4.7-2.RHEL4.1.s390.rpm
File outdated by:  RHSA-2011:1377
    MD5: 1634740126a0c0e9f6c3d32ee0440dff
postgresql-server-7.4.7-2.RHEL4.1.s390.rpm
File outdated by:  RHSA-2011:1377
    MD5: e5cc410a24ab084811269c8cfb82baeb
postgresql-tcl-7.4.7-2.RHEL4.1.s390.rpm
File outdated by:  RHSA-2011:1377
    MD5: 146614ff66aef3c562d8e40f73642a8c
postgresql-test-7.4.7-2.RHEL4.1.s390.rpm
File outdated by:  RHSA-2011:1377
    MD5: 096895ed7da7e396b509e5342b8ca156
 
s390x:
postgresql-7.4.7-2.RHEL4.1.s390x.rpm
File outdated by:  RHSA-2011:1377
    MD5: cdb2c8d8affde739ff8c09ec203414cb
postgresql-contrib-7.4.7-2.RHEL4.1.s390x.rpm
File outdated by:  RHSA-2011:1377
    MD5: c89c16f717478055f6c5a3262a5c904d
postgresql-devel-7.4.7-2.RHEL4.1.s390x.rpm
File outdated by:  RHSA-2011:1377
    MD5: 7155f40e42f605b4c3db49951db86c0f
postgresql-docs-7.4.7-2.RHEL4.1.s390x.rpm
File outdated by:  RHSA-2011:1377
    MD5: e70c52d4ec436cbed3a47febb8152e72
postgresql-jdbc-7.4.7-2.RHEL4.1.s390x.rpm
File outdated by:  RHSA-2011:1377
    MD5: d82f643222f0e542ed5357619b058365
postgresql-libs-7.4.7-2.RHEL4.1.s390.rpm
File outdated by:  RHSA-2011:1377
    MD5: 476ed4d0d0b1ee2510cfca96628391e0
postgresql-libs-7.4.7-2.RHEL4.1.s390x.rpm
File outdated by:  RHSA-2011:1377
    MD5: d774caa8a4fdfa0211d3ebff6ffa0c93
postgresql-pl-7.4.7-2.RHEL4.1.s390x.rpm
File outdated by:  RHSA-2011:1377
    MD5: 5c6713ee95d04ba7703245d38573deaf
postgresql-python-7.4.7-2.RHEL4.1.s390x.rpm
File outdated by:  RHSA-2011:1377
    MD5: cf0b594f982c34e805d895e19c3de52e
postgresql-server-7.4.7-2.RHEL4.1.s390x.rpm
File outdated by:  RHSA-2011:1377
    MD5: 63da4f50fb669b7b2dfa7b02efc66d6b
postgresql-tcl-7.4.7-2.RHEL4.1.s390x.rpm
File outdated by:  RHSA-2011:1377
    MD5: 883fe4ec6c243fd7967240933aa6edd8
postgresql-test-7.4.7-2.RHEL4.1.s390x.rpm
File outdated by:  RHSA-2011:1377
    MD5: bd301c03b0af52655c530a0a388755a4
 
x86_64:
postgresql-7.4.7-2.RHEL4.1.x86_64.rpm
File outdated by:  RHSA-2011:1377
    MD5: 160c62ec767ff02044312f7ac8dedcb9
postgresql-contrib-7.4.7-2.RHEL4.1.x86_64.rpm
File outdated by:  RHSA-2011:1377
    MD5: 566bcbd048c537b1af7c1292c02a0b4a
postgresql-devel-7.4.7-2.RHEL4.1.x86_64.rpm
File outdated by:  RHSA-2011:1377
    MD5: e97a12835837cc113d5eafbd3cfe837a
postgresql-docs-7.4.7-2.RHEL4.1.x86_64.rpm
File outdated by:  RHSA-2011:1377
    MD5: 3f836c1c3dbdd9e9267666e3d469c009
postgresql-jdbc-7.4.7-2.RHEL4.1.x86_64.rpm
File outdated by:  RHSA-2011:1377
    MD5: bc4f32b5a6365cbf8fe19d18ee301584
postgresql-libs-7.4.7-2.RHEL4.1.i386.rpm
File outdated by:  RHSA-2011:1377
    MD5: fc57db8cf70d429f50f47de0de273a5d
postgresql-libs-7.4.7-2.RHEL4.1.x86_64.rpm
File outdated by:  RHSA-2011:1377
    MD5: 688d65282a1391f2188c356d88c21424
postgresql-pl-7.4.7-2.RHEL4.1.x86_64.rpm
File outdated by:  RHSA-2011:1377
    MD5: 811345247cc87ce5e29a68cf60119ac5
postgresql-python-7.4.7-2.RHEL4.1.x86_64.rpm
File outdated by:  RHSA-2011:1377
    MD5: 3fc8e7c2cfc2403227eacdc00f633dcb
postgresql-server-7.4.7-2.RHEL4.1.x86_64.rpm
File outdated by:  RHSA-2011:1377
    MD5: 86aff4b1ad4a271516ea5f4a67a716f3
postgresql-tcl-7.4.7-2.RHEL4.1.x86_64.rpm
File outdated by:  RHSA-2011:1377
    MD5: a8d738af14ae28007fa34594b3f93ca9
postgresql-test-7.4.7-2.RHEL4.1.x86_64.rpm
File outdated by:  RHSA-2011:1377
    MD5: d771483eb87fa3cf2b53585f99a95d57
 
Red Hat Enterprise Linux ES (v. 4)

IA-32:
postgresql-7.4.7-2.RHEL4.1.i386.rpm
File outdated by:  RHSA-2011:1377
    MD5: 94d767f2f6ef199da85b02a329831df4
postgresql-contrib-7.4.7-2.RHEL4.1.i386.rpm
File outdated by:  RHSA-2011:1377
    MD5: 24d8c367ea671793886694acee47dd46
postgresql-devel-7.4.7-2.RHEL4.1.i386.rpm
File outdated by:  RHSA-2011:1377
    MD5: 97cf17eadcfa47e8a5935ef934ad80c1
postgresql-docs-7.4.7-2.RHEL4.1.i386.rpm
File outdated by:  RHSA-2011:1377
    MD5: 617ef0322d65637391f4a5ec829c0b48
postgresql-jdbc-7.4.7-2.RHEL4.1.i386.rpm
File outdated by:  RHSA-2011:1377
    MD5: a7290745d3b10152905c7a9b6e5d2303
postgresql-libs-7.4.7-2.RHEL4.1.i386.rpm
File outdated by:  RHSA-2011:1377
    MD5: fc57db8cf70d429f50f47de0de273a5d
postgresql-pl-7.4.7-2.RHEL4.1.i386.rpm
File outdated by:  RHSA-2011:1377
    MD5: 215a38538bac632bd75ea928f83c8dea
postgresql-python-7.4.7-2.RHEL4.1.i386.rpm
File outdated by:  RHSA-2011:1377
    MD5: 03f5055d27b62fce264aacb6871da359
postgresql-server-7.4.7-2.RHEL4.1.i386.rpm
File outdated by:  RHSA-2011:1377
    MD5: f595f6046a7b3f8edb58433670423000
postgresql-tcl-7.4.7-2.RHEL4.1.i386.rpm
File outdated by:  RHSA-2011:1377
    MD5: b11d6077c7eeeb024b52aa3e2d17bf33
postgresql-test-7.4.7-2.RHEL4.1.i386.rpm
File outdated by:  RHSA-2011:1377
    MD5: 21bbaa0275666e60f729ebafd1b09bd7
 
IA-64:
postgresql-7.4.7-2.RHEL4.1.ia64.rpm
File outdated by:  RHSA-2011:1377
    MD5: 413493d8d89ddb33b71529f196cd8eeb
postgresql-contrib-7.4.7-2.RHEL4.1.ia64.rpm
File outdated by:  RHSA-2011:1377
    MD5: a429b5ccf6d1a3a72ef877d8937a1d38
postgresql-devel-7.4.7-2.RHEL4.1.ia64.rpm
File outdated by:  RHSA-2011:1377
    MD5: 3493f3559c39fbe7252646da33ba9612
postgresql-docs-7.4.7-2.RHEL4.1.ia64.rpm
File outdated by:  RHSA-2011:1377
    MD5: cfe7b3d303df0853d29293fda459f2ce
postgresql-jdbc-7.4.7-2.RHEL4.1.ia64.rpm
File outdated by:  RHSA-2011:1377
    MD5: c68a2c4dd41262805118c2a6d5f3bcdf
postgresql-libs-7.4.7-2.RHEL4.1.i386.rpm
File outdated by:  RHSA-2011:1377
    MD5: fc57db8cf70d429f50f47de0de273a5d
postgresql-libs-7.4.7-2.RHEL4.1.ia64.rpm
File outdated by:  RHSA-2011:1377
    MD5: 05574b6e2d668682fdf8b2615c377e1e
postgresql-pl-7.4.7-2.RHEL4.1.ia64.rpm
File outdated by:  RHSA-2011:1377
    MD5: 4fb94f23fab1495b66015b24ebb8ef84
postgresql-python-7.4.7-2.RHEL4.1.ia64.rpm
File outdated by:  RHSA-2011:1377
    MD5: 8dd8fe43a6aa7c2015e011b8daeb260b
postgresql-server-7.4.7-2.RHEL4.1.ia64.rpm
File outdated by:  RHSA-2011:1377
    MD5: bf72451ec862491282b438dfadfb621b
postgresql-tcl-7.4.7-2.RHEL4.1.ia64.rpm
File outdated by:  RHSA-2011:1377
    MD5: 3ff85543fdd87549364b43dc259073bb
postgresql-test-7.4.7-2.RHEL4.1.ia64.rpm
File outdated by:  RHSA-2011:1377
    MD5: 1a6659e0f87faadd4ddd7b04ca38b40e
 
x86_64:
postgresql-7.4.7-2.RHEL4.1.x86_64.rpm
File outdated by:  RHSA-2011:1377
    MD5: 160c62ec767ff02044312f7ac8dedcb9
postgresql-contrib-7.4.7-2.RHEL4.1.x86_64.rpm
File outdated by:  RHSA-2011:1377
    MD5: 566bcbd048c537b1af7c1292c02a0b4a
postgresql-devel-7.4.7-2.RHEL4.1.x86_64.rpm
File outdated by:  RHSA-2011:1377
    MD5: e97a12835837cc113d5eafbd3cfe837a
postgresql-docs-7.4.7-2.RHEL4.1.x86_64.rpm
File outdated by:  RHSA-2011:1377
    MD5: 3f836c1c3dbdd9e9267666e3d469c009
postgresql-jdbc-7.4.7-2.RHEL4.1.x86_64.rpm
File outdated by:  RHSA-2011:1377
    MD5: bc4f32b5a6365cbf8fe19d18ee301584
postgresql-libs-7.4.7-2.RHEL4.1.i386.rpm
File outdated by:  RHSA-2011:1377
    MD5: fc57db8cf70d429f50f47de0de273a5d
postgresql-libs-7.4.7-2.RHEL4.1.x86_64.rpm
File outdated by:  RHSA-2011:1377
    MD5: 688d65282a1391f2188c356d88c21424
postgresql-pl-7.4.7-2.RHEL4.1.x86_64.rpm
File outdated by:  RHSA-2011:1377
    MD5: 811345247cc87ce5e29a68cf60119ac5
postgresql-python-7.4.7-2.RHEL4.1.x86_64.rpm
File outdated by:  RHSA-2011:1377
    MD5: 3fc8e7c2cfc2403227eacdc00f633dcb
postgresql-server-7.4.7-2.RHEL4.1.x86_64.rpm
File outdated by:  RHSA-2011:1377
    MD5: 86aff4b1ad4a271516ea5f4a67a716f3
postgresql-tcl-7.4.7-2.RHEL4.1.x86_64.rpm
File outdated by:  RHSA-2011:1377
    MD5: a8d738af14ae28007fa34594b3f93ca9
postgresql-test-7.4.7-2.RHEL4.1.x86_64.rpm
File outdated by:  RHSA-2011:1377
    MD5: d771483eb87fa3cf2b53585f99a95d57
 
Red Hat Enterprise Linux WS (v. 4)

IA-32:
postgresql-7.4.7-2.RHEL4.1.i386.rpm
File outdated by:  RHSA-2011:1377
    MD5: 94d767f2f6ef199da85b02a329831df4
postgresql-contrib-7.4.7-2.RHEL4.1.i386.rpm
File outdated by:  RHSA-2011:1377
    MD5: 24d8c367ea671793886694acee47dd46
postgresql-devel-7.4.7-2.RHEL4.1.i386.rpm
File outdated by:  RHSA-2011:1377
    MD5: 97cf17eadcfa47e8a5935ef934ad80c1
postgresql-docs-7.4.7-2.RHEL4.1.i386.rpm
File outdated by:  RHSA-2011:1377
    MD5: 617ef0322d65637391f4a5ec829c0b48
postgresql-jdbc-7.4.7-2.RHEL4.1.i386.rpm
File outdated by:  RHSA-2011:1377
    MD5: a7290745d3b10152905c7a9b6e5d2303
postgresql-libs-7.4.7-2.RHEL4.1.i386.rpm
File outdated by:  RHSA-2011:1377
    MD5: fc57db8cf70d429f50f47de0de273a5d
postgresql-pl-7.4.7-2.RHEL4.1.i386.rpm
File outdated by:  RHSA-2011:1377
    MD5: 215a38538bac632bd75ea928f83c8dea
postgresql-python-7.4.7-2.RHEL4.1.i386.rpm
File outdated by:  RHSA-2011:1377
    MD5: 03f5055d27b62fce264aacb6871da359
postgresql-server-7.4.7-2.RHEL4.1.i386.rpm
File outdated by:  RHSA-2011:1377
    MD5: f595f6046a7b3f8edb58433670423000
postgresql-tcl-7.4.7-2.RHEL4.1.i386.rpm
File outdated by:  RHSA-2011:1377
    MD5: b11d6077c7eeeb024b52aa3e2d17bf33
postgresql-test-7.4.7-2.RHEL4.1.i386.rpm
File outdated by:  RHSA-2011:1377
    MD5: 21bbaa0275666e60f729ebafd1b09bd7
 
IA-64:
postgresql-7.4.7-2.RHEL4.1.ia64.rpm
File outdated by:  RHSA-2011:1377
    MD5: 413493d8d89ddb33b71529f196cd8eeb
postgresql-contrib-7.4.7-2.RHEL4.1.ia64.rpm
File outdated by:  RHSA-2011:1377
    MD5: a429b5ccf6d1a3a72ef877d8937a1d38
postgresql-devel-7.4.7-2.RHEL4.1.ia64.rpm
File outdated by:  RHSA-2011:1377
    MD5: 3493f3559c39fbe7252646da33ba9612
postgresql-docs-7.4.7-2.RHEL4.1.ia64.rpm
File outdated by:  RHSA-2011:1377
    MD5: cfe7b3d303df0853d29293fda459f2ce
postgresql-jdbc-7.4.7-2.RHEL4.1.ia64.rpm
File outdated by:  RHSA-2011:1377
    MD5: c68a2c4dd41262805118c2a6d5f3bcdf
postgresql-libs-7.4.7-2.RHEL4.1.i386.rpm
File outdated by:  RHSA-2011:1377
    MD5: fc57db8cf70d429f50f47de0de273a5d
postgresql-libs-7.4.7-2.RHEL4.1.ia64.rpm
File outdated by:  RHSA-2011:1377
    MD5: 05574b6e2d668682fdf8b2615c377e1e
postgresql-pl-7.4.7-2.RHEL4.1.ia64.rpm
File outdated by:  RHSA-2011:1377
    MD5: 4fb94f23fab1495b66015b24ebb8ef84
postgresql-python-7.4.7-2.RHEL4.1.ia64.rpm
File outdated by:  RHSA-2011:1377
    MD5: 8dd8fe43a6aa7c2015e011b8daeb260b
postgresql-server-7.4.7-2.RHEL4.1.ia64.rpm
File outdated by:  RHSA-2011:1377
    MD5: bf72451ec862491282b438dfadfb621b
postgresql-tcl-7.4.7-2.RHEL4.1.ia64.rpm
File outdated by:  RHSA-2011:1377
    MD5: 3ff85543fdd87549364b43dc259073bb
postgresql-test-7.4.7-2.RHEL4.1.ia64.rpm
File outdated by:  RHSA-2011:1377
    MD5: 1a6659e0f87faadd4ddd7b04ca38b40e
 
x86_64:
postgresql-7.4.7-2.RHEL4.1.x86_64.rpm
File outdated by:  RHSA-2011:1377
    MD5: 160c62ec767ff02044312f7ac8dedcb9
postgresql-contrib-7.4.7-2.RHEL4.1.x86_64.rpm
File outdated by:  RHSA-2011:1377
    MD5: 566bcbd048c537b1af7c1292c02a0b4a
postgresql-devel-7.4.7-2.RHEL4.1.x86_64.rpm
File outdated by:  RHSA-2011:1377
    MD5: e97a12835837cc113d5eafbd3cfe837a
postgresql-docs-7.4.7-2.RHEL4.1.x86_64.rpm
File outdated by:  RHSA-2011:1377
    MD5: 3f836c1c3dbdd9e9267666e3d469c009
postgresql-jdbc-7.4.7-2.RHEL4.1.x86_64.rpm
File outdated by:  RHSA-2011:1377
    MD5: bc4f32b5a6365cbf8fe19d18ee301584
postgresql-libs-7.4.7-2.RHEL4.1.i386.rpm
File outdated by:  RHSA-2011:1377
    MD5: fc57db8cf70d429f50f47de0de273a5d
postgresql-libs-7.4.7-2.RHEL4.1.x86_64.rpm
File outdated by:  RHSA-2011:1377
    MD5: 688d65282a1391f2188c356d88c21424
postgresql-pl-7.4.7-2.RHEL4.1.x86_64.rpm
File outdated by:  RHSA-2011:1377
    MD5: 811345247cc87ce5e29a68cf60119ac5
postgresql-python-7.4.7-2.RHEL4.1.x86_64.rpm
File outdated by:  RHSA-2011:1377
    MD5: 3fc8e7c2cfc2403227eacdc00f633dcb
postgresql-server-7.4.7-2.RHEL4.1.x86_64.rpm
File outdated by:  RHSA-2011:1377
    MD5: 86aff4b1ad4a271516ea5f4a67a716f3
postgresql-tcl-7.4.7-2.RHEL4.1.x86_64.rpm
File outdated by:  RHSA-2011:1377
    MD5: a8d738af14ae28007fa34594b3f93ca9
postgresql-test-7.4.7-2.RHEL4.1.x86_64.rpm
File outdated by:  RHSA-2011:1377
    MD5: d771483eb87fa3cf2b53585f99a95d57
 
(The unlinked packages above are only available from the Red Hat Network)

Bugs fixed (see bugzilla for more information)

147380 - CAN-2005-0227 Multiple security issues in PostgreSQL (CAN-2005-0244 CAN-2005-0245 CAN-2005-0246 CAN-2005-0247)


References



These packages are GPG signed by Red Hat for security. Our key and details on how to verify the signature are available from:
https://www.redhat.com/security/team/key/#package

The Red Hat security contact is secalert@redhat.com. More contact details at http://www.redhat.com/security/team/contact/