Bug Fix Advisory python-virtinst bug fix and enhancement update

Advisory: RHBA-2014:1444-1
Type: Bug Fix Advisory
Severity: N/A
Issued on: 2014-10-13
Last updated on: 2014-10-13
Affected Products: Red Hat Enterprise Linux Desktop (v. 6)
Red Hat Enterprise Linux HPC Node (v. 6)
Red Hat Enterprise Linux Server (v. 6)
Red Hat Enterprise Linux Workstation (v. 6)

Details

Updated python-virtinst package that fixes several bugs and add various
enhancements are now available for Red Hat Enterprise Linux 6.

The python-virtinst package contains several command-line utilities, including
virt-install for building and installing new virtual machines, and virt-clone
for cloning existing virtual machines.

This update fixes the following bugs:

* Due to a bug in the python-virtinst package, the "virt-install --graphics
spice" command did not create a spicevmc channel. This bug has been fixed and
the aforementioned command now works as expected. (BZ#853386)

* Due to a bug in the python-virtinst package, the "sparse=false" parameter of
the virt-install command was ignored and the newly crated storage was not fully
allocated. This bug has been fixed and the "virt-install sparse=false" command
now works correctly. (BZ#873545)

* Prior to this update, when the allocation of a new lvm volume was set to 0
with
the virt-install utility, no error message was returned. With this update,
virt-install has been modified to display an error message in the aforementioned
case. (BZ#1000980)

* The virt-manager utility failed to clone virtual machines (VMs) with fully
allocated logical volumes. After clicking the Clone button in virt-manager GUI,
the following message was displayed:

Sparse logical volumes are not supported

This bug has been fixed and VMs with fully allocated logical volumes can now be
cloned successfully with virt-manager GUI. (BZ#1055225)

* When the virt-install command was executed with the "device=lun" option, it
terminated with the following message:

Unknown device type 'lun'

This bug has been fixed, and lun device type is now recognized correctly by
virt-install. (BZ#1077232)

* When selecting a PCI device to be assigned to a virtual machine, the
virt-manager GUI did not display the domain of PCI devices. Consequently, it was
impossible to assign a PCI device in any domain other than zero. This bug has
been fixed and virt-manager now displays domains correctly in the described
case. (BZ#1085499)

In addition, this update adds the following enhancements:

* This update adds support for the MacVTap device driver to the python-virtinst
package. MacVTap, which facilitates virtualized bridged networking, can now be
used when installing new virtual guest machines. (BZ#855740)

* This update adds options for USB redirection to the python-virtinst package.
(BZ#1001999)

* The list of operating system variants displayed by the "virt-install
--os-variant list" command has been updated. (BZ#1011290)

* This update enables the startup_policy parameter for the --disk option of the
virt-install command. This parameter allows to specify what to do with the disk
if the source file is not accessible. It accepts the same parameters as the
startupPolicy domain XML attribute. (BZ#1017423)

Users of python-virtinst are advised to upgrade to this updated package, which
fixes these bugs and adds these enhancements.


Solution

Before applying this update, make sure all previously released errata
relevant to your system have been applied.

This update is available via the Red Hat Network. Details on how to
use the Red Hat Network to apply this update are available at
https://access.redhat.com/articles/11258

Updated packages

Red Hat Enterprise Linux Desktop (v. 6)

SRPMS:
python-virtinst-0.600.0-24.el6.src.rpm
File outdated by:  RHBA-2017:0685
    MD5: 327f9f95f5199b707830bbf0018dc56c
SHA-256: 885db4c0d2af7170f5e10ac5bd27a33c86c28957063f89643e55be56deeb0073
 
IA-32:
python-virtinst-0.600.0-24.el6.noarch.rpm
File outdated by:  RHBA-2017:0685
    MD5: b628e128a63fac21a3030f43d5bc69fe
SHA-256: 6f28c5096811d3c7859e27564c20427da5a4e1d89953d4cbb85e70d02a40045e
 
x86_64:
python-virtinst-0.600.0-24.el6.noarch.rpm
File outdated by:  RHBA-2017:0685
    MD5: b628e128a63fac21a3030f43d5bc69fe
SHA-256: 6f28c5096811d3c7859e27564c20427da5a4e1d89953d4cbb85e70d02a40045e
 
Red Hat Enterprise Linux HPC Node (v. 6)

SRPMS:
python-virtinst-0.600.0-24.el6.src.rpm
File outdated by:  RHBA-2017:0685
    MD5: 327f9f95f5199b707830bbf0018dc56c
SHA-256: 885db4c0d2af7170f5e10ac5bd27a33c86c28957063f89643e55be56deeb0073
 
x86_64:
python-virtinst-0.600.0-24.el6.noarch.rpm
File outdated by:  RHBA-2017:0685
    MD5: b628e128a63fac21a3030f43d5bc69fe
SHA-256: 6f28c5096811d3c7859e27564c20427da5a4e1d89953d4cbb85e70d02a40045e
 
Red Hat Enterprise Linux Server (v. 6)

SRPMS:
python-virtinst-0.600.0-24.el6.src.rpm
File outdated by:  RHBA-2017:0685
    MD5: 327f9f95f5199b707830bbf0018dc56c
SHA-256: 885db4c0d2af7170f5e10ac5bd27a33c86c28957063f89643e55be56deeb0073
 
IA-32:
python-virtinst-0.600.0-24.el6.noarch.rpm
File outdated by:  RHBA-2017:0685
    MD5: b628e128a63fac21a3030f43d5bc69fe
SHA-256: 6f28c5096811d3c7859e27564c20427da5a4e1d89953d4cbb85e70d02a40045e
 
PPC:
python-virtinst-0.600.0-24.el6.noarch.rpm
File outdated by:  RHBA-2017:0685
    MD5: b628e128a63fac21a3030f43d5bc69fe
SHA-256: 6f28c5096811d3c7859e27564c20427da5a4e1d89953d4cbb85e70d02a40045e
 
s390x:
python-virtinst-0.600.0-24.el6.noarch.rpm
File outdated by:  RHBA-2017:0685
    MD5: b628e128a63fac21a3030f43d5bc69fe
SHA-256: 6f28c5096811d3c7859e27564c20427da5a4e1d89953d4cbb85e70d02a40045e
 
x86_64:
python-virtinst-0.600.0-24.el6.noarch.rpm
File outdated by:  RHBA-2017:0685
    MD5: b628e128a63fac21a3030f43d5bc69fe
SHA-256: 6f28c5096811d3c7859e27564c20427da5a4e1d89953d4cbb85e70d02a40045e
 
Red Hat Enterprise Linux Workstation (v. 6)

SRPMS:
python-virtinst-0.600.0-24.el6.src.rpm
File outdated by:  RHBA-2017:0685
    MD5: 327f9f95f5199b707830bbf0018dc56c
SHA-256: 885db4c0d2af7170f5e10ac5bd27a33c86c28957063f89643e55be56deeb0073
 
IA-32:
python-virtinst-0.600.0-24.el6.noarch.rpm
File outdated by:  RHBA-2017:0685
    MD5: b628e128a63fac21a3030f43d5bc69fe
SHA-256: 6f28c5096811d3c7859e27564c20427da5a4e1d89953d4cbb85e70d02a40045e
 
x86_64:
python-virtinst-0.600.0-24.el6.noarch.rpm
File outdated by:  RHBA-2017:0685
    MD5: b628e128a63fac21a3030f43d5bc69fe
SHA-256: 6f28c5096811d3c7859e27564c20427da5a4e1d89953d4cbb85e70d02a40045e
 
(The unlinked packages above are only available from the Red Hat Network)

Bugs fixed (see bugzilla for more information)

1000980 - No error shows when the allocation of new lvm volume set as 0
1001999 - [RFE] USB Redirection device options in virt-install
1011290 - os-variant list of virt-install is not updated.
1024151 - Typo in virt-install manual on RHEL6, should use "an "instead of "and" in format option description.
1024180 - qcow should not be in the virt-image 5 manual.
1024700 - Feature state attribute of off in the virtual image descriptor doesn't work.
1055225 - Cannot clone a logical volume based VM via virt-manager even if the volume is fully allocated
1095204 - qcow should not be in error info when use virt-image create a guest with invalid disk format in XML
853386 - virt-install --graphics spice does not create the spicevmc channel
855740 - virt-install does not support macvtap
873545 - virt-install parameter sparse=false doesn't take effect
886779 - Graphics display type sdl should be removed from virt-install manual



These packages are GPG signed by Red Hat for security. Our key and details on how to verify the signature are available from:
https://www.redhat.com/security/team/key/#package

The Red Hat security contact is secalert@redhat.com. More contact details at http://www.redhat.com/security/team/contact/