Bug Fix Advisory compat-openmpi bug fix update

Advisory: RHBA-2013:1711-1
Type: Bug Fix Advisory
Severity: N/A
Issued on: 2013-11-20
Last updated on: 2013-11-20
Affected Products: Red Hat Enterprise Linux Desktop (v. 6)
Red Hat Enterprise Linux HPC Node (v. 6)
Red Hat Enterprise Linux Server (v. 6)
Red Hat Enterprise Linux Workstation (v. 6)

Details

Updated compat-openmpi packages that fix one bug are now available for Red Hat
Enterprise Linux 6.

The compat-openmpi packages contain shared libraries from earlier versions of
Open Message Passing Interface (Open MPI). The libraries from previous releases
have been compiled against the current version of Red Hat Enterprise Linux 6,
and the packages enable earlier programs to keep functioning properly.

This update fixes the following bug:

* The compat-openmpi packages previously did not ensure compatibility with
earlier versions of the Open MPI shared libraries. Consequently, the users
failed to run certain applications using Open MPI on Red Hat Enterprise Linux
6.3 and later if those applications were compiled against Open MPI versions used
on Red Hat Enterprise Linux 6.2 and earlier. After this update, the
compat-openmpi packages now maintain compatibility with earlier versions of Open
MPI on Red Hat Enterprise Linux 6. (BZ#876315)

Users of compat-openmpi are advised to upgrade to these updated packages, which
fix this bug.


Solution

Before applying this update, make sure all previously released errata relevant
to your system have been applied.

This update is available via the Red Hat Network. Details on how to use the Red
Hat Network to apply this update are available at
https://access.redhat.com/site/articles/11258

Updated packages

Red Hat Enterprise Linux Desktop (v. 6)

SRPMS:
compat-openmpi-1.4.3-1.1.el6.src.rpm
File outdated by:  RHBA-2014:1551
    MD5: 996b20439b6ad3d08f8758abf0b19ff2
SHA-256: 8761f3f6a4bc35443007cd0a558eb61ef2f231d464b25f1c9570cb188f8055bf
 
IA-32:
compat-openmpi-1.4.3-1.1.el6.i686.rpm
File outdated by:  RHBA-2014:1551
    MD5: 7ba22748a04bfdea2b9b2b50eb58a9be
SHA-256: 95cd4edd0fa81b6027fbbbb9987dfcda82d3707be3058723bbabcc4e71b93ebb
compat-openmpi-debuginfo-1.4.3-1.1.el6.i686.rpm
File outdated by:  RHBA-2014:1551
    MD5: bba23c578607695ea35e7c0056b69ee6
SHA-256: b8aa5c46884a412b22c830e770e8826eeb2ee9dd50871fb3d33b87793dddbed6
compat-openmpi-devel-1.4.3-1.1.el6.i686.rpm
File outdated by:  RHBA-2014:1551
    MD5: 5c345348ac4d1465657d39acbacdcaca
SHA-256: 7ba2b197732bc916c0ce35cd0eb52b80b7e70301946f279ecaf91c59f1690111
 
x86_64:
compat-openmpi-1.4.3-1.1.el6.i686.rpm
File outdated by:  RHBA-2014:1551
    MD5: 7ba22748a04bfdea2b9b2b50eb58a9be
SHA-256: 95cd4edd0fa81b6027fbbbb9987dfcda82d3707be3058723bbabcc4e71b93ebb
compat-openmpi-1.4.3-1.1.el6.x86_64.rpm
File outdated by:  RHBA-2014:1551
    MD5: 4315a8f99c7c19ceb8242c088087bed0
SHA-256: 422ba5a544c7c78b2205124970e12c14549ae3db78ed8207d0831ae3cb58d6a6
compat-openmpi-debuginfo-1.4.3-1.1.el6.i686.rpm
File outdated by:  RHBA-2014:1551
    MD5: bba23c578607695ea35e7c0056b69ee6
SHA-256: b8aa5c46884a412b22c830e770e8826eeb2ee9dd50871fb3d33b87793dddbed6
compat-openmpi-debuginfo-1.4.3-1.1.el6.x86_64.rpm
File outdated by:  RHBA-2014:1551
    MD5: 00afce2d3c3c123045b4fa147f03c924
SHA-256: f1c14accbc935fd1132829f02e0f4327ecbe3f792ff4a9587bc0a763faa67d1a
compat-openmpi-devel-1.4.3-1.1.el6.i686.rpm
File outdated by:  RHBA-2014:1551
    MD5: 5c345348ac4d1465657d39acbacdcaca
SHA-256: 7ba2b197732bc916c0ce35cd0eb52b80b7e70301946f279ecaf91c59f1690111
compat-openmpi-devel-1.4.3-1.1.el6.x86_64.rpm
File outdated by:  RHBA-2014:1551
    MD5: 3d999f7053490e4a49d5a92c4363e014
SHA-256: 3a8835cbce38cd50bbae22c37203336a97c9b9cde430fe9a1d0a75aec5e06086
compat-openmpi-psm-1.4.3-1.1.el6.x86_64.rpm
File outdated by:  RHBA-2014:1551
    MD5: c449b70f607537c8e03bf99f0a3262d0
SHA-256: 3e81c536d5aecfacfbbe31bf9fffef14d3950f8a1b03c8f66dde702abc845b31
compat-openmpi-psm-devel-1.4.3-1.1.el6.x86_64.rpm
File outdated by:  RHBA-2014:1551
    MD5: 59f9f1e05e993b6523ebb0b4cb423c40
SHA-256: 66a8f6dffb2b9c42a55a87f9b2aec4e42f85513872aeb49bd9e583efdaa3c14b
 
Red Hat Enterprise Linux HPC Node (v. 6)

SRPMS:
compat-openmpi-1.4.3-1.1.el6.src.rpm
File outdated by:  RHBA-2014:1551
    MD5: 996b20439b6ad3d08f8758abf0b19ff2
SHA-256: 8761f3f6a4bc35443007cd0a558eb61ef2f231d464b25f1c9570cb188f8055bf
 
x86_64:
compat-openmpi-1.4.3-1.1.el6.i686.rpm
File outdated by:  RHBA-2014:1551
    MD5: 7ba22748a04bfdea2b9b2b50eb58a9be
SHA-256: 95cd4edd0fa81b6027fbbbb9987dfcda82d3707be3058723bbabcc4e71b93ebb
compat-openmpi-1.4.3-1.1.el6.x86_64.rpm
File outdated by:  RHBA-2014:1551
    MD5: 4315a8f99c7c19ceb8242c088087bed0
SHA-256: 422ba5a544c7c78b2205124970e12c14549ae3db78ed8207d0831ae3cb58d6a6
compat-openmpi-debuginfo-1.4.3-1.1.el6.i686.rpm
File outdated by:  RHBA-2016:0967
    MD5: bba23c578607695ea35e7c0056b69ee6
SHA-256: b8aa5c46884a412b22c830e770e8826eeb2ee9dd50871fb3d33b87793dddbed6
compat-openmpi-debuginfo-1.4.3-1.1.el6.x86_64.rpm
File outdated by:  RHBA-2016:0967
    MD5: 00afce2d3c3c123045b4fa147f03c924
SHA-256: f1c14accbc935fd1132829f02e0f4327ecbe3f792ff4a9587bc0a763faa67d1a
compat-openmpi-devel-1.4.3-1.1.el6.i686.rpm
File outdated by:  RHBA-2014:1551
    MD5: 5c345348ac4d1465657d39acbacdcaca
SHA-256: 7ba2b197732bc916c0ce35cd0eb52b80b7e70301946f279ecaf91c59f1690111
compat-openmpi-devel-1.4.3-1.1.el6.x86_64.rpm
File outdated by:  RHBA-2014:1551
    MD5: 3d999f7053490e4a49d5a92c4363e014
SHA-256: 3a8835cbce38cd50bbae22c37203336a97c9b9cde430fe9a1d0a75aec5e06086
compat-openmpi-psm-1.4.3-1.1.el6.x86_64.rpm
File outdated by:  RHBA-2014:1551
    MD5: c449b70f607537c8e03bf99f0a3262d0
SHA-256: 3e81c536d5aecfacfbbe31bf9fffef14d3950f8a1b03c8f66dde702abc845b31
compat-openmpi-psm-devel-1.4.3-1.1.el6.x86_64.rpm
File outdated by:  RHBA-2014:1551
    MD5: 59f9f1e05e993b6523ebb0b4cb423c40
SHA-256: 66a8f6dffb2b9c42a55a87f9b2aec4e42f85513872aeb49bd9e583efdaa3c14b
 
Red Hat Enterprise Linux Server (v. 6)

SRPMS:
compat-openmpi-1.4.3-1.1.el6.src.rpm
File outdated by:  RHBA-2014:1551
    MD5: 996b20439b6ad3d08f8758abf0b19ff2
SHA-256: 8761f3f6a4bc35443007cd0a558eb61ef2f231d464b25f1c9570cb188f8055bf
 
IA-32:
compat-openmpi-1.4.3-1.1.el6.i686.rpm
File outdated by:  RHBA-2014:1551
    MD5: 7ba22748a04bfdea2b9b2b50eb58a9be
SHA-256: 95cd4edd0fa81b6027fbbbb9987dfcda82d3707be3058723bbabcc4e71b93ebb
compat-openmpi-debuginfo-1.4.3-1.1.el6.i686.rpm
File outdated by:  RHBA-2016:0967
    MD5: bba23c578607695ea35e7c0056b69ee6
SHA-256: b8aa5c46884a412b22c830e770e8826eeb2ee9dd50871fb3d33b87793dddbed6
compat-openmpi-devel-1.4.3-1.1.el6.i686.rpm
File outdated by:  RHBA-2014:1551
    MD5: 5c345348ac4d1465657d39acbacdcaca
SHA-256: 7ba2b197732bc916c0ce35cd0eb52b80b7e70301946f279ecaf91c59f1690111
 
PPC:
compat-openmpi-1.4.3-1.1.el6.ppc.rpm
File outdated by:  RHBA-2014:1551
    MD5: 2975273d95de24c2d2e291a00f99b56a
SHA-256: 98ee0b46f7043a07b4e1ea22c27eedad85947ab57897a6f62a44cfc5a5e597a2
compat-openmpi-1.4.3-1.1.el6.ppc64.rpm
File outdated by:  RHBA-2014:1551
    MD5: c96eb815ac75110efae32f7278a6f35e
SHA-256: b0d240de426a0fe76d0397f19fd49f02bb87aa4b69fa5e63be77787f4db34904
compat-openmpi-debuginfo-1.4.3-1.1.el6.ppc.rpm
File outdated by:  RHBA-2016:0967
    MD5: f99026392bb840f839e362f7875f9a7e
SHA-256: a062458da541801b4b67b26ccedf8cc99b9b1078f86490769ccfd231370d623a
compat-openmpi-debuginfo-1.4.3-1.1.el6.ppc64.rpm
File outdated by:  RHBA-2016:0967
    MD5: 9d03607458763f6167433783eaaa0bfb
SHA-256: 5d080a5d380b98a2165810c40b719d9876aa6b7ff369ee79102eec53728305ed
compat-openmpi-devel-1.4.3-1.1.el6.ppc.rpm
File outdated by:  RHBA-2014:1551
    MD5: c79bedc33043e34caf3375d26ea0cfb5
SHA-256: 17bc0978c78f6f791a72e9d6a4ee1e4ebd1eb651dc858e4e2a082469c9488900
compat-openmpi-devel-1.4.3-1.1.el6.ppc64.rpm
File outdated by:  RHBA-2014:1551
    MD5: 28ee96f9adc1b1145c96b99f2d3efcbb
SHA-256: 9678139ab9836ebd4c1381313429a881fb1ffd264cce7ef245d01ccfc36486da
 
x86_64:
compat-openmpi-1.4.3-1.1.el6.i686.rpm
File outdated by:  RHBA-2014:1551
    MD5: 7ba22748a04bfdea2b9b2b50eb58a9be
SHA-256: 95cd4edd0fa81b6027fbbbb9987dfcda82d3707be3058723bbabcc4e71b93ebb
compat-openmpi-1.4.3-1.1.el6.x86_64.rpm
File outdated by:  RHBA-2014:1551
    MD5: 4315a8f99c7c19ceb8242c088087bed0
SHA-256: 422ba5a544c7c78b2205124970e12c14549ae3db78ed8207d0831ae3cb58d6a6
compat-openmpi-debuginfo-1.4.3-1.1.el6.i686.rpm
File outdated by:  RHBA-2016:0967
    MD5: bba23c578607695ea35e7c0056b69ee6
SHA-256: b8aa5c46884a412b22c830e770e8826eeb2ee9dd50871fb3d33b87793dddbed6
compat-openmpi-debuginfo-1.4.3-1.1.el6.x86_64.rpm
File outdated by:  RHBA-2016:0967
    MD5: 00afce2d3c3c123045b4fa147f03c924
SHA-256: f1c14accbc935fd1132829f02e0f4327ecbe3f792ff4a9587bc0a763faa67d1a
compat-openmpi-devel-1.4.3-1.1.el6.i686.rpm
File outdated by:  RHBA-2014:1551
    MD5: 5c345348ac4d1465657d39acbacdcaca
SHA-256: 7ba2b197732bc916c0ce35cd0eb52b80b7e70301946f279ecaf91c59f1690111
compat-openmpi-devel-1.4.3-1.1.el6.x86_64.rpm
File outdated by:  RHBA-2014:1551
    MD5: 3d999f7053490e4a49d5a92c4363e014
SHA-256: 3a8835cbce38cd50bbae22c37203336a97c9b9cde430fe9a1d0a75aec5e06086
compat-openmpi-psm-1.4.3-1.1.el6.x86_64.rpm
File outdated by:  RHBA-2014:1551
    MD5: c449b70f607537c8e03bf99f0a3262d0
SHA-256: 3e81c536d5aecfacfbbe31bf9fffef14d3950f8a1b03c8f66dde702abc845b31
compat-openmpi-psm-devel-1.4.3-1.1.el6.x86_64.rpm
File outdated by:  RHBA-2014:1551
    MD5: 59f9f1e05e993b6523ebb0b4cb423c40
SHA-256: 66a8f6dffb2b9c42a55a87f9b2aec4e42f85513872aeb49bd9e583efdaa3c14b
 
Red Hat Enterprise Linux Workstation (v. 6)

SRPMS:
compat-openmpi-1.4.3-1.1.el6.src.rpm
File outdated by:  RHBA-2014:1551
    MD5: 996b20439b6ad3d08f8758abf0b19ff2
SHA-256: 8761f3f6a4bc35443007cd0a558eb61ef2f231d464b25f1c9570cb188f8055bf
 
IA-32:
compat-openmpi-1.4.3-1.1.el6.i686.rpm
File outdated by:  RHBA-2014:1551
    MD5: 7ba22748a04bfdea2b9b2b50eb58a9be
SHA-256: 95cd4edd0fa81b6027fbbbb9987dfcda82d3707be3058723bbabcc4e71b93ebb
compat-openmpi-debuginfo-1.4.3-1.1.el6.i686.rpm
File outdated by:  RHBA-2016:0967
    MD5: bba23c578607695ea35e7c0056b69ee6
SHA-256: b8aa5c46884a412b22c830e770e8826eeb2ee9dd50871fb3d33b87793dddbed6
compat-openmpi-devel-1.4.3-1.1.el6.i686.rpm
File outdated by:  RHBA-2014:1551
    MD5: 5c345348ac4d1465657d39acbacdcaca
SHA-256: 7ba2b197732bc916c0ce35cd0eb52b80b7e70301946f279ecaf91c59f1690111
 
x86_64:
compat-openmpi-1.4.3-1.1.el6.i686.rpm
File outdated by:  RHBA-2014:1551
    MD5: 7ba22748a04bfdea2b9b2b50eb58a9be
SHA-256: 95cd4edd0fa81b6027fbbbb9987dfcda82d3707be3058723bbabcc4e71b93ebb
compat-openmpi-1.4.3-1.1.el6.x86_64.rpm
File outdated by:  RHBA-2014:1551
    MD5: 4315a8f99c7c19ceb8242c088087bed0
SHA-256: 422ba5a544c7c78b2205124970e12c14549ae3db78ed8207d0831ae3cb58d6a6
compat-openmpi-debuginfo-1.4.3-1.1.el6.i686.rpm
File outdated by:  RHBA-2016:0967
    MD5: bba23c578607695ea35e7c0056b69ee6
SHA-256: b8aa5c46884a412b22c830e770e8826eeb2ee9dd50871fb3d33b87793dddbed6
compat-openmpi-debuginfo-1.4.3-1.1.el6.x86_64.rpm
File outdated by:  RHBA-2016:0967
    MD5: 00afce2d3c3c123045b4fa147f03c924
SHA-256: f1c14accbc935fd1132829f02e0f4327ecbe3f792ff4a9587bc0a763faa67d1a
compat-openmpi-devel-1.4.3-1.1.el6.i686.rpm
File outdated by:  RHBA-2014:1551
    MD5: 5c345348ac4d1465657d39acbacdcaca
SHA-256: 7ba2b197732bc916c0ce35cd0eb52b80b7e70301946f279ecaf91c59f1690111
compat-openmpi-devel-1.4.3-1.1.el6.x86_64.rpm
File outdated by:  RHBA-2014:1551
    MD5: 3d999f7053490e4a49d5a92c4363e014
SHA-256: 3a8835cbce38cd50bbae22c37203336a97c9b9cde430fe9a1d0a75aec5e06086
compat-openmpi-psm-1.4.3-1.1.el6.x86_64.rpm
File outdated by:  RHBA-2014:1551
    MD5: c449b70f607537c8e03bf99f0a3262d0
SHA-256: 3e81c536d5aecfacfbbe31bf9fffef14d3950f8a1b03c8f66dde702abc845b31
compat-openmpi-psm-devel-1.4.3-1.1.el6.x86_64.rpm
File outdated by:  RHBA-2014:1551
    MD5: 59f9f1e05e993b6523ebb0b4cb423c40
SHA-256: 66a8f6dffb2b9c42a55a87f9b2aec4e42f85513872aeb49bd9e583efdaa3c14b
 
(The unlinked packages above are only available from the Red Hat Network)


These packages are GPG signed by Red Hat for security. Our key and details on how to verify the signature are available from:
https://www.redhat.com/security/team/key/#package

The Red Hat security contact is secalert@redhat.com. More contact details at http://www.redhat.com/security/team/contact/