Skip to navigation

Bug Fix Advisory mod_authz_ldap bug fix update

Advisory: RHBA-2010:0880-1
Type: Bug Fix Advisory
Severity: N/A
Issued on: 2010-11-11
Last updated on: 2010-11-11
Affected Products: RHEL Desktop Workstation (v. 5 client)
Red Hat Enterprise Linux (v. 5 server)

Details

An updated mod_authz_ldap package that fixes a bug is now available for Red Hat
Enterprise Linux 5.

mod_authz_ldap is a module for the Apache HTTP Server. This module provides
support for authenticating users against an LDAP database.

This update fixes the following bug:

* Previously, memory leaks occurred when running mod_authz_ldap. With this
update, the issue is resolved.

All users of mod_authz_ldap are advised to upgrade to this updated package,
which resolves this issue.


Solution

Before applying this update, make sure all previously-released errata
relevant to your system have been applied.

This update is available via the Red Hat Network. Details on how to
use the Red Hat Network to apply this update are available at
http://kbase.redhat.com/faq/docs/DOC-11259

Updated packages

RHEL Desktop Workstation (v. 5 client)

SRPMS:
mod_authz_ldap-0.26-9.el5_5.1.src.rpm
File outdated by:  RHBA-2011:0482
    MD5: fe9ef8bd46e99b9d04d29086f480b465
SHA-256: ca7b21983824613021589a63cf332c7459b51b72b8089becc93c9594e43ccd63
 
IA-32:
mod_authz_ldap-0.26-9.el5_5.1.i386.rpm
File outdated by:  RHBA-2011:0482
    MD5: e7b95cb19f0ea66a403feaaf9338741f
SHA-256: e2eaa7f36e2e6c520ee6cf5c7511672ed4cedb99090c35c50ef013674647457a
 
x86_64:
mod_authz_ldap-0.26-9.el5_5.1.x86_64.rpm
File outdated by:  RHBA-2011:0482
    MD5: aecae7ed5e452eb163c1c88a7689913d
SHA-256: 51a58e5ac8d715e9c08fce9349dc5dcfce1a0b06e4bc0298ae8ccb2e119e1cac
 
Red Hat Enterprise Linux (v. 5 server)

SRPMS:
mod_authz_ldap-0.26-9.el5_5.1.src.rpm
File outdated by:  RHBA-2011:0482
    MD5: fe9ef8bd46e99b9d04d29086f480b465
SHA-256: ca7b21983824613021589a63cf332c7459b51b72b8089becc93c9594e43ccd63
 
IA-32:
mod_authz_ldap-0.26-9.el5_5.1.i386.rpm
File outdated by:  RHBA-2011:0482
    MD5: e7b95cb19f0ea66a403feaaf9338741f
SHA-256: e2eaa7f36e2e6c520ee6cf5c7511672ed4cedb99090c35c50ef013674647457a
 
IA-64:
mod_authz_ldap-0.26-9.el5_5.1.ia64.rpm
File outdated by:  RHBA-2011:0482
    MD5: 0395bf20a587315f4b2abcc8c45a3dbe
SHA-256: 4270da2815aa9a32f965ac6aca5391a2c5de0578d996567955b5fb5868aa130e
 
PPC:
mod_authz_ldap-0.26-9.el5_5.1.ppc.rpm
File outdated by:  RHBA-2011:0482
    MD5: 9117237586461f52f253c07094db089d
SHA-256: a0c67d489b6f97d13b17f089276d799a5bed323a32e0585e365be5e76e062a21
 
s390x:
mod_authz_ldap-0.26-9.el5_5.1.s390x.rpm
File outdated by:  RHBA-2011:0482
    MD5: c608a73a4107845958fbfa6a21f3c2da
SHA-256: 75de96b1bdd8735605e2e2c2e9dad22ac613fe752fb840a0710f4e342f86be3d
 
x86_64:
mod_authz_ldap-0.26-9.el5_5.1.x86_64.rpm
File outdated by:  RHBA-2011:0482
    MD5: aecae7ed5e452eb163c1c88a7689913d
SHA-256: 51a58e5ac8d715e9c08fce9349dc5dcfce1a0b06e4bc0298ae8ccb2e119e1cac
 
(The unlinked packages above are only available from the Red Hat Network)

Bugs fixed (see bugzilla for more information)

641347 - Memory leak in mod_authz_ldap in RHEL5.3 [rhel-5.5.z]



These packages are GPG signed by Red Hat for security. Our key and details on how to verify the signature are available from:
https://www.redhat.com/security/team/key/#package

The Red Hat security contact is secalert@redhat.com. More contact details at http://www.redhat.com/security/team/contact/