Skip to navigation

Bug Fix Advisory binutils bug fix update

Advisory: RHBA-2009:0465-2
Type: Bug Fix Advisory
Severity: N/A
Issued on: 2009-05-06
Last updated on: 2009-09-02
Affected Products: RHEL Desktop Workstation (v. 5 client)
Red Hat Enterprise Linux (v. 5 server)
Red Hat Enterprise Linux Desktop (v. 5 client)

Details

Updated binutils packages that resolve several issues are now available.

binutils is a collection of utilities used for the creation of executable code.

These updated binutils packages provide fixes for the following bugs:

* the "objdump" and "size" utilities were not recognizing ELF64-i386 object
files. Such files are not normally produced on 32-bit x86 architectures.
However, the kdump utility does produce such files on Physical Address
Extension (PAE)-enabled kernels. With these updated packages, it is now
possible to use the objdump and size utilities on ELF64-i386 object files.
(BZ#457189)

* due to a rare linking error, producing certain executables caused
multi-megabyte zero-filled gaps in the executables. This did not affect the
running of excutables affected by this bug. This linker error has been
corrected in these updated packages so that executables do not contain
spurious zero-filled gaps. (BZ#458301)

* the error message for the "strings -n [non-number]" command were less
clear than in the previous package release, and therefore has been reverted
and clarified. (BZ#480009)

* the c++filt(1) man page contained a typo when giving the syntax for the
recognized '--strip-underscore' option. (BZ#485194)

* the c++filt(1) man page incorrectly mentioned the '-j' and '--java'
options, which are not available when running c++filt. These mentionings
have been removed from the man page. (BZ#495196)

All users of binutils are advised to upgrade to these updated packages,
which resolve these issues.


Solution

Before applying this update, make sure that all previously-released
errata relevant to your system have been applied.

This update is available via Red Hat Network. Details on how to use
the Red Hat Network to apply this update are available at
http://kbase.redhat.com/faq/docs/DOC-11259

Updated packages

RHEL Desktop Workstation (v. 5 client)

IA-32:
binutils-devel-2.17.50.0.6-12.el5.i386.rpm
File outdated by:  RHBA-2013:1306
    MD5: 2bed512a7d6b4d9cfbfa92050d5f0fa0
 
x86_64:
binutils-devel-2.17.50.0.6-12.el5.i386.rpm
File outdated by:  RHBA-2013:1306
    MD5: 2bed512a7d6b4d9cfbfa92050d5f0fa0
binutils-devel-2.17.50.0.6-12.el5.x86_64.rpm
File outdated by:  RHBA-2013:1306
    MD5: ceb05844de2a2130ce12603ab121e211
 
Red Hat Enterprise Linux (v. 5 server)

IA-32:
binutils-2.17.50.0.6-12.el5.i386.rpm
File outdated by:  RHBA-2013:1306
    MD5: 1971458c1ebf5154ec2642e7b470b37b
binutils-devel-2.17.50.0.6-12.el5.i386.rpm
File outdated by:  RHBA-2013:1306
    MD5: 2bed512a7d6b4d9cfbfa92050d5f0fa0
 
IA-64:
binutils-2.17.50.0.6-12.el5.ia64.rpm
File outdated by:  RHBA-2013:1306
    MD5: edb71c725557f92565e2cc5ec5416d48
binutils-devel-2.17.50.0.6-12.el5.ia64.rpm
File outdated by:  RHBA-2013:1306
    MD5: 63f4a61c95753f32382adb72a785adae
 
PPC:
binutils-2.17.50.0.6-12.el5.ppc.rpm
File outdated by:  RHBA-2013:1306
    MD5: 012cbbafe3160478e76f427632b8c6e5
binutils-devel-2.17.50.0.6-12.el5.ppc.rpm
File outdated by:  RHBA-2013:1306
    MD5: e8de72ea2c5391eca73d1c8a7d7754ff
binutils-devel-2.17.50.0.6-12.el5.ppc64.rpm
File outdated by:  RHBA-2013:1306
    MD5: f47ed4b35f2570f996fc9f05f079bc0b
 
s390x:
binutils-2.17.50.0.6-12.el5.s390x.rpm
File outdated by:  RHBA-2013:1306
    MD5: 428c8b35f1edd6ebd84181bb69b3bdb1
binutils-devel-2.17.50.0.6-12.el5.s390.rpm
File outdated by:  RHBA-2013:1306
    MD5: d474272cf53c2c8969c2c205434429b9
binutils-devel-2.17.50.0.6-12.el5.s390x.rpm
File outdated by:  RHBA-2013:1306
    MD5: fe3fee5926dcd6c06f9817a2f7819ff8
 
x86_64:
binutils-2.17.50.0.6-12.el5.x86_64.rpm
File outdated by:  RHBA-2013:1306
    MD5: ce7d12a1f2d31e79c1e786adf246aacd
binutils-devel-2.17.50.0.6-12.el5.i386.rpm
File outdated by:  RHBA-2013:1306
    MD5: 2bed512a7d6b4d9cfbfa92050d5f0fa0
binutils-devel-2.17.50.0.6-12.el5.x86_64.rpm
File outdated by:  RHBA-2013:1306
    MD5: ceb05844de2a2130ce12603ab121e211
 
Red Hat Enterprise Linux Desktop (v. 5 client)

IA-32:
binutils-2.17.50.0.6-12.el5.i386.rpm
File outdated by:  RHBA-2013:1306
    MD5: 1971458c1ebf5154ec2642e7b470b37b
 
x86_64:
binutils-2.17.50.0.6-12.el5.x86_64.rpm
File outdated by:  RHBA-2013:1306
    MD5: ce7d12a1f2d31e79c1e786adf246aacd
 
(The unlinked packages above are only available from the Red Hat Network)

Bugs fixed (see bugzilla for more information)

457189 - Unable to Open vmcore from Kdump
458301 - rpmbuild produces 2MB section gap
485194 - man page for c++filt contains unsupported option



These packages are GPG signed by Red Hat for security. Our key and details on how to verify the signature are available from:
https://www.redhat.com/security/team/key/#package

The Red Hat security contact is secalert@redhat.com. More contact details at http://www.redhat.com/security/team/contact/