Skip to navigation

Bug Fix Advisory ipsec-tools bug fix update

Advisory: RHBA-2008:0513-2
Type: Bug Fix Advisory
Severity: N/A
Issued on: 2008-06-05
Last updated on: 2008-06-05
Affected Products: Red Hat Enterprise Linux (v. 5 server)
Red Hat Enterprise Linux Desktop (v. 5 client)
Red Hat Enterprise Linux EUS (v. 5.2.z server)

Details

An updated ipsec-tools package that fixes a bug is now available.

The ipsec-tools package contains configuration and management tools for
IPsec.

The kernel headers included in the previous ipsec-tools package did not
contain defines for certain algorithms supported by the current Red Hat
Enterprise Linux 5 kernel. This may have prevented binaries from compiling
on PowerPC architectures, or, in certain situations, caused the "setkey"
command to fail. In this updated package, the current kernel headers are
used, allowing the "setkey" command to support all algorithms supported by
the kernel.

Users of ipsec-tools are advised to upgrade to this updated package, which
resolves this issue.


Solution

Before applying this update, make sure that all previously-released
errata relevant to your system have been applied.

This update is available via Red Hat Network. Details on how to use
the Red Hat Network to apply this update are available at
http://kbase.redhat.com/faq/FAQ_58_10188

Updated packages

Red Hat Enterprise Linux (v. 5 server)

SRPMS:
ipsec-tools-0.6.5-9.el5_2.1.src.rpm
File outdated by:  RHSA-2008:0849
    MD5: 62f2acfd21e6411ea083e5f9d253bfee
 
IA-32:
ipsec-tools-0.6.5-9.el5_2.1.i386.rpm
File outdated by:  RHBA-2012:1249
    MD5: a9106073559adedf938365722b0c9dd4
 
IA-64:
ipsec-tools-0.6.5-9.el5_2.1.ia64.rpm
File outdated by:  RHBA-2012:1249
    MD5: 76cffc6017295ac1d4bc3a2f0eb80a14
 
PPC:
ipsec-tools-0.6.5-9.el5_2.1.ppc.rpm
File outdated by:  RHBA-2012:1249
    MD5: 52ff21755eeb8df97012b207eb62c655
 
s390x:
ipsec-tools-0.6.5-9.el5_2.1.s390x.rpm
File outdated by:  RHBA-2012:1249
    MD5: 1f6691d1e33039540bedf16954531ec8
 
x86_64:
ipsec-tools-0.6.5-9.el5_2.1.x86_64.rpm
File outdated by:  RHBA-2012:1249
    MD5: ba773f4701f156e4e732dd9b5bce8b31
 
Red Hat Enterprise Linux Desktop (v. 5 client)

SRPMS:
ipsec-tools-0.6.5-9.el5_2.1.src.rpm
File outdated by:  RHSA-2008:0849
    MD5: 62f2acfd21e6411ea083e5f9d253bfee
 
IA-32:
ipsec-tools-0.6.5-9.el5_2.1.i386.rpm
File outdated by:  RHBA-2012:1249
    MD5: a9106073559adedf938365722b0c9dd4
 
x86_64:
ipsec-tools-0.6.5-9.el5_2.1.x86_64.rpm
File outdated by:  RHBA-2012:1249
    MD5: ba773f4701f156e4e732dd9b5bce8b31
 
Red Hat Enterprise Linux EUS (v. 5.2.z server)

SRPMS:
ipsec-tools-0.6.5-9.el5_2.1.src.rpm
File outdated by:  RHSA-2008:0849
    MD5: 62f2acfd21e6411ea083e5f9d253bfee
 
IA-32:
ipsec-tools-0.6.5-9.el5_2.1.i386.rpm
File outdated by:  RHSA-2008:0849
    MD5: a9106073559adedf938365722b0c9dd4
 
IA-64:
ipsec-tools-0.6.5-9.el5_2.1.ia64.rpm
File outdated by:  RHSA-2008:0849
    MD5: 76cffc6017295ac1d4bc3a2f0eb80a14
 
PPC:
ipsec-tools-0.6.5-9.el5_2.1.ppc.rpm
File outdated by:  RHSA-2008:0849
    MD5: 52ff21755eeb8df97012b207eb62c655
 
s390x:
ipsec-tools-0.6.5-9.el5_2.1.s390x.rpm
File outdated by:  RHSA-2008:0849
    MD5: 1f6691d1e33039540bedf16954531ec8
 
x86_64:
ipsec-tools-0.6.5-9.el5_2.1.x86_64.rpm
File outdated by:  RHSA-2008:0849
    MD5: ba773f4701f156e4e732dd9b5bce8b31
 
(The unlinked packages above are only available from the Red Hat Network)

Bugs fixed (see bugzilla for more information)

448912 - [RHEL5.2][IPv6 DoD] setkey failed with ppc64 ipsec-tools, need recompile


Keywords

algorithms, setkey


These packages are GPG signed by Red Hat for security. Our key and details on how to verify the signature are available from:
https://www.redhat.com/security/team/key/#package

The Red Hat security contact is secalert@redhat.com. More contact details at http://www.redhat.com/security/team/contact/