Skip to navigation

Bug Fix Advisory mcstrans bug fix update

Advisory: RHBA-2007:1133-3
Type: Bug Fix Advisory
Severity: N/A
Issued on: 2007-12-13
Last updated on: 2007-12-13
Affected Products: Red Hat Enterprise Linux (v. 5 server)
Red Hat Enterprise Linux Desktop (v. 5 client)
Red Hat Enterprise Linux EUS (v. 5.1.z server)

Details

An updated mcstrans package that fixes a translation bug is now available.

Security-enhanced Linux is a feature of the Linux® kernel and a number of
utilities with enhanced security functionality designed to add mandatory
access controls to Linux. The Security-enhanced Linux kernel contains new
architectural components originally developed to improve the security of
the Flask operating system. These architectural components provide general
support for the enforcement of many kinds of mandatory access control
policies, including those based on the concepts of Type Enforcement®,
Role-based Access Control, and Multi-level Security.

mcstrans provides a translation daemon to translate SELinux categories from
internal representations to user-defined representations.

Bugs fixed in this updated package include:

* mcstransd incorrectly translated some MLS (Multilevel Security) labels.

* a minor memory leak was also fixed.

Users are advised to upgrade to this updated mcstrans package which
resolves these issues.


Solution

Users are advised to upgrade to this updated mcstrans package which
resolves these issues.

Updated packages

Red Hat Enterprise Linux (v. 5 server)

SRPMS:
mcstrans-0.2.6-1.el5_1.1.src.rpm
File outdated by:  RHBA-2008:0258
    MD5: 68d33f66d1187728f76b5b1b0b83920b
 
IA-32:
mcstrans-0.2.6-1.el5_1.1.i386.rpm
File outdated by:  RHBA-2009:0231
    MD5: 4b9d433fdc206f3e05b8a2fa6931412c
 
IA-64:
mcstrans-0.2.6-1.el5_1.1.ia64.rpm
File outdated by:  RHBA-2009:0231
    MD5: 6f1a3f2c7ad693dd8bad6b90652fe910
 
PPC:
mcstrans-0.2.6-1.el5_1.1.ppc.rpm
File outdated by:  RHBA-2009:0231
    MD5: c39f14d79846c1985102bf3865fedf3c
 
s390x:
mcstrans-0.2.6-1.el5_1.1.s390x.rpm
File outdated by:  RHBA-2009:0231
    MD5: d697eeab7df01c90b36f00e596b3c0da
 
x86_64:
mcstrans-0.2.6-1.el5_1.1.x86_64.rpm
File outdated by:  RHBA-2009:0231
    MD5: 6e3881b92466ca26f6d517143a3221cc
 
Red Hat Enterprise Linux Desktop (v. 5 client)

SRPMS:
mcstrans-0.2.6-1.el5_1.1.src.rpm
File outdated by:  RHBA-2008:0258
    MD5: 68d33f66d1187728f76b5b1b0b83920b
 
IA-32:
mcstrans-0.2.6-1.el5_1.1.i386.rpm
File outdated by:  RHBA-2009:0231
    MD5: 4b9d433fdc206f3e05b8a2fa6931412c
 
x86_64:
mcstrans-0.2.6-1.el5_1.1.x86_64.rpm
File outdated by:  RHBA-2009:0231
    MD5: 6e3881b92466ca26f6d517143a3221cc
 
Red Hat Enterprise Linux EUS (v. 5.1.z server)

SRPMS:
mcstrans-0.2.6-1.el5_1.1.src.rpm
File outdated by:  RHBA-2008:0258
    MD5: 68d33f66d1187728f76b5b1b0b83920b
 
IA-32:
mcstrans-0.2.6-1.el5_1.1.i386.rpm
File outdated by:  RHBA-2008:0258
    MD5: 4b9d433fdc206f3e05b8a2fa6931412c
 
IA-64:
mcstrans-0.2.6-1.el5_1.1.ia64.rpm
File outdated by:  RHBA-2008:0258
    MD5: 6f1a3f2c7ad693dd8bad6b90652fe910
 
PPC:
mcstrans-0.2.6-1.el5_1.1.ppc.rpm
File outdated by:  RHBA-2008:0258
    MD5: c39f14d79846c1985102bf3865fedf3c
 
s390x:
mcstrans-0.2.6-1.el5_1.1.s390x.rpm
File outdated by:  RHBA-2008:0258
    MD5: d697eeab7df01c90b36f00e596b3c0da
 
x86_64:
mcstrans-0.2.6-1.el5_1.1.x86_64.rpm
File outdated by:  RHBA-2008:0258
    MD5: 6e3881b92466ca26f6d517143a3221cc
 
(The unlinked packages above are only available from the Red Hat Network)


These packages are GPG signed by Red Hat for security. Our key and details on how to verify the signature are available from:
https://www.redhat.com/security/team/key/#package

The Red Hat security contact is secalert@redhat.com. More contact details at http://www.redhat.com/security/team/contact/