Skip to navigation

Bug Fix Advisory lvm2 bug fix update

Advisory: RHBA-2007:1093-4
Type: Bug Fix Advisory
Severity: N/A
Issued on: 2007-12-11
Last updated on: 2007-12-11
Affected Products: Red Hat Desktop (v. 4)
Red Hat Enterprise Linux AS (v. 4)
Red Hat Enterprise Linux AS (v. 4.6.z)
Red Hat Enterprise Linux ES (v. 4)
Red Hat Enterprise Linux ES (v. 4.6.z)
Red Hat Enterprise Linux WS (v. 4)

Details

Updated lvm2 packages that include a fix for a locking bug are
now available.

The lvm2 package contains support for Logical Volume Management (LVM).

This update fixes a bug where in certain situations, LVM2 commands used
locking incorrectly. Without this update, if any of the commands listed
below are run concurrently with other LVM commands, the command may exit
prematurely, or in very rare cases, the LVM2 metadata could become
unreadable and have to be reinstated by running the "vgcfgrestore" command.

The following LVM2 commands were affected:

* pvdisplay

* pvresize

* pvs

* vgs

* vgdisplay

* vgreduce

In clustered environments, this fix must be applied along with the
RHBA-2007:1096 lvm2-cluster advisory.

All users of lvm2 are advised to upgrade to these updated packages,
which resolve this issue.


Solution

Before applying this update, make sure that all previously-released
errata relevant to your system have been applied.

This update is available via Red Hat Network. Details on how to use
the Red Hat Network to apply this update are available at
http://kbase.redhat.com/faq/FAQ_58_10188

Updated packages

Red Hat Desktop (v. 4)

IA-32:
lvm2-2.02.27-2.el4_6.1.i386.rpm
File outdated by:  RHBA-2011:1185
    MD5: 5a0fe15b34afa16690a6ca2a15264898
 
x86_64:
lvm2-2.02.27-2.el4_6.1.x86_64.rpm
File outdated by:  RHBA-2011:1185
    MD5: 97a7473621332aefe405f0bb85938e3f
 
Red Hat Enterprise Linux AS (v. 4)

IA-32:
lvm2-2.02.27-2.el4_6.1.i386.rpm
File outdated by:  RHBA-2011:1185
    MD5: 5a0fe15b34afa16690a6ca2a15264898
 
IA-64:
lvm2-2.02.27-2.el4_6.1.ia64.rpm
File outdated by:  RHBA-2011:1185
    MD5: 5bd5b89fe6726bef43e88013f8eb1f3e
 
PPC:
lvm2-2.02.27-2.el4_6.1.ppc.rpm
File outdated by:  RHBA-2011:1185
    MD5: bb1084bdca389e15013fb4699ed4bedd
 
s390:
lvm2-2.02.27-2.el4_6.1.s390.rpm
File outdated by:  RHBA-2011:1185
    MD5: 8690303867e8e2b019b5efea00392f91
 
s390x:
lvm2-2.02.27-2.el4_6.1.s390x.rpm
File outdated by:  RHBA-2011:1185
    MD5: 9830257ec52cd24c521aa95f51591b8d
 
x86_64:
lvm2-2.02.27-2.el4_6.1.x86_64.rpm
File outdated by:  RHBA-2011:1185
    MD5: 97a7473621332aefe405f0bb85938e3f
 
Red Hat Enterprise Linux AS (v. 4.6.z)

IA-32:
lvm2-2.02.27-2.el4_6.1.i386.rpm
File outdated by:  RHBA-2008:0048
    MD5: 5a0fe15b34afa16690a6ca2a15264898
 
IA-64:
lvm2-2.02.27-2.el4_6.1.ia64.rpm
File outdated by:  RHBA-2008:0048
    MD5: 5bd5b89fe6726bef43e88013f8eb1f3e
 
PPC:
lvm2-2.02.27-2.el4_6.1.ppc.rpm
File outdated by:  RHBA-2008:0048
    MD5: bb1084bdca389e15013fb4699ed4bedd
 
s390:
lvm2-2.02.27-2.el4_6.1.s390.rpm
File outdated by:  RHBA-2008:0048
    MD5: 8690303867e8e2b019b5efea00392f91
 
s390x:
lvm2-2.02.27-2.el4_6.1.s390x.rpm
File outdated by:  RHBA-2008:0048
    MD5: 9830257ec52cd24c521aa95f51591b8d
 
x86_64:
lvm2-2.02.27-2.el4_6.1.x86_64.rpm
File outdated by:  RHBA-2008:0048
    MD5: 97a7473621332aefe405f0bb85938e3f
 
Red Hat Enterprise Linux ES (v. 4)

IA-32:
lvm2-2.02.27-2.el4_6.1.i386.rpm
File outdated by:  RHBA-2011:1185
    MD5: 5a0fe15b34afa16690a6ca2a15264898
 
IA-64:
lvm2-2.02.27-2.el4_6.1.ia64.rpm
File outdated by:  RHBA-2011:1185
    MD5: 5bd5b89fe6726bef43e88013f8eb1f3e
 
x86_64:
lvm2-2.02.27-2.el4_6.1.x86_64.rpm
File outdated by:  RHBA-2011:1185
    MD5: 97a7473621332aefe405f0bb85938e3f
 
Red Hat Enterprise Linux ES (v. 4.6.z)

IA-32:
lvm2-2.02.27-2.el4_6.1.i386.rpm
File outdated by:  RHBA-2008:0048
    MD5: 5a0fe15b34afa16690a6ca2a15264898
 
IA-64:
lvm2-2.02.27-2.el4_6.1.ia64.rpm
File outdated by:  RHBA-2008:0048
    MD5: 5bd5b89fe6726bef43e88013f8eb1f3e
 
x86_64:
lvm2-2.02.27-2.el4_6.1.x86_64.rpm
File outdated by:  RHBA-2008:0048
    MD5: 97a7473621332aefe405f0bb85938e3f
 
Red Hat Enterprise Linux WS (v. 4)

IA-32:
lvm2-2.02.27-2.el4_6.1.i386.rpm
File outdated by:  RHBA-2011:1185
    MD5: 5a0fe15b34afa16690a6ca2a15264898
 
IA-64:
lvm2-2.02.27-2.el4_6.1.ia64.rpm
File outdated by:  RHBA-2011:1185
    MD5: 5bd5b89fe6726bef43e88013f8eb1f3e
 
x86_64:
lvm2-2.02.27-2.el4_6.1.x86_64.rpm
File outdated by:  RHBA-2011:1185
    MD5: 97a7473621332aefe405f0bb85938e3f
 
(The unlinked packages above are only available from the Red Hat Network)

Bugs fixed (see bugzilla for more information)

386841 - 'cluster request failed' during vgs command



These packages are GPG signed by Red Hat for security. Our key and details on how to verify the signature are available from:
https://www.redhat.com/security/team/key/#package

The Red Hat security contact is secalert@redhat.com. More contact details at http://www.redhat.com/security/team/contact/