Red Hat Customer Portal

Skip to main content

Security Advisory Low: Red Hat Satellite IBM Java Runtime security update

Advisory: RHSA-2015:0264-1
Type: Security Advisory
Severity: Low
Issued on: 2015-02-24
Last updated on: 2015-02-24
Affected Products: Red Hat Satellite (v. 5.6 for RHEL 5)
Red Hat Satellite (v. 5.6 for RHEL 6)
CVEs (cve.mitre.org): CVE-2014-3065
CVE-2014-3068
CVE-2014-3086
CVE-2014-3566
CVE-2014-4209
CVE-2014-4218
CVE-2014-4219
CVE-2014-4227
CVE-2014-4244
CVE-2014-4252
CVE-2014-4262
CVE-2014-4263
CVE-2014-4265
CVE-2014-4288
CVE-2014-6457
CVE-2014-6458
CVE-2014-6492
CVE-2014-6493
CVE-2014-6502
CVE-2014-6503
CVE-2014-6506
CVE-2014-6511
CVE-2014-6512
CVE-2014-6515
CVE-2014-6531
CVE-2014-6532
CVE-2014-6558
CVE-2014-6585
CVE-2014-6587
CVE-2014-6591
CVE-2014-6593
CVE-2014-8891
CVE-2014-8892
CVE-2015-0395
CVE-2015-0403
CVE-2015-0406
CVE-2015-0407
CVE-2015-0408
CVE-2015-0410
CVE-2015-0412

Details

Updated java-1.6.0-ibm packages that fix several security issues are now
available for Red Hat Satellite 5.6.

Red Hat Product Security has rated this update as having Low security
impact. Common Vulnerability Scoring System (CVSS) base scores, which give
detailed severity ratings, are available for each vulnerability from the
CVE links in the References section.

This update corrects several security vulnerabilities in the IBM Java
Runtime Environment shipped as part of Red Hat Satellite 5.6. In a typical
operating environment, these are of low security risk as the runtime is not
used on untrusted applets.

Several flaws were fixed in the IBM Java 2 Runtime Environment.
(CVE-2014-3065, CVE-2014-3068, CVE-2014-3566, CVE-2014-4209, CVE-2014-4218,
CVE-2014-4219, CVE-2014-4227, CVE-2014-4244, CVE-2014-4252, CVE-2014-4262,
CVE-2014-4263, CVE-2014-4265, CVE-2014-4288, CVE-2014-6457, CVE-2014-6458,
CVE-2014-6492, CVE-2014-6493, CVE-2014-6502, CVE-2014-6503, CVE-2014-6506,
CVE-2014-6511, CVE-2014-6512, CVE-2014-6515, CVE-2014-6531, CVE-2014-6532,
CVE-2014-6558, CVE-2014-6585, CVE-2014-6587, CVE-2014-6591, CVE-2014-6593,
CVE-2014-8891, CVE-2014-8892, CVE-2015-0395, CVE-2015-0403, CVE-2015-0406,
CVE-2015-0407, CVE-2015-0408, CVE-2015-0410, CVE-2015-0412)

The CVE-2014-4262 and CVE-2014-6512 issues were discovered by Florian
Weimer of Red Hat Product Security.

Users of Red Hat Satellite 5.6 are advised to upgrade to these updated
packages, which contain the IBM Java SE 6 SR16-FP3 release. For this
update to take effect, Red Hat Satellite must be restarted
("/usr/sbin/rhn-satellite restart"), as well as all running instances of
IBM Java.


Solution

Before applying this update, make sure all previously released errata
relevant to your system have been applied.

This update is available via the Red Hat Network. Details on how to use the
Red Hat Network to apply this update are available at
https://access.redhat.com/articles/11258

Updated packages

Red Hat Satellite (v. 5.6 for RHEL 5)

SRPMS:
java-1.6.0-ibm-1.6.0.16.3-1jpp.1.el5.src.rpm
File outdated by:  RHSA-2015:1604
    MD5: 775c47eb4117c024ccef6648ab68f6c2
SHA-256: f6ca97f1e0b9e37ac9a7278c2d8d4292cbd972c40e821d5a58593a2e3031a7b4
 
s390x:
java-1.6.0-ibm-1.6.0.16.3-1jpp.1.el5.s390x.rpm
File outdated by:  RHSA-2015:1604
    MD5: 94e172ffef45a5e927d8be741a2b0177
SHA-256: 808d88b6a3289c1f38d4917ff67c325ec63b4b6b08c18bed4e423b6ccce593b3
java-1.6.0-ibm-devel-1.6.0.16.3-1jpp.1.el5.s390x.rpm
File outdated by:  RHSA-2015:1604
    MD5: 5f27e4966f6bbf53987679397d1788a2
SHA-256: 2335e4ba50602e64fb7d68f74d03d0ea3fdd41f363c7d6b645e1c98ab8d2eaa1
 
x86_64:
java-1.6.0-ibm-1.6.0.16.3-1jpp.1.el5.x86_64.rpm
File outdated by:  RHSA-2015:1604
    MD5: de882979937efd39e71494c0dcf7ac9b
SHA-256: e9b20f893449ce893725080e7b26bb4c43fa363a7919497f599811f83bb256b1
java-1.6.0-ibm-devel-1.6.0.16.3-1jpp.1.el5.x86_64.rpm
File outdated by:  RHSA-2015:1604
    MD5: f94db4b9e944b0390750363274380cc6
SHA-256: 3f4628a0196bb0e7767541f22e191694ddc902d7725435056b5bd6289e7ab800
 
Red Hat Satellite (v. 5.6 for RHEL 6)

SRPMS:
java-1.6.0-ibm-1.6.0.16.3-1jpp.1.el6.src.rpm
File outdated by:  RHSA-2015:1604
    MD5: d48aa4d2c989df41d228022177544ccb
SHA-256: 8e39a215f9843a0be18948442a15e95f727d6162beab2921b0f5c2d584a18747
 
s390x:
java-1.6.0-ibm-1.6.0.16.3-1jpp.1.el6.s390x.rpm
File outdated by:  RHSA-2015:1604
    MD5: 387eb506cb4f70428ac8e8824ba87be5
SHA-256: 2d61da548e40b619065717d36086934bdbac83b5c9d0467fd9af7b56daeeada5
java-1.6.0-ibm-devel-1.6.0.16.3-1jpp.1.el6.s390x.rpm
File outdated by:  RHSA-2015:1604
    MD5: 71bd9edcd007c58a13010c7e258299ab
SHA-256: 8432411b6c5f2834dac8ee1c4376c35c35ecc1b23e3c5474ae801fdcc86d7111
 
x86_64:
java-1.6.0-ibm-1.6.0.16.3-1jpp.1.el6.x86_64.rpm
File outdated by:  RHSA-2015:1604
    MD5: 7fb7402e6141751e633e068293f02b16
SHA-256: 6d737db42c96b0a05ad904d676d4e1d900f7442bbbd660c7d750019f9a1a6f88
java-1.6.0-ibm-devel-1.6.0.16.3-1jpp.1.el6.x86_64.rpm
File outdated by:  RHSA-2015:1604
    MD5: a1389e8ee4005a983f87d4e4e59fbfb7
SHA-256: 0619b11efd1a53f7964696539f4f7aab644397f365cb18b345a6b25d4c9ce6fe
 
(The unlinked packages above are only available from the Red Hat Network)

Bugs fixed (see bugzilla for more information)

1071210 - CVE-2014-6512 OpenJDK: DatagramSocket connected socket missing source check (Libraries, 8039509)
1075795 - CVE-2014-4262 OpenJDK: AtomicReferenceFieldUpdater missing primitive type check (Libraries, 8039520)
1119475 - CVE-2014-4244 OpenJDK: RSA blinding issues (Security, 8031346)
1119476 - CVE-2014-4263 OpenJDK: insufficient Diffie-Hellman public key validation (Security, 8037162)
1119596 - CVE-2014-4219 OpenJDK: Bytecode verification does not prevent ctor calls to this() and super() (Hotspot, 8035119)
1119608 - CVE-2014-4209 OpenJDK: SubjectDelegator protection insufficient (JMX, 8029755)
1119611 - CVE-2014-4218 OpenJDK: Clone interfaces passed to proxy methods (Libraries, 8035009)
1119613 - CVE-2014-4252 OpenJDK: Prevent instantiation of service with non-public constructor (Security, 8035004)
1119912 - CVE-2014-4227 Oracle JDK: unspecified vulnerability fixed in 6u81, 7u65 and 8u11 (Deployment)
1119913 - CVE-2014-4265 Oracle JDK: unspecified vulnerability fixed in 6u81, 7u65 and 8u11 (Deployment)
1150155 - CVE-2014-6506 OpenJDK: insufficient permission checks when setting resource bundle on system logger (Libraries, 8041564)
1150651 - CVE-2014-6531 OpenJDK: insufficient ResourceBundle name check (Libraries, 8044274)
1150669 - CVE-2014-6502 OpenJDK: LogRecord use of incorrect CL when loading ResourceBundle (Libraries, 8042797)
1151046 - CVE-2014-6457 OpenJDK: Triple Handshake attack against TLS/SSL connections (JSSE, 8037066)
1151063 - CVE-2014-6558 OpenJDK: CipherInputStream incorrect exception handling (Security, 8037846)
1151517 - CVE-2014-6511 ICU: Layout Engine ContextualSubstitution missing boundary checks (JDK 2D, 8041540)
1152756 - CVE-2014-6532 Oracle JDK: unspecified vulnerability fixed in 6u85, 7u71 and 8u25 (Deployment)
1152757 - CVE-2014-6503 Oracle JDK: unspecified vulnerability fixed in 6u85, 7u71 and 8u25 (Deployment)
1152759 - CVE-2014-6492 Oracle JDK: unspecified vulnerability fixed in 6u85, 7u71 and 8u25 (Deployment)
1152760 - CVE-2014-6493 Oracle JDK: unspecified vulnerability fixed in 6u85, 7u71 and 8u25 (Deployment)
1152761 - CVE-2014-4288 Oracle JDK: unspecified vulnerability fixed in 6u85, 7u71 and 8u25 (Deployment)
1152763 - CVE-2014-6458 Oracle JDK: unspecified vulnerability fixed in 6u85, 7u71 and 8u25 (Deployment)
1152766 - CVE-2014-6515 Oracle JDK: unspecified vulnerability fixed in 6u85, 7u71 and 8u25 (Deployment)
1152789 - CVE-2014-3566 SSL/TLS: Padding Oracle On Downgraded Legacy Encryption attack
1162554 - CVE-2014-3065 IBM JDK: privilege escalation via shared class cache
1164201 - CVE-2014-3068 IBM JDK: Java CMS keystore provider potentially allows brute-force private key recovery
1183021 - CVE-2015-0412 OpenJDK: insufficient code privileges checks (JAX-WS, 8054367)
1183023 - CVE-2015-0408 OpenJDK: incorrect context class loader use in RMI transport (RMI, 8055309)
1183031 - CVE-2015-0395 OpenJDK: phantom references handling issue in garbage collector (Hotspot, 8047125)
1183043 - CVE-2015-0407 OpenJDK: directory information leak via file chooser (Swing, 8055304)
1183044 - CVE-2015-0410 OpenJDK: DER decoder infinite loop (Security, 8059485)
1183049 - CVE-2014-6593 OpenJDK: incorrect tracking of ChangeCipherSpec during SSL/TLS handshake (JSSE, 8057555)
1183645 - CVE-2014-6585 ICU: font parsing OOB read (OpenJDK 2D, 8055489)
1183646 - CVE-2014-6591 ICU: font parsing OOB read (OpenJDK 2D, 8056276)
1183715 - CVE-2014-6587 OpenJDK: MulticastSocket NULL pointer dereference (Libraries, 8056264)
1184275 - CVE-2015-0403 Oracle JDK: unspecified vulnerability fixed in 6u91, 7u75 and 8u31 (Deployment)
1184277 - CVE-2015-0406 Oracle JDK: unspecified vulnerability fixed in 6u91, 7u75 and 8u31 (Deployment)
1189142 - CVE-2014-8891 IBM JDK: unspecified full Java sandbox bypass fixed in Feb 2015 update
1189145 - CVE-2014-8892 IBM JDK: unspecified partial Java sandbox bypass fixed in Feb 2015 update


References

https://www.redhat.com/security/data/cve/CVE-2014-3065.html
https://www.redhat.com/security/data/cve/CVE-2014-3068.html
https://www.redhat.com/security/data/cve/CVE-2014-3086.html
https://www.redhat.com/security/data/cve/CVE-2014-3566.html
https://www.redhat.com/security/data/cve/CVE-2014-4209.html
https://www.redhat.com/security/data/cve/CVE-2014-4218.html
https://www.redhat.com/security/data/cve/CVE-2014-4219.html
https://www.redhat.com/security/data/cve/CVE-2014-4227.html
https://www.redhat.com/security/data/cve/CVE-2014-4244.html
https://www.redhat.com/security/data/cve/CVE-2014-4252.html
https://www.redhat.com/security/data/cve/CVE-2014-4262.html
https://www.redhat.com/security/data/cve/CVE-2014-4263.html
https://www.redhat.com/security/data/cve/CVE-2014-4265.html
https://www.redhat.com/security/data/cve/CVE-2014-4288.html
https://www.redhat.com/security/data/cve/CVE-2014-6457.html
https://www.redhat.com/security/data/cve/CVE-2014-6458.html
https://www.redhat.com/security/data/cve/CVE-2014-6492.html
https://www.redhat.com/security/data/cve/CVE-2014-6493.html
https://www.redhat.com/security/data/cve/CVE-2014-6502.html
https://www.redhat.com/security/data/cve/CVE-2014-6503.html
https://www.redhat.com/security/data/cve/CVE-2014-6506.html
https://www.redhat.com/security/data/cve/CVE-2014-6511.html
https://www.redhat.com/security/data/cve/CVE-2014-6512.html
https://www.redhat.com/security/data/cve/CVE-2014-6515.html
https://www.redhat.com/security/data/cve/CVE-2014-6531.html
https://www.redhat.com/security/data/cve/CVE-2014-6532.html
https://www.redhat.com/security/data/cve/CVE-2014-6558.html
https://www.redhat.com/security/data/cve/CVE-2014-6585.html
https://www.redhat.com/security/data/cve/CVE-2014-6587.html
https://www.redhat.com/security/data/cve/CVE-2014-6591.html
https://www.redhat.com/security/data/cve/CVE-2014-6593.html
https://www.redhat.com/security/data/cve/CVE-2014-8891.html
https://www.redhat.com/security/data/cve/CVE-2014-8892.html
https://www.redhat.com/security/data/cve/CVE-2015-0395.html
https://www.redhat.com/security/data/cve/CVE-2015-0403.html
https://www.redhat.com/security/data/cve/CVE-2015-0406.html
https://www.redhat.com/security/data/cve/CVE-2015-0407.html
https://www.redhat.com/security/data/cve/CVE-2015-0408.html
https://www.redhat.com/security/data/cve/CVE-2015-0410.html
https://www.redhat.com/security/data/cve/CVE-2015-0412.html
https://access.redhat.com/security/updates/classification/#low
https://www.ibm.com/developerworks/java/jdk/alerts/


These packages are GPG signed by Red Hat for security. Our key and details on how to verify the signature are available from:
https://www.redhat.com/security/team/key/#package

The Red Hat security contact is secalert@redhat.com. More contact details at http://www.redhat.com/security/team/contact/