Skip to navigation

Security Advisory Important: gpdf security update

Advisory: RHSA-2009:1503-1
Type: Security Advisory
Severity: Important
Issued on: 2009-10-15
Last updated on: 2009-10-15
Affected Products: Red Hat Desktop (v. 4)
Red Hat Enterprise Linux AS (v. 4)
Red Hat Enterprise Linux AS (v. 4.8.z)
Red Hat Enterprise Linux ES (v. 4)
Red Hat Enterprise Linux ES (v. 4.8.z)
Red Hat Enterprise Linux WS (v. 4)
CVEs (cve.mitre.org): CVE-2009-0791
CVE-2009-1188
CVE-2009-3604
CVE-2009-3608
CVE-2009-3609

Details

An updated gpdf package that fixes multiple security issues is now
available for Red Hat Enterprise Linux 4.

This update has been rated as having important security impact by the Red
Hat Security Response Team.

GPdf is a viewer for Portable Document Format (PDF) files.

Multiple integer overflow flaws were found in GPdf. An attacker could
create a malicious PDF file that would cause GPdf to crash or, potentially,
execute arbitrary code when opened. (CVE-2009-0791, CVE-2009-1188,
CVE-2009-3604, CVE-2009-3608, CVE-2009-3609)

Red Hat would like to thank Adam Zabrocki for reporting the CVE-2009-3604
issue, and Chris Rohlf for reporting the CVE-2009-3608 issue.

Users are advised to upgrade to this updated package, which contains a
backported patch to correct these issues.


Solution

Before applying this update, make sure that all previously-released
errata relevant to your system have been applied.

This update is available via Red Hat Network. Details on how to use
the Red Hat Network to apply this update are available at
http://kbase.redhat.com/faq/docs/DOC-11259

Updated packages

Red Hat Desktop (v. 4)

IA-32:
gpdf-2.8.2-7.7.2.el4_8.5.i386.rpm
File outdated by:  RHSA-2010:0752
    MD5: 00b9169650f67d7491664cb683c711be
 
x86_64:
gpdf-2.8.2-7.7.2.el4_8.5.x86_64.rpm
File outdated by:  RHSA-2010:0752
    MD5: 05dab11629a17c080eb72c976964730d
 
Red Hat Enterprise Linux AS (v. 4)

IA-32:
gpdf-2.8.2-7.7.2.el4_8.5.i386.rpm
File outdated by:  RHSA-2010:0752
    MD5: 00b9169650f67d7491664cb683c711be
 
IA-64:
gpdf-2.8.2-7.7.2.el4_8.5.ia64.rpm
File outdated by:  RHSA-2010:0752
    MD5: 9a4d77cc106d28a91035c1b361e1ca4f
 
PPC:
gpdf-2.8.2-7.7.2.el4_8.5.ppc.rpm
File outdated by:  RHSA-2010:0752
    MD5: 34a0cce11529e8ae4071102eacb9f907
 
s390:
gpdf-2.8.2-7.7.2.el4_8.5.s390.rpm
File outdated by:  RHSA-2010:0752
    MD5: 1332eaf3fc937fc8f80d397e6078ec6a
 
s390x:
gpdf-2.8.2-7.7.2.el4_8.5.s390x.rpm
File outdated by:  RHSA-2010:0752
    MD5: d03efecf64033c751959374c2c9fa012
 
x86_64:
gpdf-2.8.2-7.7.2.el4_8.5.x86_64.rpm
File outdated by:  RHSA-2010:0752
    MD5: 05dab11629a17c080eb72c976964730d
 
Red Hat Enterprise Linux AS (v. 4.8.z)

IA-32:
gpdf-2.8.2-7.7.2.el4_8.5.i386.rpm
File outdated by:  RHSA-2010:0752
    MD5: 00b9169650f67d7491664cb683c711be
 
IA-64:
gpdf-2.8.2-7.7.2.el4_8.5.ia64.rpm
File outdated by:  RHSA-2010:0752
    MD5: 9a4d77cc106d28a91035c1b361e1ca4f
 
PPC:
gpdf-2.8.2-7.7.2.el4_8.5.ppc.rpm
File outdated by:  RHSA-2010:0752
    MD5: 34a0cce11529e8ae4071102eacb9f907
 
s390:
gpdf-2.8.2-7.7.2.el4_8.5.s390.rpm
File outdated by:  RHSA-2010:0752
    MD5: 1332eaf3fc937fc8f80d397e6078ec6a
 
s390x:
gpdf-2.8.2-7.7.2.el4_8.5.s390x.rpm
File outdated by:  RHSA-2010:0752
    MD5: d03efecf64033c751959374c2c9fa012
 
x86_64:
gpdf-2.8.2-7.7.2.el4_8.5.x86_64.rpm
File outdated by:  RHSA-2010:0752
    MD5: 05dab11629a17c080eb72c976964730d
 
Red Hat Enterprise Linux ES (v. 4)

IA-32:
gpdf-2.8.2-7.7.2.el4_8.5.i386.rpm
File outdated by:  RHSA-2010:0752
    MD5: 00b9169650f67d7491664cb683c711be
 
IA-64:
gpdf-2.8.2-7.7.2.el4_8.5.ia64.rpm
File outdated by:  RHSA-2010:0752
    MD5: 9a4d77cc106d28a91035c1b361e1ca4f
 
x86_64:
gpdf-2.8.2-7.7.2.el4_8.5.x86_64.rpm
File outdated by:  RHSA-2010:0752
    MD5: 05dab11629a17c080eb72c976964730d
 
Red Hat Enterprise Linux ES (v. 4.8.z)

IA-32:
gpdf-2.8.2-7.7.2.el4_8.5.i386.rpm
File outdated by:  RHSA-2010:0752
    MD5: 00b9169650f67d7491664cb683c711be
 
IA-64:
gpdf-2.8.2-7.7.2.el4_8.5.ia64.rpm
File outdated by:  RHSA-2010:0752
    MD5: 9a4d77cc106d28a91035c1b361e1ca4f
 
x86_64:
gpdf-2.8.2-7.7.2.el4_8.5.x86_64.rpm
File outdated by:  RHSA-2010:0752
    MD5: 05dab11629a17c080eb72c976964730d
 
Red Hat Enterprise Linux WS (v. 4)

IA-32:
gpdf-2.8.2-7.7.2.el4_8.5.i386.rpm
File outdated by:  RHSA-2010:0752
    MD5: 00b9169650f67d7491664cb683c711be
 
IA-64:
gpdf-2.8.2-7.7.2.el4_8.5.ia64.rpm
File outdated by:  RHSA-2010:0752
    MD5: 9a4d77cc106d28a91035c1b361e1ca4f
 
x86_64:
gpdf-2.8.2-7.7.2.el4_8.5.x86_64.rpm
File outdated by:  RHSA-2010:0752
    MD5: 05dab11629a17c080eb72c976964730d
 
(The unlinked packages above are only available from the Red Hat Network)

Bugs fixed (see bugzilla for more information)

491840 - CVE-2009-0791 xpdf: multiple integer overflows
495907 - CVE-2009-1188 xpdf/poppler: SplashBitmap integer overflow
526637 - CVE-2009-3608 xpdf/poppler: integer overflow in ObjectStream::ObjectStream (oCERT-2009-016)
526893 - CVE-2009-3609 xpdf/poppler: ImageStream::ImageStream integer overflow
526911 - CVE-2009-3604 xpdf/poppler: Splash::drawImage integer overflow and missing allocation return value check


References



These packages are GPG signed by Red Hat for security. Our key and details on how to verify the signature are available from:
https://www.redhat.com/security/team/key/#package

The Red Hat security contact is secalert@redhat.com. More contact details at http://www.redhat.com/security/team/contact/