Skip to navigation

Security Advisory Critical: firefox security update

Advisory: RHSA-2006:0758-2
Type: Security Advisory
Severity: Critical
Issued on: 2006-12-19
Last updated on: 2006-12-19
Affected Products: Red Hat Desktop (v. 4)
Red Hat Enterprise Linux AS (v. 4)
Red Hat Enterprise Linux ES (v. 4)
Red Hat Enterprise Linux WS (v. 4)
CVEs (cve.mitre.org): CVE-2006-6497
CVE-2006-6498
CVE-2006-6501
CVE-2006-6502
CVE-2006-6503
CVE-2006-6504

Details

Updated firefox packages that fix several security bugs are now available
for Red Hat Enterprise Linux 4.

This update has been rated as having critical security impact by the Red
Hat Security Response Team.

Mozilla Firefox is an open source Web browser.

Several flaws were found in the way Firefox processes certain malformed
Javascript code. A malicious web page could cause the execution of
Javascript code in such a way that could cause Firefox to crash or execute
arbitrary code as the user running Firefox. (CVE-2006-6498, CVE-2006-6501,
CVE-2006-6502, CVE-2006-6503, CVE-2006-6504)

Several flaws were found in the way Firefox renders web pages. A malicious
web page could cause the browser to crash or possibly execute arbitrary
code as the user running Firefox. (CVE-2006-6497)

Users of Firefox are advised to upgrade to these erratum packages, which
contain Firefox version 1.5.0.9 that corrects these issues.


Solution

Before applying this update, make sure all previously released errata
relevant to your system have been applied.

This update is available via Red Hat Network. To use Red Hat Network,
launch the Red Hat Update Agent with the following command:

up2date

This will start an interactive process that will result in the appropriate
RPMs being upgraded on your system.

Updated packages

Red Hat Desktop (v. 4)

SRPMS:
firefox-1.5.0.9-0.1.el4.src.rpm
File outdated by:  RHSA-2012:0142
    MD5: d0eccc79ceaea24b476d34d51e70f1f0
 
IA-32:
firefox-1.5.0.9-0.1.el4.i386.rpm
File outdated by:  RHSA-2012:0142
    MD5: bd4f815b6c088bc97ccafcd87fc7b725
 
x86_64:
firefox-1.5.0.9-0.1.el4.x86_64.rpm
File outdated by:  RHSA-2012:0142
    MD5: 6194d2a97028a49e0acb8cbfd5789776
 
Red Hat Enterprise Linux AS (v. 4)

SRPMS:
firefox-1.5.0.9-0.1.el4.src.rpm
File outdated by:  RHSA-2012:0142
    MD5: d0eccc79ceaea24b476d34d51e70f1f0
 
IA-32:
firefox-1.5.0.9-0.1.el4.i386.rpm
File outdated by:  RHSA-2012:0142
    MD5: bd4f815b6c088bc97ccafcd87fc7b725
 
IA-64:
firefox-1.5.0.9-0.1.el4.ia64.rpm
File outdated by:  RHSA-2012:0142
    MD5: dfa5106fa6372a30e0f64718f71cf03d
 
PPC:
firefox-1.5.0.9-0.1.el4.ppc.rpm
File outdated by:  RHSA-2012:0142
    MD5: f221ad6749a595fcea26b8fc62ba1d41
 
s390:
firefox-1.5.0.9-0.1.el4.s390.rpm
File outdated by:  RHSA-2012:0142
    MD5: 226743d08765bbc50be04ed340dbe426
 
s390x:
firefox-1.5.0.9-0.1.el4.s390x.rpm
File outdated by:  RHSA-2012:0142
    MD5: 7bbc9e55e747edb910c55da28a369411
 
x86_64:
firefox-1.5.0.9-0.1.el4.x86_64.rpm
File outdated by:  RHSA-2012:0142
    MD5: 6194d2a97028a49e0acb8cbfd5789776
 
Red Hat Enterprise Linux ES (v. 4)

SRPMS:
firefox-1.5.0.9-0.1.el4.src.rpm
File outdated by:  RHSA-2012:0142
    MD5: d0eccc79ceaea24b476d34d51e70f1f0
 
IA-32:
firefox-1.5.0.9-0.1.el4.i386.rpm
File outdated by:  RHSA-2012:0142
    MD5: bd4f815b6c088bc97ccafcd87fc7b725
 
IA-64:
firefox-1.5.0.9-0.1.el4.ia64.rpm
File outdated by:  RHSA-2012:0142
    MD5: dfa5106fa6372a30e0f64718f71cf03d
 
x86_64:
firefox-1.5.0.9-0.1.el4.x86_64.rpm
File outdated by:  RHSA-2012:0142
    MD5: 6194d2a97028a49e0acb8cbfd5789776
 
Red Hat Enterprise Linux WS (v. 4)

SRPMS:
firefox-1.5.0.9-0.1.el4.src.rpm
File outdated by:  RHSA-2012:0142
    MD5: d0eccc79ceaea24b476d34d51e70f1f0
 
IA-32:
firefox-1.5.0.9-0.1.el4.i386.rpm
File outdated by:  RHSA-2012:0142
    MD5: bd4f815b6c088bc97ccafcd87fc7b725
 
IA-64:
firefox-1.5.0.9-0.1.el4.ia64.rpm
File outdated by:  RHSA-2012:0142
    MD5: dfa5106fa6372a30e0f64718f71cf03d
 
x86_64:
firefox-1.5.0.9-0.1.el4.x86_64.rpm
File outdated by:  RHSA-2012:0142
    MD5: 6194d2a97028a49e0acb8cbfd5789776
 
(The unlinked packages above are only available from the Red Hat Network)

Bugs fixed (see bugzilla for more information)

219682 - CVE-2006-6497 Multiple Firefox issues (CVE-2006-6498, CVE-2006-6501, CVE-2006-6502, CVE-2006-6503, CVE-2006-6504)


References



These packages are GPG signed by Red Hat for security. Our key and details on how to verify the signature are available from:
https://www.redhat.com/security/team/key/#package

The Red Hat security contact is secalert@redhat.com. More contact details at http://www.redhat.com/security/team/contact/