Skip to navigation

Security Advisory Updated balsa and mutt packages fix vulnerabilities

Advisory: RHSA-2003:109-12
Type: Security Advisory
Severity: N/A
Issued on: 2003-04-03
Last updated on: 2003-04-03
Affected Products: Red Hat Linux 7.2
Red Hat Linux 7.3
Red Hat Linux 8.0
Red Hat Linux 9
CVEs (cve.mitre.org): CVE-2002-1090
CVE-2003-0140

Details

New Balsa, Mutt, and libesmtp packages that fix potential buffer overflow
vulnerabilities are now available.

Mutt is a text-mode email client. Balsa is a GNOME email client which
includes code from Mutt.

A potential buffer overflow in Mutt version 1.4 exists when parsing mailbox
names returned by an IMAP server. It is possible that a hostile IMAP server
could cause arbitrary code to be executed by the user running Mutt. This
issue affects versions of Mutt provided with Red Hat Linux 8.0 and Red Hat
Linux 9.

Versions 1.2 and higher of Balsa incorporate the vulnerable Mutt IMAP code
and are therefore vulnerable to this issue as well. It is possible that a
hostile IMAP server could cause arbitrary code to be executed by the user
running Balsa. This issue affects Red Hat Linux 7.2, 7.3, 8.0 and 9.

Additionally, a buffer overflow in libesmtp, an SMTP library used by Balsa,
before version 0.8.11 allows a hostile remote SMTP server to execute
arbitrary code via a certain response or cause a denial of service via long
server responses. This issue only affects versions of libesmtp provided by
Red Hat Linux 7.2 and 7.3.

Users of Mutt and Balsa are recommended to update to these erratum packages
containing updated versions of Mutt, Balsa, and libesmtp which are not
vulnerable to these issues.


Solution

Before applying this update, make sure all previously released errata
relevant to your system have been applied.

To update all RPMs for your particular architecture, run:

rpm -Fvh [filenames]

where [filenames] is a list of the RPMs you wish to upgrade. Only those
RPMs which are currently installed will be updated. Those RPMs which are
not installed but included in the list will not be updated. Note that you
can also use wildcards (*.rpm) if your current directory *only* contains the
desired RPMs.

Please note that this update is also available via Red Hat Network. Many
people find this an easier way to apply updates. To use Red Hat Network,
launch the Red Hat Update Agent with the following command:

up2date

This will start an interactive process that will result in the appropriate
RPMs being upgraded on your system.

Updated packages

Red Hat Linux 7.2

SRPMS:
ftp://updates.redhat.com/rhn/public/2703533/balsa/1.2.4-7.7.2/SRPMS/balsa-1.2.4-7.7.2.src.rpm
Missing file
    MD5: 5bab8505c792c1682072f90ec5babe6a
ftp://updates.redhat.com/rhn/repository/NULL/balsa/1.2.4-7.7.2/SRPMS/balsa-1.2.4-7.7.2.src.rpm
Missing file
    MD5: 5bab8505c792c1682072f90ec5babe6a
ftp://updates.redhat.com/rhn/public/2703533/libesmtp/0.8.12-0.7.x/SRPMS/libesmtp-0.8.12-0.7.x.src.rpm
Missing file
    MD5: d5234163353ecf276c872abf253703d9
ftp://updates.redhat.com/rhn/repository/NULL/libesmtp/0.8.12-0.7.x/SRPMS/libesmtp-0.8.12-0.7.x.src.rpm
Missing file
    MD5: d5234163353ecf276c872abf253703d9
 
IA-32:
ftp://updates.redhat.com/rhn/repository/NULL/balsa/1.2.4-7.7.2/i386/balsa-1.2.4-7.7.2.i386.rpm
Missing file
    MD5: 9a2394f555cc8ea15891e04da2e73030
ftp://updates.redhat.com/rhn/repository/NULL/libesmtp/0.8.12-0.7.x/i386/libesmtp-0.8.12-0.7.x.i386.rpm
Missing file
    MD5: f4d4ae7c3af052f43e1873169ed06036
ftp://updates.redhat.com/rhn/repository/NULL/libesmtp-devel/0.8.12-0.7.x/i386/libesmtp-devel-0.8.12-0.7.x.i386.rpm
Missing file
    MD5: 08be48e6749eaa9eee9c3c130c8e8bd5
 
IA-64:
ftp://updates.redhat.com/rhn/repository/NULL/balsa/1.2.4-7.7.2/ia64/balsa-1.2.4-7.7.2.ia64.rpm
Missing file
    MD5: fb4a47e64ac2a8e35ea98bd64f980eb5
ftp://updates.redhat.com/rhn/repository/NULL/libesmtp/0.8.12-0.7.x/ia64/libesmtp-0.8.12-0.7.x.ia64.rpm
Missing file
    MD5: f5dd08e62f829edf0d1f24a26b7ab364
ftp://updates.redhat.com/rhn/repository/NULL/libesmtp-devel/0.8.12-0.7.x/ia64/libesmtp-devel-0.8.12-0.7.x.ia64.rpm
Missing file
    MD5: af33956420acf4c8c1e551850aaec2c8
 
Red Hat Linux 7.3

SRPMS:
ftp://updates.redhat.com/rhn/repository/NULL/balsa/1.2.4-7.7.3/SRPMS/balsa-1.2.4-7.7.3.src.rpm
Missing file
    MD5: 23c4b1e9fb9e3b9d59329f878b7ddd56
ftp://updates.redhat.com/rhn/public/2703533/libesmtp/0.8.12-0.7.x/SRPMS/libesmtp-0.8.12-0.7.x.src.rpm
Missing file
    MD5: d5234163353ecf276c872abf253703d9
ftp://updates.redhat.com/rhn/repository/NULL/libesmtp/0.8.12-0.7.x/SRPMS/libesmtp-0.8.12-0.7.x.src.rpm
Missing file
    MD5: d5234163353ecf276c872abf253703d9
 
IA-32:
ftp://updates.redhat.com/rhn/repository/NULL/balsa/1.2.4-7.7.3/i386/balsa-1.2.4-7.7.3.i386.rpm
Missing file
    MD5: ef25302d3b208b76d574c1dd32baf160
ftp://updates.redhat.com/rhn/repository/NULL/libesmtp/0.8.12-0.7.x/i386/libesmtp-0.8.12-0.7.x.i386.rpm
Missing file
    MD5: f4d4ae7c3af052f43e1873169ed06036
ftp://updates.redhat.com/rhn/repository/NULL/libesmtp-devel/0.8.12-0.7.x/i386/libesmtp-devel-0.8.12-0.7.x.i386.rpm
Missing file
    MD5: 08be48e6749eaa9eee9c3c130c8e8bd5
 
Red Hat Linux 8.0

SRPMS:
ftp://updates.redhat.com/rhn/repository/NULL/balsa/1.2.4-8/SRPMS/balsa-1.2.4-8.src.rpm
Missing file
    MD5: ee54ef0139d795761ab552085100d57f
ftp://updates.redhat.com/rhn/repository/NULL/mutt/1.4.1-0.8.x/SRPMS/mutt-1.4.1-0.8.x.src.rpm
Missing file
    MD5: db56cb885a976cb82b9493a7bcad0fbc
 
IA-32:
ftp://updates.redhat.com/rhn/repository/NULL/balsa/1.2.4-8/i386/balsa-1.2.4-8.i386.rpm
Missing file
    MD5: 6e65eeccc64b858b12e8cdfdf845bae6
ftp://updates.redhat.com/rhn/repository/NULL/mutt/1.4.1-0.8.x/i386/mutt-1.4.1-0.8.x.i386.rpm
Missing file
    MD5: 074c0b649d51043349c2ca628fc7d217
 
Red Hat Linux 9

SRPMS:
ftp://updates.redhat.com/rhn/repository/NULL/balsa/2.0.6-2/SRPMS/balsa-2.0.6-2.src.rpm
Missing file
    MD5: a10d74ad40852b6dd43fdbcb51fac529
mutt-1.4.1-1.src.rpm
File outdated by:  RHSA-2004:051
    MD5: 9e6dc99dcd0adc430995776fedf89712
 
IA-32:
ftp://updates.redhat.com/rhn/repository/NULL/balsa/2.0.6-2/i386/balsa-2.0.6-2.i386.rpm
Missing file
    MD5: 26b0deca515d58111780cb510236776a
mutt-1.4.1-1.i386.rpm
File outdated by:  RHSA-2004:051
    MD5: 389f755b4702a1acb1a8f891750fe7b2
 

Bugs fixed (see bugzilla for more information)

66389 - Buffer overflow in versions < 0.8.11
86394 - Security flaw in mutt discovered by Core Security Technologies


References


Keywords

balsa, IMAP, mutt, server, UTF7, UTF8


These packages are GPG signed by Red Hat for security. Our key and details on how to verify the signature are available from:
https://www.redhat.com/security/team/key/#package

The Red Hat security contact is secalert@redhat.com. More contact details at http://www.redhat.com/security/team/contact/