Skip to navigation

Security Advisory ethereal security update

Advisory: RHSA-2003:077-13
Type: Security Advisory
Severity: Moderate
Issued on: 2003-07-08
Last updated on: 2003-07-08
Affected Products: Red Hat Enterprise Linux AS (v. 2.1)
Red Hat Enterprise Linux ES (v. 2.1)
Red Hat Enterprise Linux WS (v. 2.1)
Red Hat Linux Advanced Workstation 2.1 for the Itanium Processor
CVEs (cve.mitre.org): CVE-2003-0081
CVE-2003-0159
CVE-2003-0356
CVE-2003-0357
CVE-2003-0428
CVE-2003-0429
CVE-2003-0430
CVE-2003-0431
CVE-2003-0432

Details

Updated Ethereal packages fixing a number of remotely exploitable security
issues are now available.

Ethereal is a package designed for monitoring network traffic.

A number of security issues affect Ethereal. By exploiting these issues it
may be possible to make Ethereal crash or run arbitrary code by injecting a
purposefully malformed packet onto the wire, or by convincing someone to
read a malformed packet trace file.

Ethereal 0.9.9 and earlier allows remote attackers to cause a denial
of service (crash) and possibly execute arbitrary code via carefully
crafted SOCKS packets. The Common Vulnerabilities and Exposures project
(cve.mitre.org) has assigned the name CAN-2003-0081 to this issue.

A heap-based buffer overflow exists in the NTLMSSP code for Ethereal
0.9.9 and earlier. (CAN-2003-0159)

Multiple off-by-one vulnerabilities exist in Ethereal 0.9.11 and earlier in
the AIM, GIOP Gryphon, OSPF, PPTP, Quake, Quake2, Quake3, Rsync, SMB, SMPP,
and TSP dissectors, which do not properly use the tvb_get_nstringz and
tvb_get_nstringz0 functions. (CAN-2003-0356)

Multiple integer overflow vulnerabilities exist in Ethereal 0.9.11 and
earlier in the Mount and PPP dissectors. (CAN-2003-0357)

A vulnerability in the DCERPC dissector exists in Ethereal 0.9.12 and
earlier, allowing remote attackers to cause a denial of service (memory
consumption) via a certain NDR string. (CAN-2003-0428)

A possible buffer overflow vulnerability exists in Ethereal 0.9.12 and
earlier, caused by invalid IPv4 or IPv6 prefix lengths and possibly
triggering a buffer overflow. (CAN-2003-0429)

A vulnerability exists in Ethereal 0.9.12 and earlier, allowing remote
attackers to cause a denial of service (crash) via an invalid ASN.1 value.
(CAN-2003-0430)

The tvb_get_nstringz0 function in Ethereal 0.9.12 and earlier does not
properly handle a zero-length buffer size. (CAN-2003-0431)

Ethereal 0.9.12 and earlier does not handle certain strings properly in the
BGP, WTP, DNS, 802.11, ISAKMP, WSP, CLNP, ISIS, and RMI dissectors.
(CAN-2003-0432)

Users of Ethereal should update to these erratum packages containing
Ethereal version 0.9.13, which are not vulnerable to these issues.


Solution

Before applying this update, make sure all previously released errata
relevant to your system have been applied.

Please note that this update is available via Red Hat Network. To use Red
Hat Network, launch the Red Hat Update Agent with the following command:

up2date

This will start an interactive process that will result in the appropriate
RPMs being upgraded on your system.

Updated packages

Red Hat Enterprise Linux AS (v. 2.1)

IA-32:
ethereal-0.9.13-1.AS21.1.i386.rpm
File outdated by:  RHSA-2006:0420
    MD5: 345b90e8d7bb509a98554848d43b158d
ethereal-gnome-0.9.13-1.AS21.1.i386.rpm
File outdated by:  RHSA-2006:0420
    MD5: 44a4e6c6f66ff35626e3832c1e57fc86
 
IA-64:
ethereal-0.9.13-1.AS21.1.ia64.rpm
File outdated by:  RHSA-2006:0420
    MD5: 96bd9d8faf0f9618b9c8145bbde75266
ethereal-gnome-0.9.13-1.AS21.1.ia64.rpm
File outdated by:  RHSA-2006:0420
    MD5: 328d7cb05244132329b0bf0df3a9b8be
 
Red Hat Enterprise Linux ES (v. 2.1)

IA-32:
ethereal-0.9.13-1.AS21.1.i386.rpm
File outdated by:  RHSA-2006:0420
    MD5: 345b90e8d7bb509a98554848d43b158d
ethereal-gnome-0.9.13-1.AS21.1.i386.rpm
File outdated by:  RHSA-2006:0420
    MD5: 44a4e6c6f66ff35626e3832c1e57fc86
 
Red Hat Enterprise Linux WS (v. 2.1)

IA-32:
ethereal-0.9.13-1.AS21.1.i386.rpm
File outdated by:  RHSA-2006:0420
    MD5: 345b90e8d7bb509a98554848d43b158d
ethereal-gnome-0.9.13-1.AS21.1.i386.rpm
File outdated by:  RHSA-2006:0420
    MD5: 44a4e6c6f66ff35626e3832c1e57fc86
 
Red Hat Linux Advanced Workstation 2.1 for the Itanium Processor

IA-64:
ethereal-0.9.13-1.AS21.1.ia64.rpm
File outdated by:  RHSA-2006:0420
    MD5: 96bd9d8faf0f9618b9c8145bbde75266
ethereal-gnome-0.9.13-1.AS21.1.ia64.rpm
File outdated by:  RHSA-2006:0420
    MD5: 328d7cb05244132329b0bf0df3a9b8be
 

Bugs fixed (see bugzilla for more information)

85179 - SOCKS format string vuln in Ethereal 0.9.8/9


References


Keywords

ethereal, SOCKS


These packages are GPG signed by Red Hat for security. Our key and details on how to verify the signature are available from:
https://www.redhat.com/security/team/key/#package

The Red Hat security contact is secalert@redhat.com. More contact details at http://www.redhat.com/security/team/contact/