Skip to navigation

Security Advisory Updated PHP packages available

Advisory: RHSA-2003:017-06
Type: Security Advisory
Severity: N/A
Issued on: 2003-02-05
Last updated on: 2003-02-04
Affected Products: Red Hat Linux 8.0
CVEs (cve.mitre.org): CVE-2002-1396

Details

Updated PHP packages are available that fix a vulnerability in the
wordwrap() function and a number of compatibility bugs.

PHP is an HTML-embedded scripting language commonly used with the Apache
HTTP server.

A heap-based buffer overflow was found in the wordwrap() function in PHP
versions after 4.1.2 and before 4.3.0. If wordwrap() is used on
user-supplied input this could allow remote attackers to cause a denial of
service or execute arbitrary code.

Red Hat Linux 8.0 shipped with a version of PHP that was vulnerable to this
issue. Other Red Hat Linux distributions shipped with an earlier version
of PHP and are not vulnerable to this issue.

In addition, a number of compatiblity bugs have also been found between PHP
4.2 and Apache 2.0.

All users of PHP are advised to upgrade to these erratum packages which
contain a patch to correct these issues.


Solution

Before applying this update, make sure all previously released errata
relevant to your system have been applied.

To update all RPMs for your particular architecture, run:

rpm -Fvh [filenames]

where [filenames] is a list of the RPMs you wish to upgrade. Only those
RPMs which are currently installed will be updated. Those RPMs which are
not installed but included in the list will not be updated. Note that you
can also use wildcards (*.rpm) if your current directory *only* contains
the desired RPMs.

Please note that this update is also available via Red Hat Network. Many
people find this an easier way to apply updates. To use Red Hat Network,
launch the Red Hat Update Agent with the following command:

up2date

This will start an interactive process that will result in the appropriate
RPMs being upgraded on your system.

Updated packages

Red Hat Linux 8.0

SRPMS:
php-4.2.2-8.0.7.src.rpm
File outdated by:  RHSA-2003:204
    MD5: 6142b2ac0eb22a2f6b33724ab5f40c72
 
IA-32:
php-4.2.2-8.0.7.i386.rpm
File outdated by:  RHSA-2003:204
    MD5: ee10926c45bf9fb9cdd3694700662711
php-devel-4.2.2-8.0.7.i386.rpm
File outdated by:  RHSA-2003:204
    MD5: 370779db08cf8f7f8346b516fc4ebbde
php-imap-4.2.2-8.0.7.i386.rpm
File outdated by:  RHSA-2003:204
    MD5: ce94c1398ec3e5a2edc4455e4949da70
php-ldap-4.2.2-8.0.7.i386.rpm
File outdated by:  RHSA-2003:204
    MD5: 5a7ecb7ce8ceb67ca53f1daa15488957
php-manual-4.2.2-8.0.7.i386.rpm
File outdated by:  RHSA-2003:204
    MD5: d7d2b4aeac657ea17d5d4a3a9f72eb51
php-mysql-4.2.2-8.0.7.i386.rpm
File outdated by:  RHSA-2003:204
    MD5: 5174df281714e3bf550d5697df326be4
php-odbc-4.2.2-8.0.7.i386.rpm
File outdated by:  RHSA-2003:204
    MD5: ed2a793624ad2869da4c09f38d88bb75
php-pgsql-4.2.2-8.0.7.i386.rpm
File outdated by:  RHSA-2003:204
    MD5: dd19149ccecab409296cdb7feaf8dd2e
php-snmp-4.2.2-8.0.7.i386.rpm
File outdated by:  RHSA-2003:204
    MD5: d7b8bdc55e9cc453f1639f1c34c118ef
 

Bugs fixed (see bugzilla for more information)

74396 - safe mode not working in php-4.2.2-8.0.5
75029 - PHP with Apache 2.0: getlastmod function fails
75712 - php4 with apache 2, getenv(ANYTHING) returns blank string
75878 - Apache caches requests by default, or there is some bug around.
78586 - Invalid command php_flag


References


Keywords

PHP, wordwrap


These packages are GPG signed by Red Hat for security. Our key and details on how to verify the signature are available from:
https://www.redhat.com/security/team/key/#package

The Red Hat security contact is secalert@redhat.com. More contact details at http://www.redhat.com/security/team/contact/