Skip to navigation

Security Advisory Updated packages fix PostScript and PDF security issue

Advisory: RHSA-2002:212-06
Type: Security Advisory
Severity: N/A
Issued on: 2002-09-25
Last updated on: 2002-09-30
Affected Products: Powertools 7.0
Powertools 7.1
CVEs (cve.mitre.org): CVE-2002-0838

Details

Updated packages for ggv fix a local buffer overflow
when reading malformed PDF or PostScript files.

ggv is a user interface for the Ghostscript PostScript(R) interpreter used
to display PostScript and PDF documents on an X Window System.

Zen Parse found a local buffer overflow in gv version 3.5.8 and earlier.
ggv versions 1.0.2 and earlier contain code derived from gv and therefore
have the same vulnerability. An attacker can create a carefully crafted
malformed PDF or PostScript file in such a way that when that file is
viewed arbitrary commands can be executed.

All users of ggv are advised to upgrade to the errata packages which
contain a patch and are not vulnerable to this issue.


Solution

Before applying this update, make sure all previously released errata
relevant to your system have been applied.

To update all RPMs for your particular architecture, run:

rpm -Fvh [filenames]

where [filenames] is a list of the RPMs you wish to upgrade. Only those
RPMs which are currently installed will be updated. Those RPMs which are
not installed but included in the list will not be updated. Note that you
can also use wildcards (*.rpm) if your current directory *only* contains the
desired RPMs.

Please note that this update is also available via Red Hat Network. Many
people find this an easier way to apply updates. To use Red Hat Network,
launch the Red Hat Update Agent with the following command:

up2date

This will start an interactive process that will result in the appropriate
RPMs being upgraded on your system.

Updated packages

Powertools 7.0

SRPMS:
ftp://updates.redhat.com/rhn/public/2703533/ggv/1.0.2-5.1/SRPMS/ggv-1.0.2-5.1.src.rpm
Missing file
    MD5: c0915e40e1d512174f9c2f024399e866
ftp://updates.redhat.com/rhn/repository/NULL/ggv/1.0.2-5.1/SRPMS/ggv-1.0.2-5.1.src.rpm
Missing file
    MD5: c0915e40e1d512174f9c2f024399e866
 
Alpha:
ftp://updates.redhat.com/rhn/repository/NULL/ggv/1.0.2-5.1/alpha/ggv-1.0.2-5.1.alpha.rpm
Missing file
    MD5: 2f105b4be32d361cb5477d04f2a2fbba
 
IA-32:
ftp://updates.redhat.com/rhn/repository/NULL/ggv/1.0.2-5.1/i386/ggv-1.0.2-5.1.i386.rpm
Missing file
    MD5: afd4eab8f18ca4f03ead7c4025f99ab1
 
Powertools 7.1

SRPMS:
ftp://updates.redhat.com/rhn/public/2703533/ggv/1.0.2-5.1/SRPMS/ggv-1.0.2-5.1.src.rpm
Missing file
    MD5: c0915e40e1d512174f9c2f024399e866
ftp://updates.redhat.com/rhn/repository/NULL/ggv/1.0.2-5.1/SRPMS/ggv-1.0.2-5.1.src.rpm
Missing file
    MD5: c0915e40e1d512174f9c2f024399e866
 
Alpha:
ftp://updates.redhat.com/rhn/repository/NULL/ggv/1.0.2-5.1/alpha/ggv-1.0.2-5.1.alpha.rpm
Missing file
    MD5: 2f105b4be32d361cb5477d04f2a2fbba
 
IA-32:
ftp://updates.redhat.com/rhn/repository/NULL/ggv/1.0.2-5.1/i386/ggv-1.0.2-5.1.i386.rpm
Missing file
    MD5: afd4eab8f18ca4f03ead7c4025f99ab1
 

References


Keywords

adobe, exploit, pdf, postscript


These packages are GPG signed by Red Hat for security. Our key and details on how to verify the signature are available from:
https://www.redhat.com/security/team/key/#package

The Red Hat security contact is secalert@redhat.com. More contact details at http://www.redhat.com/security/team/contact/