Skip to navigation

Security Advisory Updated squirrelmail packages close cross-site scripting vulnerabilities

Advisory: RHSA-2002:204-10
Type: Security Advisory
Severity: N/A
Issued on: 2002-09-20
Last updated on: 2002-10-09
Affected Products: Red Hat Linux 8.0
CVEs (cve.mitre.org): CVE-2002-1131
CVE-2002-1132

Details

Updated squirrelmail packages are now available for Red Hat Linux.

SquirrelMail is a webmail package written in PHP. Two vulnerabilities
have been found that affect SquirrelMail version 1.2.7 and earlier.

Cross-site scripting vulnerabilities allow remote attackers to execute
script as other web users via addressbook.php, options.php, search.php, or
help.php.

It is possible for remote attackers to determine the absolute pathname of
the options.php script via a malformed optpage file argument, which
generates an error message when the file cannot be included in the script.

Red Hat Linux 8 shipped with SquirrelMail version 1.2.7 and is therefore
vulnerable to these issues.

All users are advised to upgrade to these errata packages containing
SquirrelMail version 1.2.8 which is not vulnerable to these issues.


Solution

Before applying this update, make sure all previously released errata
relevant to your system have been applied.

To update all RPMs for your particular architecture, run:

rpm -Fvh [filenames]

where [filenames] is a list of the RPMs you wish to upgrade. Only those
RPMs which are currently installed will be updated. Those RPMs which are
not installed but included in the list will not be updated. Note that you
can also use wildcards (*.rpm) if your current directory *only* contains the
desired RPMs.

Please note that this update is also available via Red Hat Network. Many
people find this an easier way to apply updates. To use Red Hat Network,
launch the Red Hat Update Agent with the following command:

up2date

This will start an interactive process that will result in the appropriate
RPMs being upgraded on your system.

Updated packages

Red Hat Linux 8.0

SRPMS:
squirrelmail-1.2.8-1.src.rpm
File outdated by:  RHSA-2003:112
    MD5: 2a03426b9e7b439563310c8b34f3c1cb
 
IA-32:
squirrelmail-1.2.8-1.noarch.rpm
File outdated by:  RHSA-2003:112
    MD5: de62960435fc414967ea8503e0ce721f
 

Bugs fixed (see bugzilla for more information)

74313 - SquirrelMail 1.2.7 vulnerable to XSS attacks


References


Keywords

cross-site, scripting, squirrelmail


These packages are GPG signed by Red Hat for security. Our key and details on how to verify the signature are available from:
https://www.redhat.com/security/team/key/#package

The Red Hat security contact is secalert@redhat.com. More contact details at http://www.redhat.com/security/team/contact/