Skip to navigation

Security Advisory Updated krb5 packages fix remote buffer overflow

Advisory: RHSA-2002:172-08
Type: Security Advisory
Severity: N/A
Issued on: 2002-08-02
Last updated on: 2002-08-20
Affected Products: Red Hat Linux 6.2
Red Hat Linux 7.0
Red Hat Linux 7.1
Red Hat Linux 7.2
Red Hat Linux 7.3
CVEs (cve.mitre.org): CVE-2002-0391

Details

Updated Kerberos 5 packages are now available for Red Hat Linux 6.2, 7,
7.1, 7.2, and 7.3. These updates fix a buffer overflow in the XDR decoder.

Sun RPC is a remote procedure call framework which allows clients to invoke
procedures in a server process over a network. XDR is a mechanism for
encoding data structures for use with RPC.

The Kerberos 5 network authentication system contains an RPC library which
includes an XDR decoder derived from Sun's RPC implementation. The Sun
implementation was recently demonstrated to be vulnerable to a heap
overflow. It is believed that the attacker needs to be able to
authenticate to the kadmin daemon for this attack to be successful. No
exploits are known to currently exist.

All users should upgrade to these errata packages which contain an updated
version of Kerberos 5 which is not vulnerable to this issue.


Solution

Before applying this update, make sure all previously released errata
relevant to your system have been applied.

To update all RPMs for your particular architecture, run:

rpm -Fvh [filenames]

where [filenames] is a list of the RPMs you wish to upgrade. Only those
RPMs which are currently installed will be updated. Those RPMs which are
not installed but included in the list will not be updated. Note that you
can also use wildcards (*.rpm) if your current directory *only* contains the
desired RPMs.

Please note that this update is also available via Red Hat Network. Many
people find this an easier way to apply updates. To use Red Hat Network,
launch the Red Hat Update Agent with the following command:

up2date

This will start an interactive process that will result in the appropriate
RPMs being upgraded on your system.

Updated packages

Red Hat Linux 6.2

SRPMS:
krb5-1.1.1-29.src.rpm
File outdated by:  RHSA-2002:242
    MD5: 877c253289b1838c0af51de263efbce2
 
Alpha:
krb5-configs-1.1.1-29.alpha.rpm
File outdated by:  RHSA-2002:242
    MD5: 293e9901801a9b7c93994203cb7c5fa9
krb5-devel-1.1.1-29.alpha.rpm
File outdated by:  RHSA-2002:242
    MD5: 44308ad6599a4145c9ca0f4038d4bcbc
krb5-libs-1.1.1-29.alpha.rpm
File outdated by:  RHSA-2002:242
    MD5: ed5492fd6e45b8fee9895dcff61363d6
krb5-server-1.1.1-29.alpha.rpm
File outdated by:  RHSA-2002:242
    MD5: dfc12d8135f183eb1d98e600e21f01fb
krb5-workstation-1.1.1-29.alpha.rpm
File outdated by:  RHSA-2002:242
    MD5: e7f346040bf9e3c42fd853d69cb2ef78
 
IA-32:
krb5-configs-1.1.1-29.i386.rpm
File outdated by:  RHSA-2003:051
    MD5: 9345dc3a7a579a021061bca74e6b640a
krb5-devel-1.1.1-29.i386.rpm
File outdated by:  RHSA-2003:051
    MD5: 84c97facbf59bb70dde668187fefab4c
krb5-libs-1.1.1-29.i386.rpm
File outdated by:  RHSA-2003:051
    MD5: 972ec31e6103e145a1672618b9971d3e
krb5-server-1.1.1-29.i386.rpm
File outdated by:  RHSA-2003:051
    MD5: 23f8f5f75850208b2d40dd10dc9927b5
krb5-workstation-1.1.1-29.i386.rpm
File outdated by:  RHSA-2003:051
    MD5: 4a6395c671391ed1fee6ea9e9ee33065
 
Sparc:
krb5-configs-1.1.1-29.sparc.rpm
File outdated by:  RHSA-2002:242
    MD5: 50b52160b0700d3384cf86371f7b374b
krb5-devel-1.1.1-29.sparc.rpm
File outdated by:  RHSA-2002:242
    MD5: a82f945159c05141439de0df43bb25ed
krb5-libs-1.1.1-29.sparc.rpm
File outdated by:  RHSA-2002:242
    MD5: ddcf9b4fec32e0f93da1806eb8cd72ba
krb5-server-1.1.1-29.sparc.rpm
File outdated by:  RHSA-2002:242
    MD5: db06836719bd389f056259ac3af63131
krb5-workstation-1.1.1-29.sparc.rpm
File outdated by:  RHSA-2002:242
    MD5: f99f0d9bdc7ec03c99591cf8168b93b9
 
Red Hat Linux 7.0

SRPMS:
krb5-1.2.2-14.src.rpm
File outdated by:  RHSA-2003:051
    MD5: 1703c67f82b8feaa0f76efce9ddf17d9
 
Alpha:
krb5-devel-1.2.2-14.alpha.rpm
File outdated by:  RHSA-2002:242
    MD5: f3e7ce965fafdec10fdad015fa7d079f
krb5-libs-1.2.2-14.alpha.rpm
File outdated by:  RHSA-2002:242
    MD5: 2a98e1de18a262a3fa4fbe33bf61cf7d
krb5-server-1.2.2-14.alpha.rpm
File outdated by:  RHSA-2002:242
    MD5: 49f5808a9a778fab780456f7c54d8e7b
krb5-workstation-1.2.2-14.alpha.rpm
File outdated by:  RHSA-2002:242
    MD5: 8ad075c29413edacd36fa86789a20c93
 
IA-32:
krb5-devel-1.2.2-14.i386.rpm
File outdated by:  RHSA-2003:051
    MD5: 96bf320130172f0ed00eeec4f7543bff
krb5-libs-1.2.2-14.i386.rpm
File outdated by:  RHSA-2003:051
    MD5: a76356c93f518ce52f8ed678eff39ea6
krb5-server-1.2.2-14.i386.rpm
File outdated by:  RHSA-2003:051
    MD5: 7eac994af1d0b1a0d913755dcd2931af
krb5-workstation-1.2.2-14.i386.rpm
File outdated by:  RHSA-2003:051
    MD5: d80a32bde5d7eacc3b6fc2418aa6f5d8
 
Red Hat Linux 7.1

SRPMS:
krb5-1.2.2-14.src.rpm
File outdated by:  RHSA-2003:051
    MD5: 1703c67f82b8feaa0f76efce9ddf17d9
 
Alpha:
krb5-devel-1.2.2-14.alpha.rpm
File outdated by:  RHSA-2002:242
    MD5: f3e7ce965fafdec10fdad015fa7d079f
krb5-libs-1.2.2-14.alpha.rpm
File outdated by:  RHSA-2002:242
    MD5: 2a98e1de18a262a3fa4fbe33bf61cf7d
krb5-server-1.2.2-14.alpha.rpm
File outdated by:  RHSA-2002:242
    MD5: 49f5808a9a778fab780456f7c54d8e7b
krb5-workstation-1.2.2-14.alpha.rpm
File outdated by:  RHSA-2002:242
    MD5: 8ad075c29413edacd36fa86789a20c93
 
IA-32:
krb5-devel-1.2.2-14.i386.rpm
File outdated by:  RHSA-2003:051
    MD5: 96bf320130172f0ed00eeec4f7543bff
krb5-libs-1.2.2-14.i386.rpm
File outdated by:  RHSA-2003:051
    MD5: a76356c93f518ce52f8ed678eff39ea6
krb5-server-1.2.2-14.i386.rpm
File outdated by:  RHSA-2003:051
    MD5: 7eac994af1d0b1a0d913755dcd2931af
krb5-workstation-1.2.2-14.i386.rpm
File outdated by:  RHSA-2003:051
    MD5: d80a32bde5d7eacc3b6fc2418aa6f5d8
 
IA-64:
krb5-devel-1.2.2-14.ia64.rpm
File outdated by:  RHSA-2002:242
    MD5: e81bea51555ea322fe31891bd04a7a0e
krb5-libs-1.2.2-14.ia64.rpm
File outdated by:  RHSA-2002:242
    MD5: 731a101f76a2797a3ea4b896fed78049
krb5-server-1.2.2-14.ia64.rpm
File outdated by:  RHSA-2002:242
    MD5: 16958f16d12b91c522ec50a50cd66a75
krb5-workstation-1.2.2-14.ia64.rpm
File outdated by:  RHSA-2002:242
    MD5: d364eac9c4feedfe0c6efc3eb7be1555
 
Red Hat Linux 7.2

SRPMS:
krb5-1.2.2-14.src.rpm
File outdated by:  RHSA-2003:051
    MD5: 1703c67f82b8feaa0f76efce9ddf17d9
 
IA-32:
krb5-devel-1.2.2-14.i386.rpm
File outdated by:  RHSA-2003:051
    MD5: 96bf320130172f0ed00eeec4f7543bff
krb5-libs-1.2.2-14.i386.rpm
File outdated by:  RHSA-2003:051
    MD5: a76356c93f518ce52f8ed678eff39ea6
krb5-server-1.2.2-14.i386.rpm
File outdated by:  RHSA-2003:051
    MD5: 7eac994af1d0b1a0d913755dcd2931af
krb5-workstation-1.2.2-14.i386.rpm
File outdated by:  RHSA-2003:051
    MD5: d80a32bde5d7eacc3b6fc2418aa6f5d8
 
IA-64:
krb5-devel-1.2.2-14.ia64.rpm
File outdated by:  RHSA-2003:051
    MD5: e81bea51555ea322fe31891bd04a7a0e
krb5-libs-1.2.2-14.ia64.rpm
File outdated by:  RHSA-2003:051
    MD5: 731a101f76a2797a3ea4b896fed78049
krb5-server-1.2.2-14.ia64.rpm
File outdated by:  RHSA-2003:051
    MD5: 16958f16d12b91c522ec50a50cd66a75
krb5-workstation-1.2.2-14.ia64.rpm
File outdated by:  RHSA-2003:051
    MD5: d364eac9c4feedfe0c6efc3eb7be1555
 
Red Hat Linux 7.3

SRPMS:
krb5-1.2.4-2.src.rpm
File outdated by:  RHSA-2003:051
    MD5: a809b04a80d7ea5bfc25d192b4eec681
 
IA-32:
krb5-devel-1.2.4-2.i386.rpm
File outdated by:  RHSA-2003:051
    MD5: a4a6a6904a2be6da0e68b1b176ed2b9b
krb5-libs-1.2.4-2.i386.rpm
File outdated by:  RHSA-2003:051
    MD5: 2fa946892a8194411500594d48706411
krb5-server-1.2.4-2.i386.rpm
File outdated by:  RHSA-2003:051
    MD5: a5a79b11ba6ef0e9e3f88603c6ac95a6
krb5-workstation-1.2.4-2.i386.rpm
File outdated by:  RHSA-2003:051
    MD5: 863c43cef0cddb45cb79f9539e824024
 

References



These packages are GPG signed by Red Hat for security. Our key and details on how to verify the signature are available from:
https://www.redhat.com/security/team/key/#package

The Red Hat security contact is secalert@redhat.com. More contact details at http://www.redhat.com/security/team/contact/