Red Hat Customer Portal

Skip to main content

Security Advisory Updated bind packages fix denial of service attack

Advisory: RHSA-2002:105-09
Type: Security Advisory
Severity: N/A
Issued on: 2002-06-02
Last updated on: 2002-06-04
Affected Products: Red Hat Linux 7.1
Red Hat Linux 7.2
Red Hat Linux 7.3
CVEs (cve.mitre.org): CVE-2002-0400

Details

Version 9 of the bind name prior to version 9.2.1 contain a denial of
service vulnerability.

BIND (Berkeley Internet Name Domain) is an implementation of the DNS
(Domain Name System) protocols. Versions of BIND 9 prior to 9.2.1 have a bug
that causes certain requests to the BIND name server (named) to fail an
internal consistency check, causing the name server to stop responding to
requests. This can be used by a remote attacker to cause a denial of
service (DOS) attack against name servers.

Red Hat Linux 7.1, 7.2 and 7.3 shipped with versions of BIND vulnerable to
this issue. All users of BIND are advised to upgrade to the errata
packages containing BIND 9.2.1 which is not vulnerable to this issue.


Solution

Before applying this update, make sure all previously released errata
relevant to your system have been applied.

To update all RPMs for your particular architecture, run:

rpm -Fvh [filenames]

where [filenames] is a list of the RPMs you wish to upgrade. Only those
RPMs which are currently installed will be updated. Those RPMs which are
not installed but included in the list will not be updated. Note that you
can also use wildcards (*.rpm) if your current directory *only* contains the
desired RPMs.

Please note that this update is also available via Red Hat Network. Many
people find this an easier way to apply updates. To use Red Hat Network,
launch the Red Hat Update Agent with the following command:

up2date

This will start an interactive process that will result in the appropriate
RPMs being upgraded on your system.

Updated packages

Red Hat Linux 7.1

SRPMS:
bind-9.2.1-0.70.src.rpm
File outdated by:  RHSA-2002:133
    MD5: b7c3a3e21b75f3cc3b67891988c3a061
 
Alpha:
bind-9.2.1-0.70.alpha.rpm
File outdated by:  RHSA-2002:133
    MD5: 99d1b6ba14c3df1c5f31a3d4e2627095
bind-devel-9.2.1-0.70.alpha.rpm
File outdated by:  RHSA-2002:133
    MD5: a6c926dd242e6248cd3fd7e830f09f2d
bind-utils-9.2.1-0.70.alpha.rpm
File outdated by:  RHSA-2002:133
    MD5: 32c028a6a58726fcb66fcd59a2540696
 
IA-32:
bind-9.2.1-0.70.i386.rpm
File outdated by:  RHSA-2002:133
    MD5: eaf7057b6f168b79f4dc31956e7fdc8e
bind-devel-9.2.1-0.70.i386.rpm
File outdated by:  RHSA-2002:133
    MD5: 210292b24525009ee5c7cdf2b8c4b7a8
bind-utils-9.2.1-0.70.i386.rpm
File outdated by:  RHSA-2002:133
    MD5: d3229a5c3ab3b30a64e923d15edbe3bf
 
IA-64:
bind-9.2.1-0.70.ia64.rpm
File outdated by:  RHSA-2002:133
    MD5: b05d4ff48a2cd89babf50e8097489245
bind-devel-9.2.1-0.70.ia64.rpm
File outdated by:  RHSA-2002:133
    MD5: e41811e4bfc33aad40e609a8c71cace3
bind-utils-9.2.1-0.70.ia64.rpm
File outdated by:  RHSA-2002:133
    MD5: 8737f157ddb70f1e272d34c6448bf0bf
 
Red Hat Linux 7.2

SRPMS:
bind-9.2.1-0.7x.src.rpm
File outdated by:  RHSA-2002:133
    MD5: 2443a2f29ddf9af62eb48038bde0b9ee
 
IA-32:
bind-9.2.1-0.7x.i386.rpm
File outdated by:  RHSA-2002:133
    MD5: 16f6b21979fcbd90a5b044f5208ef20b
bind-devel-9.2.1-0.7x.i386.rpm
File outdated by:  RHSA-2002:133
    MD5: e6c63bf2190d50a3b014586304b97465
bind-utils-9.2.1-0.7x.i386.rpm
File outdated by:  RHSA-2002:133
    MD5: 6ca180c3e8ce4477cddd734843374e18
 
IA-64:
bind-9.2.1-0.7x.ia64.rpm
File outdated by:  RHSA-2002:133
    MD5: 50fba0e5fa8a33cc4db9020f76140824
bind-devel-9.2.1-0.7x.ia64.rpm
File outdated by:  RHSA-2002:133
    MD5: 983dd7df3f5ce85e50fcc92ec6055b05
bind-utils-9.2.1-0.7x.ia64.rpm
File outdated by:  RHSA-2002:133
    MD5: 927cd81e750a524dace2d4f085b10976
 
Red Hat Linux 7.3

SRPMS:
bind-9.2.1-0.7x.src.rpm
File outdated by:  RHSA-2002:133
    MD5: 2443a2f29ddf9af62eb48038bde0b9ee
 
IA-32:
bind-9.2.1-0.7x.i386.rpm
File outdated by:  RHSA-2002:133
    MD5: 16f6b21979fcbd90a5b044f5208ef20b
bind-devel-9.2.1-0.7x.i386.rpm
File outdated by:  RHSA-2002:133
    MD5: e6c63bf2190d50a3b014586304b97465
bind-utils-9.2.1-0.7x.i386.rpm
File outdated by:  RHSA-2002:133
    MD5: 6ca180c3e8ce4477cddd734843374e18
 

References


Keywords

bind, consistancy, dos, srv


These packages are GPG signed by Red Hat for security. Our key and details on how to verify the signature are available from:
https://www.redhat.com/security/team/key/#package

The Red Hat security contact is secalert@redhat.com. More contact details at http://www.redhat.com/security/team/contact/