Skip to navigation

Security Advisory New PHP packages fix vulnerability in safemode

Advisory: RHSA-2002:102-33
Type: Security Advisory
Severity: N/A
Issued on: 2002-05-27
Last updated on: 2002-08-23
Affected Products: Red Hat Linux 7.0
Red Hat Linux 7.1
Red Hat Linux 7.2
Red Hat Linux 7.3
CVEs (cve.mitre.org): CVE-2001-1246

Details

PHP versions earlier than 4.1.0 contain a vulnerability that could allow
arbitrary commands to be executed.

[updated 22 Aug 2002]
The initial set of errata packages contained an incorrect set of
dependencies. This meant that a number of packages would need to be
installed before php that were not essential to the operation of php.
Updated errata packages are included with this advisory that have corrected
dependencies.

PHP is an HTML-embedded scripting language commonly used with Apache. PHP
versions 4.0.5 through 4.1.0 in safe mode do not properly cleanse
the 5th parameter to the mail() function. This vulnerability allows local
users and possibly remote attackers to execute arbitrary commands via shell
metacharacters.

The Common Vulnerabilities and Exposures project (cve.mitre.org) has
assigned the name CAN-2001-1246 to this issue.

Red Hat Linux version 7.2 shipped with PHP 4.0.6 by default, which is
vulnerable to this issue.

Versions of Red Hat Linux before 7.2 shipped with an earlier version of PHP
not vulnerable to this issue. However, if the the most recent errata
(RHSA-2002:035) was applied to these systems, then they are vulnerable
and should be upgraded.

It is highly recommended that all users of PHP upgrade to these errata
packages, which are not vulnerable to this issue.

Please Note:

This PHP errata enforces memory limits on the size of the PHP process to
prevent a badly generated script from becoming a possible source for a
denial of service attack. The default process size is 8Mb though you can
adjust this as you deem necessary thought the php.ini directive
memory_limit. For example, to change the process memory limit to 4MB, add
the following:

memory_limit 4194304

Important Note:

There are special instructions you should follow regarding your
/etc/php.ini configuration file in the "Solution" section below.


Solution

Please note that the /etc/php.ini configuration file is not replaced or
overwritten. You should carefully review your configuration file and adapt
it to your server or service functions.

Before applying this update, make sure all previously released errata
relevant to your system have been applied.

To update all RPMs for your particular architecture, run:

rpm -Fvh [filenames]

where [filenames] is a list of the RPMs you wish to upgrade. Only those
RPMs which are currently installed will be updated. Those RPMs which are
not installed but included in the list will not be updated. Note that you
can also use wildcards (*.rpm) if your current directory *only* contains
the
desired RPMs.

Please note that this update is also available via Red Hat Network. Many
people find this an easier way to apply updates. To use Red Hat Network,
launch the Red Hat Update Agent with the following command:

up2date

This will start an interactive process that will result in the appropriate
RPMs being upgraded on your system.

Updated packages

Red Hat Linux 7.0

SRPMS:
php-4.1.2-7.0.4.src.rpm
File outdated by:  RHSA-2002:213
    MD5: 0b41437045c40a75621a0efcf0aaa802
 
Alpha:
php-4.1.2-7.0.4.alpha.rpm
File outdated by:  RHSA-2002:213
    MD5: d19cbf341d507047e83791319486fa32
php-devel-4.1.2-7.0.4.alpha.rpm
File outdated by:  RHSA-2002:213
    MD5: 1dd9841b8e0c9424cdf9370cfcf26fb3
php-imap-4.1.2-7.0.4.alpha.rpm
File outdated by:  RHSA-2002:213
    MD5: a82bd4d129454490c8c1e76340951b46
php-ldap-4.1.2-7.0.4.alpha.rpm
File outdated by:  RHSA-2002:213
    MD5: 742c01e25ed69bf5658655df7bec2e56
php-manual-4.1.2-7.0.4.alpha.rpm
File outdated by:  RHSA-2002:213
    MD5: a91eba1a833d041156590264d052e234
php-mysql-4.1.2-7.0.4.alpha.rpm
File outdated by:  RHSA-2002:213
    MD5: 26f0669ebbaef0921572e41985820be7
php-odbc-4.1.2-7.0.4.alpha.rpm
File outdated by:  RHSA-2002:213
    MD5: f9aff41fdb353585432e44fcae4a1e70
php-pgsql-4.1.2-7.0.4.alpha.rpm
File outdated by:  RHSA-2002:213
    MD5: b0c33fde43bda1ba06ac80f3927fbf0e
php-snmp-4.1.2-7.0.4.alpha.rpm
File outdated by:  RHSA-2002:213
    MD5: 23a29b0dc6b4889d3988e48953bb5e7c
 
IA-32:
php-4.1.2-7.0.4.i386.rpm
File outdated by:  RHSA-2002:213
    MD5: da6a2731130c5fc5843be831b89a6c5e
php-devel-4.1.2-7.0.4.i386.rpm
File outdated by:  RHSA-2002:213
    MD5: af5ba3f8e5b406e70fc9a56b97e6f0cf
php-imap-4.1.2-7.0.4.i386.rpm
File outdated by:  RHSA-2002:213
    MD5: 061f5d30c38edd868aa3483c700a8393
php-ldap-4.1.2-7.0.4.i386.rpm
File outdated by:  RHSA-2002:213
    MD5: c501cfabd7d46b98734aa9372a21e197
php-manual-4.1.2-7.0.4.i386.rpm
File outdated by:  RHSA-2002:213
    MD5: 0264c06fa6c7336be96d392eb60ec012
php-mysql-4.1.2-7.0.4.i386.rpm
File outdated by:  RHSA-2002:213
    MD5: f7d9329fa535512db0dcdb0de70db612
php-odbc-4.1.2-7.0.4.i386.rpm
File outdated by:  RHSA-2002:213
    MD5: 41bdc7c4489fd862d22bbd0d167e2a89
php-pgsql-4.1.2-7.0.4.i386.rpm
File outdated by:  RHSA-2002:213
    MD5: bec86ec5f2f135d86db6fe82914d8c3d
php-snmp-4.1.2-7.0.4.i386.rpm
File outdated by:  RHSA-2002:213
    MD5: e38231849c528ba56c16bd3a62a07ae5
 
Red Hat Linux 7.1

SRPMS:
php-4.1.2-7.1.4.src.rpm
File outdated by:  RHSA-2002:213
    MD5: 25363222f198e06fd014a17f61d399c1
 
Alpha:
php-4.1.2-7.1.4.alpha.rpm
File outdated by:  RHSA-2002:213
    MD5: 0b981b347876be5102a417118fcf82f7
php-devel-4.1.2-7.1.4.alpha.rpm
File outdated by:  RHSA-2002:213
    MD5: 376f0ba2417a73c20971bac793c2a6b2
php-imap-4.1.2-7.1.4.alpha.rpm
File outdated by:  RHSA-2002:213
    MD5: e0965aa5e3367772caee64cf9c44db35
php-ldap-4.1.2-7.1.4.alpha.rpm
File outdated by:  RHSA-2002:213
    MD5: edc064064362b9a15367bc3bf169c107
php-manual-4.1.2-7.1.4.alpha.rpm
File outdated by:  RHSA-2002:213
    MD5: 724461c6a76eecdfccb63cfb01458392
php-mysql-4.1.2-7.1.4.alpha.rpm
File outdated by:  RHSA-2002:213
    MD5: ecd1d009a986c2a48a0043e10ea1ea89
php-odbc-4.1.2-7.1.4.alpha.rpm
File outdated by:  RHSA-2002:213
    MD5: 0706906a29c0d04e6d39c1ffd1b89f75
php-pgsql-4.1.2-7.1.4.alpha.rpm
File outdated by:  RHSA-2002:213
    MD5: d35f47bff803c587b8b9cddbb105d562
php-snmp-4.1.2-7.1.4.alpha.rpm
File outdated by:  RHSA-2002:213
    MD5: e9daea25d5272bd85c5bdf53c1361021
 
IA-32:
php-4.1.2-7.1.4.i386.rpm
File outdated by:  RHSA-2002:213
    MD5: 70ec8a2a768f4d2d75b09c2f4c3021b3
php-devel-4.1.2-7.1.4.i386.rpm
File outdated by:  RHSA-2002:213
    MD5: c389024233a9f6ea45f274204e684649
php-imap-4.1.2-7.1.4.i386.rpm
File outdated by:  RHSA-2002:213
    MD5: f2370d2afa121c182d071481f37c5f68
php-ldap-4.1.2-7.1.4.i386.rpm
File outdated by:  RHSA-2002:213
    MD5: 8132fd82f44c6754da7c38c3b780fd6c
php-manual-4.1.2-7.1.4.i386.rpm
File outdated by:  RHSA-2002:213
    MD5: f749ef4fb706aa1abe100fad7f14fe14
php-mysql-4.1.2-7.1.4.i386.rpm
File outdated by:  RHSA-2002:213
    MD5: c9f617419447ac5115e29271739ea01b
php-odbc-4.1.2-7.1.4.i386.rpm
File outdated by:  RHSA-2002:213
    MD5: bbad4b8a43865ebf421c840bda368825
php-pgsql-4.1.2-7.1.4.i386.rpm
File outdated by:  RHSA-2002:213
    MD5: ad661fc73bb9d1a909fc5d80419c5a69
php-snmp-4.1.2-7.1.4.i386.rpm
File outdated by:  RHSA-2002:213
    MD5: ca5343b811e08ada707163e9d28ad05d
 
IA-64:
php-4.1.2-7.1.4.ia64.rpm
File outdated by:  RHSA-2002:213
    MD5: e262f5c519bb441ea316aa23a5e0a52d
php-devel-4.1.2-7.1.4.ia64.rpm
File outdated by:  RHSA-2002:213
    MD5: 23f04ca87310746866bb2f1430ff479f
php-imap-4.1.2-7.1.4.ia64.rpm
File outdated by:  RHSA-2002:213
    MD5: 2e203005498d8d657557b24cdada9338
php-ldap-4.1.2-7.1.4.ia64.rpm
File outdated by:  RHSA-2002:213
    MD5: 58576c78ff7eb848a098640fa1b722bb
php-manual-4.1.2-7.1.4.ia64.rpm
File outdated by:  RHSA-2002:213
    MD5: 731994f24d160ab46815f82e0fd3bf4e
php-mysql-4.1.2-7.1.4.ia64.rpm
File outdated by:  RHSA-2002:213
    MD5: d18fad97cbfcff02b2de730136bca153
php-odbc-4.1.2-7.1.4.ia64.rpm
File outdated by:  RHSA-2002:213
    MD5: 25a294b6560c93c7f6d7d9e6e6c23b96
php-pgsql-4.1.2-7.1.4.ia64.rpm
File outdated by:  RHSA-2002:213
    MD5: 5877ef7f6ba5b59e11710e6741f29b8b
php-snmp-4.1.2-7.1.4.ia64.rpm
File outdated by:  RHSA-2002:213
    MD5: 89a3fea6b3dd635fd2f623db892459cc
 
Red Hat Linux 7.2

SRPMS:
php-4.1.2-7.2.4.src.rpm
File outdated by:  RHSA-2002:213
    MD5: 02111cbb0e24a8fc24fa98a945f1a1b0
 
IA-32:
php-4.1.2-7.2.4.i386.rpm
File outdated by:  RHSA-2002:213
    MD5: e839ed8152651ba384de934351d107e3
php-devel-4.1.2-7.2.4.i386.rpm
File outdated by:  RHSA-2002:213
    MD5: 69d14ab6495c760afb921d2d172c9825
php-imap-4.1.2-7.2.4.i386.rpm
File outdated by:  RHSA-2002:213
    MD5: ae4c32e76d67b72c596362ef02d5a8f7
php-ldap-4.1.2-7.2.4.i386.rpm
File outdated by:  RHSA-2002:213
    MD5: 6e457168f5184ccc39e6fbba90a17fdb
php-manual-4.1.2-7.2.4.i386.rpm
File outdated by:  RHSA-2002:213
    MD5: a9c15c5aaa6ebe36bdae830c9cb22b13
php-mysql-4.1.2-7.2.4.i386.rpm
File outdated by:  RHSA-2002:213
    MD5: f081ab074a39eee36eaa552099cdc154
php-odbc-4.1.2-7.2.4.i386.rpm
File outdated by:  RHSA-2002:213
    MD5: 335b3800638659b860fb3cc1e714d272
php-pgsql-4.1.2-7.2.4.i386.rpm
File outdated by:  RHSA-2002:213
    MD5: bdcc514642a7778fe6295fe26971d951
php-snmp-4.1.2-7.2.4.i386.rpm
File outdated by:  RHSA-2002:213
    MD5: c23f95b746e05858d8876d588699f3c5
 
IA-64:
php-4.1.2-7.2.4.ia64.rpm
File outdated by:  RHSA-2002:213
    MD5: 7dcd414ecc6ad4b238aabad9224dba24
php-devel-4.1.2-7.2.4.ia64.rpm
File outdated by:  RHSA-2002:213
    MD5: 950045173dba2a8e05016942c68944c9
php-imap-4.1.2-7.2.4.ia64.rpm
File outdated by:  RHSA-2002:213
    MD5: d1a92f3445614ca4f3caef4a7bd65575
php-ldap-4.1.2-7.2.4.ia64.rpm
File outdated by:  RHSA-2002:213
    MD5: eb85c9b3a521b86fcf39be457f2e1408
php-manual-4.1.2-7.2.4.ia64.rpm
File outdated by:  RHSA-2002:213
    MD5: e7cf5879e6f938b8406090665c7b0aca
php-mysql-4.1.2-7.2.4.ia64.rpm
File outdated by:  RHSA-2002:213
    MD5: f895ac8bf6dbe0f6dfc6607fe97e29bd
php-odbc-4.1.2-7.2.4.ia64.rpm
File outdated by:  RHSA-2002:213
    MD5: 2627cc076d39753e174ca6aebcda2bc9
php-pgsql-4.1.2-7.2.4.ia64.rpm
File outdated by:  RHSA-2002:213
    MD5: 4dcdf9471be5f28aabc9d07a805a0e6b
php-snmp-4.1.2-7.2.4.ia64.rpm
File outdated by:  RHSA-2002:213
    MD5: 6b130fb5c981680956e14d89364628b1
 
Red Hat Linux 7.3

SRPMS:
php-4.1.2-7.3.4.src.rpm
File outdated by:  RHSA-2002:213
    MD5: 4e764de81a09fac9b5b1dc3b0f828eb1
 
IA-32:
php-4.1.2-7.3.4.i386.rpm
File outdated by:  RHSA-2002:213
    MD5: d1169588a3c3ab85d5265d34fde8806a
php-devel-4.1.2-7.3.4.i386.rpm
File outdated by:  RHSA-2002:213
    MD5: 7ea42bcd8bf08bea6ff5c1db0fb4e248
php-imap-4.1.2-7.3.4.i386.rpm
File outdated by:  RHSA-2002:213
    MD5: c61e39189aa4607586c23ab1540934b8
php-ldap-4.1.2-7.3.4.i386.rpm
File outdated by:  RHSA-2002:213
    MD5: 71d8b154d4c81e119e538f2138743140
php-manual-4.1.2-7.3.4.i386.rpm
File outdated by:  RHSA-2002:213
    MD5: d00c3d696c0cdd5c6423bfc5b06f9a42
php-mysql-4.1.2-7.3.4.i386.rpm
File outdated by:  RHSA-2002:213
    MD5: 9aefe56037295f49d9e66278f8744b45
php-odbc-4.1.2-7.3.4.i386.rpm
File outdated by:  RHSA-2002:213
    MD5: 1d3845004355f7da953eefbcf36d5590
php-pgsql-4.1.2-7.3.4.i386.rpm
File outdated by:  RHSA-2002:213
    MD5: 565b16d8b5f46f330a2df84a83ff5cb9
php-snmp-4.1.2-7.3.4.i386.rpm
File outdated by:  RHSA-2002:213
    MD5: b770be9b8acb97c596b050de8de55189
 

Bugs fixed (see bugzilla for more information)

72007 - php-4.1.2-7.3.3 update contains devel requires


References


Keywords

5th, mail, parameter, PHP, safemode


These packages are GPG signed by Red Hat for security. Our key and details on how to verify the signature are available from:
https://www.redhat.com/security/team/key/#package

The Red Hat security contact is secalert@redhat.com. More contact details at http://www.redhat.com/security/team/contact/