Skip to navigation

Enhancement Advisory php-pecl-memcache bug fix and enhancement update

Advisory: RHEA-2011:0794-1
Type: Product Enhancement Advisory
Severity: N/A
Issued on: 2011-05-19
Last updated on: 2011-05-19
Affected Products: Red Hat Enterprise Linux Server (v. 6)
Red Hat Enterprise Linux Workstation (v. 6)

Details

An updated php-pecl-memcache package that fixes multiple bugs and adds one
enhancement is now available for Red Hat Enterprise 6.

The php-pecl-memcache package enables PHP scripts to use the memcached caching
daemon.

The php-pecl-memcache package has been rebased to version 3.0.5 which fixes
multiple bugs and adds MemcachePool class support for the findServer() method.
(BZ#638887)

This update fixes the following bugs:

* Previously, the "delete" methods failed for some memcached server versions due
to a protocol error. With this update, the "delete" method works as expected.
(BZ#638887)

* * Previously, integer, float, and boolean values with enabled compression
could not be retrieved successfully due to an issue with the compression flag.
With this update, stored values are retrieved successfully. (BZ#638892)

* Previously, the memcache module aborted with a segmentation fault on the
64-bit PowerPC platform. This update resolves this problem and memcache runs on
the 64-bit PowerPC architecture as expected. (BZ#672363)

* Previously, php-pecl-memcache contained extra characters after %{?dist}. This
update deletes these characters. (BZ#604559)

All php-pecl-memcache users are advised to upgrade to this updated package,
which fixes these bugs and adds this enhancement.


Solution

Before applying this update, make sure that all previously-released errata
relevant to your system have been applied.

This update is available via Red Hat Network. Details on how to use the Red
Hat Network to apply this update are available at
https://access.redhat.com/kb/docs/DOC-11259

Updated packages

Red Hat Enterprise Linux Server (v. 6)

SRPMS:
php-pecl-memcache-3.0.5-3.el6.src.rpm
File outdated by:  RHBA-2012:0927
    MD5: 73d22685dc4d6faf1f4a2e105ba56cab
SHA-256: 0f3c9116ded36feadc58bf42c244ceb1a67a8cbbbd799e1bec8ac5d02d05a43a
 
IA-32:
php-pecl-memcache-3.0.5-3.el6.i686.rpm
File outdated by:  RHBA-2012:0927
    MD5: 2dfd12d3b8cf99052c21cbd14476f48a
SHA-256: 6d269b9babae77bc88bf2547c442fe48614848744ed5673ed7b0a598dbfaeca0
php-pecl-memcache-debuginfo-3.0.5-3.el6.i686.rpm
File outdated by:  RHBA-2012:0927
    MD5: 434f990da84934e839219394c3d61b1f
SHA-256: e59ad49eef17cef804f62cd8b332b6dfb138e211da2e6917065a32b05d9c2893
 
PPC:
php-pecl-memcache-3.0.5-3.el6.ppc64.rpm
File outdated by:  RHBA-2012:0927
    MD5: 22c735eeee757e83dfd90a11c210272a
SHA-256: 3c0a58330001440d80a9f83c0c3072a4fa10d52c22bdaadbb29d02a25327fd89
php-pecl-memcache-debuginfo-3.0.5-3.el6.ppc64.rpm
File outdated by:  RHBA-2012:0927
    MD5: 654decc9e838eba9a238e2bd1f1ef425
SHA-256: 27bcf100245df32de37c210030791181bd7471cc26a5a47a56b13de1414c2620
 
s390x:
php-pecl-memcache-3.0.5-3.el6.s390x.rpm
File outdated by:  RHBA-2012:0927
    MD5: 40f77a75d93eecc629c141e3979c323c
SHA-256: 1a8940baf6318bf9fb7450307c905154a0a646a8a38149175cc97dbac10660d0
php-pecl-memcache-debuginfo-3.0.5-3.el6.s390x.rpm
File outdated by:  RHBA-2012:0927
    MD5: bb99640fda2f6e2031459cc80ffcdd74
SHA-256: 154aeb729fe003761d489cc248e98bcce99701941a928ee5133e4e40da91fd0c
 
x86_64:
php-pecl-memcache-3.0.5-3.el6.x86_64.rpm
File outdated by:  RHBA-2012:0927
    MD5: d59becc7724cd538a3b366af2577ba84
SHA-256: 89ea3b9612bd917bacaa852629a58370a4fffe6ced8d47e6067e50b3ac39080f
php-pecl-memcache-debuginfo-3.0.5-3.el6.x86_64.rpm
File outdated by:  RHBA-2012:0927
    MD5: 0c21e14f64215049074388d5891cb9b4
SHA-256: fcf1bee8f519ad5ac67ca78d1b86a69915be73353ec1e9c5e4cc5f00dc9cbe10
 
Red Hat Enterprise Linux Workstation (v. 6)

SRPMS:
php-pecl-memcache-3.0.5-3.el6.src.rpm
File outdated by:  RHBA-2012:0927
    MD5: 73d22685dc4d6faf1f4a2e105ba56cab
SHA-256: 0f3c9116ded36feadc58bf42c244ceb1a67a8cbbbd799e1bec8ac5d02d05a43a
 
IA-32:
php-pecl-memcache-3.0.5-3.el6.i686.rpm
File outdated by:  RHBA-2012:0927
    MD5: 2dfd12d3b8cf99052c21cbd14476f48a
SHA-256: 6d269b9babae77bc88bf2547c442fe48614848744ed5673ed7b0a598dbfaeca0
php-pecl-memcache-debuginfo-3.0.5-3.el6.i686.rpm
File outdated by:  RHBA-2012:0927
    MD5: 434f990da84934e839219394c3d61b1f
SHA-256: e59ad49eef17cef804f62cd8b332b6dfb138e211da2e6917065a32b05d9c2893
 
x86_64:
php-pecl-memcache-3.0.5-3.el6.x86_64.rpm
File outdated by:  RHBA-2012:0927
    MD5: d59becc7724cd538a3b366af2577ba84
SHA-256: 89ea3b9612bd917bacaa852629a58370a4fffe6ced8d47e6067e50b3ac39080f
php-pecl-memcache-debuginfo-3.0.5-3.el6.x86_64.rpm
File outdated by:  RHBA-2012:0927
    MD5: 0c21e14f64215049074388d5891cb9b4
SHA-256: fcf1bee8f519ad5ac67ca78d1b86a69915be73353ec1e9c5e4cc5f00dc9cbe10
 
(The unlinked packages above are only available from the Red Hat Network)

Bugs fixed (see bugzilla for more information)

604559 - php-pecl-memcache has extra characters after %{?dist}
638887 - php-pecl-memcache extension broken due to a "protocol error"
638892 - Retrieving stored compressed integer, float, and boolean values fails
696649 - [abrt] php-cli-5.3.3-3.el6: _zend_mm_alloc_int: Process /usr/bin/php was killed by signal 11 (SIGSEGV)



These packages are GPG signed by Red Hat for security. Our key and details on how to verify the signature are available from:
https://www.redhat.com/security/team/key/#package

The Red Hat security contact is secalert@redhat.com. More contact details at http://www.redhat.com/security/team/contact/