Bug Fix Advisory yum-rhn-plugin bug fix update

Advisory: RHBA-2017:0509-1
Type: Bug Fix Advisory
Severity: N/A
Issued on: 2017-03-14
Last updated on: 2017-03-14
Affected Products: Red Hat Enterprise Linux HPC Node EUS (v. 7.2)
Red Hat Enterprise Linux Server AUS (v. 7.2)
Red Hat Enterprise Linux Server EUS (v. 7.2)
Red Hat Enterprise Linux Server TUS (v. 7.2)

Details

An updated yum-rhn-plugin package that fixes one bug is now available for Red
Hat Enterprise Linux 7.2 Extended Update Support.

The yum-rhn-plugin package provides support for connecting to Red Hat Network
(RHN) and Red Hat Satellite server. Systems registered with RHN are able to
update and install packages from Red Hat Network.

This update fixes the following bug:

* Previously, the yum-rhn-plugin package sent malformed request headers. As a
consequence, the Red Hat Satellite server failed to download repository metadata
when a Red Hat Satellite server ran the httpd package version 2.2.15 or later,
and strict-white space-enforcement mode was enabled. The bug has been fixed, so
that now yum-rhn-plugin sends correct HTTP request headers, and packages are now
installed and updated as expected. (BZ#1426702)

Users of yum-rhn-plugin are advised to upgrade to this updated package, which
fixes this bug.


Solution

Before applying this update, make sure all previously released errata
relevant to your system have been applied.

For details on how to apply this update, refer to:

https://access.redhat.com/articles/11258

Updated packages

Red Hat Enterprise Linux HPC Node EUS (v. 7.2)

SRPMS:
yum-rhn-plugin-2.0.1-5.1.el7_2.src.rpm     MD5: 57a670ae692a5aecb85ef046d0efc8fe
SHA-256: faecf290a2b45c4d174c453c7d30c24ff358b8a84cdbb0049b9bd3705e9b3af4
 
x86_64:
yum-rhn-plugin-2.0.1-5.1.el7_2.noarch.rpm     MD5: b8a2d4ed91a322d9e0ccddc96cc204d0
SHA-256: 6339dba524e803744c91f5e0eabffbddc6434ed7fc7137d1470eb7ff61ea6fb7
 
Red Hat Enterprise Linux Server AUS (v. 7.2)

SRPMS:
yum-rhn-plugin-2.0.1-5.1.el7_2.src.rpm     MD5: 57a670ae692a5aecb85ef046d0efc8fe
SHA-256: faecf290a2b45c4d174c453c7d30c24ff358b8a84cdbb0049b9bd3705e9b3af4
 
x86_64:
yum-rhn-plugin-2.0.1-5.1.el7_2.noarch.rpm     MD5: b8a2d4ed91a322d9e0ccddc96cc204d0
SHA-256: 6339dba524e803744c91f5e0eabffbddc6434ed7fc7137d1470eb7ff61ea6fb7
 
Red Hat Enterprise Linux Server EUS (v. 7.2)

SRPMS:
yum-rhn-plugin-2.0.1-5.1.el7_2.src.rpm     MD5: 57a670ae692a5aecb85ef046d0efc8fe
SHA-256: faecf290a2b45c4d174c453c7d30c24ff358b8a84cdbb0049b9bd3705e9b3af4
 
PPC:
yum-rhn-plugin-2.0.1-5.1.el7_2.noarch.rpm     MD5: b8a2d4ed91a322d9e0ccddc96cc204d0
SHA-256: 6339dba524e803744c91f5e0eabffbddc6434ed7fc7137d1470eb7ff61ea6fb7
 
PPC64LE:
yum-rhn-plugin-2.0.1-5.1.el7_2.noarch.rpm     MD5: b8a2d4ed91a322d9e0ccddc96cc204d0
SHA-256: 6339dba524e803744c91f5e0eabffbddc6434ed7fc7137d1470eb7ff61ea6fb7
 
s390x:
yum-rhn-plugin-2.0.1-5.1.el7_2.noarch.rpm     MD5: b8a2d4ed91a322d9e0ccddc96cc204d0
SHA-256: 6339dba524e803744c91f5e0eabffbddc6434ed7fc7137d1470eb7ff61ea6fb7
 
x86_64:
yum-rhn-plugin-2.0.1-5.1.el7_2.noarch.rpm     MD5: b8a2d4ed91a322d9e0ccddc96cc204d0
SHA-256: 6339dba524e803744c91f5e0eabffbddc6434ed7fc7137d1470eb7ff61ea6fb7
 
Red Hat Enterprise Linux Server TUS (v. 7.2)

SRPMS:
yum-rhn-plugin-2.0.1-5.1.el7_2.src.rpm     MD5: 57a670ae692a5aecb85ef046d0efc8fe
SHA-256: faecf290a2b45c4d174c453c7d30c24ff358b8a84cdbb0049b9bd3705e9b3af4
 
x86_64:
yum-rhn-plugin-2.0.1-5.1.el7_2.noarch.rpm     MD5: b8a2d4ed91a322d9e0ccddc96cc204d0
SHA-256: 6339dba524e803744c91f5e0eabffbddc6434ed7fc7137d1470eb7ff61ea6fb7
 
(The unlinked packages above are only available from the Red Hat Network)

Bugs fixed (see bugzilla for more information)

1426702 - 7.2.z: yum-rhn-plugin sending malformed request header



These packages are GPG signed by Red Hat for security. Our key and details on how to verify the signature are available from:
https://www.redhat.com/security/team/key/#package

The Red Hat security contact is secalert@redhat.com. More contact details at http://www.redhat.com/security/team/contact/