Skip to navigation

Bug Fix Advisory fence-agents bug fix and enhancement update

Advisory: RHBA-2011:0745-1
Type: Bug Fix Advisory
Severity: N/A
Issued on: 2011-05-19
Last updated on: 2011-05-19
Affected Products: Red Hat Enterprise Linux High Availability (v. 6)
Red Hat Enterprise Linux Resilient Storage (v. 6)

Details

An updated fence-agents package that fixes bugs, adds support for new hardware
and Red Hat Enterprise Virtualization is now available.

Red Hat fence agents are a collection of scripts to handle remote power
management for several devices. They allow failed or unreachable nodes to be
forcibly restarted and removed from the cluster.

This update includes the following bug fixes:

* Metadata generation has been corrected in order to provide information for all
known parameters for each fencing agent. (BZ#618703, BZ#623266)

* Port is now a synonym of module_name for fence_drac5, making it consistent
with other fencing agents. (BZ#619096)

* Information on how to use fence_ipmi with HP iLO version 3 has been added to
the manual page. (BZ#648892)

* The fence_egenera manual page has been improved. (BZ#635824)

* fence_scsi now works when devices report "Unit Attention". (BZ#640343)

* fence_scsi now verifies action results. (BZ#644385)

* fence_scsi now correctly identifies device mapper multipath devices.
(BZ#644389)

* fence_scsi pattern matching has been improved. (BZ#670910)

* fence_scsi now logs errors whenever a command fails. (BZ#672597)

This update adds the following enhancements:

* Support for Cisco UCS blade systems is now provided. (BZ#580492, BZ#678904)

* It is now possible for one node to delay fencing in a two-node cluster.
(BZ#614046)

* Fence_ipmilan can now use the "diag" option. (BZ#655764)

* The package has been updated to provide a fencing agent that is able to
communicate with Red Hat Enterprise Virtualization Manager, allowing virtual
machines to be fenced. (BZ#595383)

* For Intelligent Platform Management Interface (IPMI) devices, the "power_wait"
delay can now be adjusted in order to support newer iLO 3 firmware. (BZ#642671)

* Brocade 200E, Brocade 300, Brocade 4100, Brocade 4900, and Brocade 5100
fencing devices are now supported by the fence_brocade agent, and can be used
with both Red Hat High Availability and Red Hat Resilient Storage. (BZ#642235,
BZ#680170)

* An issue with fence_scsi where the key was erroneously reported as 0 has been
addressed. (BZ#653504)

* fence_wti now correctly handles large (>20) port switches. (BZ#678522)

* fence_rhevm has been updated to the current RHEVM development API. (BZ#681669,
BZ#681674)

* fence_cisco_ucs was missing from the fence-agents package, but is now
included. (BZ#682715)

All users requiring any of the changes noted above should upgrade to this new
package, which fixes these issues and adds these enhancements.


Solution

Before applying this update, make sure all previously-released errata
relevant to your system have been applied.

This update is available via the Red Hat Network. Details on how to
use the Red Hat Network to apply this update are available at
http://kbase.redhat.com/faq/docs/DOC-11259

Updated packages

Red Hat Enterprise Linux High Availability (v. 6)

SRPMS:
fence-agents-3.0.12-23.el6.src.rpm
File outdated by:  RHBA-2012:0548
    MD5: 5249ef5cba3c5948a3b6ec76afc5a861
SHA-256: 8941996a2a7e5cb23357c26fedfb762dec614ac4d0a17f6ca1f65fb768ae7d48
 
IA-32:
fence-agents-3.0.12-23.el6.i686.rpm
File outdated by:  RHBA-2012:0548
    MD5: 8fab9c8b6c2ef7460bcbbfb3cb38f587
SHA-256: fd1177616f9117dc89c9dfc3d6f324d7c1a824e5ed94ef7c5ebc392742e8c3e2
fence-agents-debuginfo-3.0.12-23.el6.i686.rpm
File outdated by:  RHBA-2012:0548
    MD5: 9b3a1e85a33605dce0a4ca87532e34d7
SHA-256: 6c172b29c0446fda3caf019cb507271fae2993bf7e5e5b6287cced5b3bde3e88
 
x86_64:
fence-agents-3.0.12-23.el6.x86_64.rpm
File outdated by:  RHBA-2012:0548
    MD5: 02937de2a77c9f9f1943d080461b823e
SHA-256: c0fcf85d1835baffd2bbfcc8cb2464a2e1fd720fd0328770588604360ab81645
fence-agents-debuginfo-3.0.12-23.el6.x86_64.rpm
File outdated by:  RHBA-2012:0548
    MD5: 94a9c4480a421dd35a4fb127da5969b2
SHA-256: d485c9e45188c39457d7b4c3d1ca2e582580701167888bc07e4f6e979af5ef11
 
Red Hat Enterprise Linux Resilient Storage (v. 6)

SRPMS:
fence-agents-3.0.12-23.el6.src.rpm
File outdated by:  RHBA-2012:0548
    MD5: 5249ef5cba3c5948a3b6ec76afc5a861
SHA-256: 8941996a2a7e5cb23357c26fedfb762dec614ac4d0a17f6ca1f65fb768ae7d48
 
IA-32:
fence-agents-3.0.12-23.el6.i686.rpm
File outdated by:  RHBA-2012:0548
    MD5: 8fab9c8b6c2ef7460bcbbfb3cb38f587
SHA-256: fd1177616f9117dc89c9dfc3d6f324d7c1a824e5ed94ef7c5ebc392742e8c3e2
fence-agents-debuginfo-3.0.12-23.el6.i686.rpm
File outdated by:  RHBA-2012:0548
    MD5: 9b3a1e85a33605dce0a4ca87532e34d7
SHA-256: 6c172b29c0446fda3caf019cb507271fae2993bf7e5e5b6287cced5b3bde3e88
 
x86_64:
fence-agents-3.0.12-23.el6.x86_64.rpm
File outdated by:  RHBA-2012:0548
    MD5: 02937de2a77c9f9f1943d080461b823e
SHA-256: c0fcf85d1835baffd2bbfcc8cb2464a2e1fd720fd0328770588604360ab81645
fence-agents-debuginfo-3.0.12-23.el6.x86_64.rpm
File outdated by:  RHBA-2012:0548
    MD5: 94a9c4480a421dd35a4fb127da5969b2
SHA-256: d485c9e45188c39457d7b4c3d1ca2e582580701167888bc07e4f6e979af5ef11
 
(The unlinked packages above are only available from the Red Hat Network)

Bugs fixed (see bugzilla for more information)

595383 - Provide fence-rhev agent that uses the RHEV REST API
614046 - Method to cause one node to delay fencing in a two node cluster
618703 - Not all parameters appear in metadata
623266 - Metadata (man pages) generation does not take different sorts of action into account
635824 - Egenera: man page is incomplete
642235 - Testing of fence_brocade switches against FOS versions 6.1.x, 6.2.x, 6.3.x, 6.4.x
648892 - Fix manual page to describe usage of fence_ipmi with ilo3
653504 - [LSI CR187225] fence_node -U can fail with "key cannot be zero" when node sees clustered pvolumes
655764 - [RFE] Add "diag" option to fence_ipmilan to support ipmi chassis power diag option
670910 - fence_scsi: need stricter regular expression when looking for specific keys
672597 - fence_scsi: properly log errors for all commands
678522 - fence_wti: Unable to parse output when splitted into several screens
678904 - RFE: fence_cisco_ucs needs to support sub-organizations
679502 - Conga sets wrong value into cluster.conf, blocking fence_device to work properly.
680170 - readd urgently fence_brocade to the list of shipped fence_agents
681669 - fence_rhevm needs to change "RUNNING" status to "UP" status as the REST-API has changed.
681674 - fence_rhevm REST-API URL needs to be updated to "/rhevm-api/".
682715 - fence_cisco_ucs missing from fence-agents package


Keywords

fence-agents


These packages are GPG signed by Red Hat for security. Our key and details on how to verify the signature are available from:
https://www.redhat.com/security/team/key/#package

The Red Hat security contact is secalert@redhat.com. More contact details at http://www.redhat.com/security/team/contact/