Skip to navigation

Bug Fix Advisory vixie-cron bug fix update

Advisory: RHBA-2009:1684-1
Type: Bug Fix Advisory
Severity: N/A
Issued on: 2009-12-18
Last updated on: 2009-12-18
Affected Products: Red Hat Enterprise Linux (v. 5 server)
Red Hat Enterprise Linux Desktop (v. 5 client)
Red Hat Enterprise Linux EUS (v. 5.4.z server)

Details

An updated vixie-cron package that fixes a bug that prevented pam variables
being set with cron jobs is now available.

The vixie-cron package contains the Vixie version of cron. Cron is a
standard UNIX daemon that runs specified programs at scheduled times. The
vixie-cron package adds improved security and more powerful configuration
options to the standard version of cron.

This update fixes the following bug:

* according to the pam man page, the cron daemon, crond, "supports access
control with PAM" but the PAM configuration file for crond did not export
environment variables correctly and, consequently, setting pam variables
via cron did not work. This update includes a corrected /etc/pam.d/crond
file that export environment variables correctly. Setting pam variables via
cron now works as documented. (BZ#546568)

All vixie-cron users should upgrade to this updated package, which resolves
this issue.


Solution

Before applying this update, make sure all previously-released errata
relevant to your system have been applied.

This update is available via the Red Hat Network. Details on how to
use the Red Hat Network to apply this update are available at
http://kbase.redhat.com/faq/docs/DOC-11259

Updated packages

Red Hat Enterprise Linux (v. 5 server)

SRPMS:
vixie-cron-4.1-77.el5_4.1.src.rpm
File outdated by:  RHSA-2012:0304
    MD5: 2b8d130e9362b012034f3f1d206449af
 
IA-32:
vixie-cron-4.1-77.el5_4.1.i386.rpm
File outdated by:  RHSA-2012:0304
    MD5: 44374dc6988b51c1da880248e050ec5d
 
IA-64:
vixie-cron-4.1-77.el5_4.1.ia64.rpm
File outdated by:  RHSA-2012:0304
    MD5: 37dd04805f1824ec02fd3da9e6410526
 
PPC:
vixie-cron-4.1-77.el5_4.1.ppc.rpm
File outdated by:  RHSA-2012:0304
    MD5: f3b710d8d27d556c40af2611d7e48ce9
 
s390x:
vixie-cron-4.1-77.el5_4.1.s390x.rpm
File outdated by:  RHSA-2012:0304
    MD5: a41a913acc1234064895979e0bbc942d
 
x86_64:
vixie-cron-4.1-77.el5_4.1.x86_64.rpm
File outdated by:  RHSA-2012:0304
    MD5: 3e635c6a25e513cc9ec13b75377544b8
 
Red Hat Enterprise Linux Desktop (v. 5 client)

SRPMS:
vixie-cron-4.1-77.el5_4.1.src.rpm
File outdated by:  RHSA-2012:0304
    MD5: 2b8d130e9362b012034f3f1d206449af
 
IA-32:
vixie-cron-4.1-77.el5_4.1.i386.rpm
File outdated by:  RHSA-2012:0304
    MD5: 44374dc6988b51c1da880248e050ec5d
 
x86_64:
vixie-cron-4.1-77.el5_4.1.x86_64.rpm
File outdated by:  RHSA-2012:0304
    MD5: 3e635c6a25e513cc9ec13b75377544b8
 
Red Hat Enterprise Linux EUS (v. 5.4.z server)

SRPMS:
vixie-cron-4.1-77.el5_4.1.src.rpm
File outdated by:  RHSA-2012:0304
    MD5: 2b8d130e9362b012034f3f1d206449af
 
IA-32:
vixie-cron-4.1-77.el5_4.1.i386.rpm     MD5: 44374dc6988b51c1da880248e050ec5d
 
IA-64:
vixie-cron-4.1-77.el5_4.1.ia64.rpm     MD5: 37dd04805f1824ec02fd3da9e6410526
 
PPC:
vixie-cron-4.1-77.el5_4.1.ppc.rpm     MD5: f3b710d8d27d556c40af2611d7e48ce9
 
s390x:
vixie-cron-4.1-77.el5_4.1.s390x.rpm     MD5: a41a913acc1234064895979e0bbc942d
 
x86_64:
vixie-cron-4.1-77.el5_4.1.x86_64.rpm     MD5: 3e635c6a25e513cc9ec13b75377544b8
 
(The unlinked packages above are only available from the Red Hat Network)

Bugs fixed (see bugzilla for more information)

546568 - cron and /etc/security/pam_env.conf problem


Keywords

after, fail, group, home, new, permission, without, year


These packages are GPG signed by Red Hat for security. Our key and details on how to verify the signature are available from:
https://www.redhat.com/security/team/key/#package

The Red Hat security contact is secalert@redhat.com. More contact details at http://www.redhat.com/security/team/contact/