Skip to navigation

Bug Fix Advisory yum bug fix update

Advisory: RHBA-2008:0388-4
Type: Bug Fix Advisory
Severity: N/A
Issued on: 2008-05-21
Last updated on: 2008-05-21
Affected Products: Red Hat Enterprise Linux (v. 5 server)
Red Hat Enterprise Linux Desktop (v. 5 client)

Details

Updated yum packages that update yum to version 3.2.8 and resolve several
issues are now available.

Yum is a utility that can check for and automatically download and
install updated RPM packages. Dependencies are obtained and downloaded
automatically prompting the user as necessary.

These updated yum packages provide fixes for the following bugs:

* yum now displays the location from which it acquired the GPG key.
* yum now returns the appropriate exit codes when listing packages.
* various corrections to the yum man page.
* yum no longer outputs the error message "Cannot open logfile
/tmp/yumroot/var/log/yum.log" when installing with the '--installroot' option.
* a missing '/var/cache/yum/<repo>/headers' directory caused the command
'yum clean all' to fail.
* a leaking file descriptor caused a number of SELinux AVC denials.
* the yum configuration file no longer contains the obsoleted 'pkgpolicy'
option.
* yum now handles full path requirements correctly.
* yum now handles an empty group file correctly.
* yum can now work with repositories on the Apache HTTP server which do not
have partial download (no Range header) support.
* yum now sends the header "User-agent: urlgrabber/3.1.0 yum/3.2.8".
* a dependency misconfiguration has been fixed, so that yum now has the
correct dependencies.
* yum now installs yum-metadata-parser with the correct CPU architecture.
* yum did not perform tracebacks when there were SQLite exceptions.
* yum did not properly handle a recursion error which resulted in the error
message "RuntimeError: maximum recursion depth exceeded".
* yum now correctly installs all dependencies.
* a problem with a multilib install corner case has been corrected.
* upgrading yum using anaconda and an installation key now works.
* a critical memory leak in yum-updatesd was detected and fixed.
* yum-updatesd no longer blocks other yum tools.
* yum-updatesd no longer needs to restart when installed packages set changes.
* yum-utils now works reliably with yum.
* the yumdownloader option '--resolve' now works correctly.
* the yumdownloader '--disablerepo' now works correctly.
* the new plugins yum-filter-data and yum-list-data allow a wide-range of
filtering and listing of yum results.
* yum-changelog now works as expected.
* yum-aliases now has a manual page.
* pirut also now installs all of its dependencies correctly.
* several GUI fixes and improvements in pirut and system-cdinstall-helper.
* pirut translation issues with the ko_KR and de_DE locales have been fixed.
* CD/DVD install now works and no longer gives a "IOError: <urlopen error
unknown url type: media>" error message.
* pup now correctly updates sos and sysreport packages.
* the puplet tray icon now appears as expected.

All users of yum are advised to upgrade to these updated packages, which
resolve these issues.


Solution

Before applying this update, make sure that all previously-released
errata relevant to your system have been applied.

This update is available via Red Hat Network. Details on how to use
the Red Hat Network to apply this update are available at
http://kbase.redhat.com/faq/FAQ_58_10188

Updated packages

Red Hat Enterprise Linux (v. 5 server)

SRPMS:
pirut-1.3.28-13.el5.src.rpm
File outdated by:  RHBA-2013:0069
    MD5: 2e196d707148dfdba6bf935c9b9b4e8f
yum-3.2.8-9.el5.src.rpm
File outdated by:  RHBA-2012:1117
    MD5: dd80281b10e3e70749654ff56ec0f4b5
yum-metadata-parser-1.1.2-2.el5.src.rpm
File outdated by:  RHBA-2012:1115
    MD5: 3663e7f48b4c276151526227bd51e812
yum-updatesd-0.9-2.el5.src.rpm
File outdated by:  RHBA-2013:0067
    MD5: c861511dce5fdee9253c0e475fcc0518
yum-utils-1.1.10-9.el5.src.rpm
File outdated by:  RHBA-2012:0281
    MD5: 32cb0f5fac42eb22512a0fe2c3e2ce5f
 
IA-32:
pirut-1.3.28-13.el5.noarch.rpm
File outdated by:  RHBA-2013:0069
    MD5: 2fa45476f48fc0ae963eee825fe47d75
yum-3.2.8-9.el5.noarch.rpm
File outdated by:  RHBA-2012:1117
    MD5: 9ae1f795d8c955719632429de7ce6959
yum-aliases-1.1.10-9.el5.noarch.rpm
File outdated by:  RHBA-2012:0281
    MD5: c44fa882a186b3c615207e645f26ae99
yum-basearchonly-1.1.10-9.el5.noarch.rpm     MD5: 1f8a11cc0823df404db240cc9e96abfe
yum-changelog-1.1.10-9.el5.noarch.rpm
File outdated by:  RHBA-2012:0281
    MD5: 57ae9ba8401d6435e5549eb54ddf910d
yum-downloadonly-1.1.10-9.el5.noarch.rpm
File outdated by:  RHBA-2012:0281
    MD5: 619c74872459d587e0d586a31b0c27db
yum-filter-data-1.1.10-9.el5.noarch.rpm
File outdated by:  RHBA-2012:0281
    MD5: d8d64c771ae0fbe8e44cab80f21dfa94
yum-kmod-1.1.10-9.el5.noarch.rpm
File outdated by:  RHBA-2012:0281
    MD5: ac1b30da6d8f22603cbb4042950c7a0e
yum-list-data-1.1.10-9.el5.noarch.rpm
File outdated by:  RHBA-2012:0281
    MD5: 1a38d05f4e030fef0b9e0c80a6ffb7d4
yum-metadata-parser-1.1.2-2.el5.i386.rpm
File outdated by:  RHBA-2012:1115
    MD5: 5b94e8688a78f4840a17e03338a5933d
yum-protect-packages-1.1.10-9.el5.noarch.rpm
File outdated by:  RHBA-2012:0281
    MD5: 15bbc917a09907da8877f61575e6702e
yum-protectbase-1.1.10-9.el5.noarch.rpm
File outdated by:  RHBA-2012:0281
    MD5: 5f069c474cba407a209dffff3cf493cb
yum-security-1.1.10-9.el5.noarch.rpm
File outdated by:  RHBA-2012:0281
    MD5: 320565b329244ba058ff33fbccec04ea
yum-skip-broken-1.1.10-9.el5.noarch.rpm     MD5: bbdea5d527acd086f716c8ab2ec164fe
yum-updateonboot-1.1.10-9.el5.noarch.rpm
File outdated by:  RHBA-2012:0281
    MD5: fcabb9597e9ffdd6f5a805dc7ae6ab13
yum-updatesd-0.9-2.el5.noarch.rpm
File outdated by:  RHBA-2013:0067
    MD5: 0704e36544d8c54cec1c06b9c6f93e21
yum-utils-1.1.10-9.el5.noarch.rpm
File outdated by:  RHBA-2012:0281
    MD5: ccc302a77c7885de39e4e82e301581b2
yum-versionlock-1.1.10-9.el5.noarch.rpm
File outdated by:  RHBA-2012:0281
    MD5: f94f1213e8351afcaa2e0fc2e282520c
 
IA-64:
pirut-1.3.28-13.el5.noarch.rpm
File outdated by:  RHBA-2013:0069
    MD5: 2fa45476f48fc0ae963eee825fe47d75
yum-3.2.8-9.el5.noarch.rpm
File outdated by:  RHBA-2012:1117
    MD5: 9ae1f795d8c955719632429de7ce6959
yum-aliases-1.1.10-9.el5.noarch.rpm
File outdated by:  RHBA-2012:0281
    MD5: c44fa882a186b3c615207e645f26ae99
yum-basearchonly-1.1.10-9.el5.noarch.rpm     MD5: 1f8a11cc0823df404db240cc9e96abfe
yum-changelog-1.1.10-9.el5.noarch.rpm
File outdated by:  RHBA-2012:0281
    MD5: 57ae9ba8401d6435e5549eb54ddf910d
yum-downloadonly-1.1.10-9.el5.noarch.rpm
File outdated by:  RHBA-2012:0281
    MD5: 619c74872459d587e0d586a31b0c27db
yum-filter-data-1.1.10-9.el5.noarch.rpm
File outdated by:  RHBA-2012:0281
    MD5: d8d64c771ae0fbe8e44cab80f21dfa94
yum-kmod-1.1.10-9.el5.noarch.rpm
File outdated by:  RHBA-2012:0281
    MD5: ac1b30da6d8f22603cbb4042950c7a0e
yum-list-data-1.1.10-9.el5.noarch.rpm
File outdated by:  RHBA-2012:0281
    MD5: 1a38d05f4e030fef0b9e0c80a6ffb7d4
yum-metadata-parser-1.1.2-2.el5.ia64.rpm
File outdated by:  RHBA-2012:1115
    MD5: d160918701e70d77c81b2294ceaf2c3d
yum-protect-packages-1.1.10-9.el5.noarch.rpm
File outdated by:  RHBA-2012:0281
    MD5: 15bbc917a09907da8877f61575e6702e
yum-protectbase-1.1.10-9.el5.noarch.rpm
File outdated by:  RHBA-2012:0281
    MD5: 5f069c474cba407a209dffff3cf493cb
yum-security-1.1.10-9.el5.noarch.rpm
File outdated by:  RHBA-2012:0281
    MD5: 320565b329244ba058ff33fbccec04ea
yum-skip-broken-1.1.10-9.el5.noarch.rpm     MD5: bbdea5d527acd086f716c8ab2ec164fe
yum-updateonboot-1.1.10-9.el5.noarch.rpm
File outdated by:  RHBA-2012:0281
    MD5: fcabb9597e9ffdd6f5a805dc7ae6ab13
yum-updatesd-0.9-2.el5.noarch.rpm
File outdated by:  RHBA-2013:0067
    MD5: 0704e36544d8c54cec1c06b9c6f93e21
yum-utils-1.1.10-9.el5.noarch.rpm
File outdated by:  RHBA-2012:0281
    MD5: ccc302a77c7885de39e4e82e301581b2
yum-versionlock-1.1.10-9.el5.noarch.rpm
File outdated by:  RHBA-2012:0281
    MD5: f94f1213e8351afcaa2e0fc2e282520c
 
PPC:
pirut-1.3.28-13.el5.noarch.rpm
File outdated by:  RHBA-2013:0069
    MD5: 2fa45476f48fc0ae963eee825fe47d75
yum-3.2.8-9.el5.noarch.rpm
File outdated by:  RHBA-2012:1117
    MD5: 9ae1f795d8c955719632429de7ce6959
yum-aliases-1.1.10-9.el5.noarch.rpm
File outdated by:  RHBA-2012:0281
    MD5: c44fa882a186b3c615207e645f26ae99
yum-basearchonly-1.1.10-9.el5.noarch.rpm     MD5: 1f8a11cc0823df404db240cc9e96abfe
yum-changelog-1.1.10-9.el5.noarch.rpm
File outdated by:  RHBA-2012:0281
    MD5: 57ae9ba8401d6435e5549eb54ddf910d
yum-downloadonly-1.1.10-9.el5.noarch.rpm
File outdated by:  RHBA-2012:0281
    MD5: 619c74872459d587e0d586a31b0c27db
yum-filter-data-1.1.10-9.el5.noarch.rpm
File outdated by:  RHBA-2012:0281
    MD5: d8d64c771ae0fbe8e44cab80f21dfa94
yum-kmod-1.1.10-9.el5.noarch.rpm
File outdated by:  RHBA-2012:0281
    MD5: ac1b30da6d8f22603cbb4042950c7a0e
yum-list-data-1.1.10-9.el5.noarch.rpm
File outdated by:  RHBA-2012:0281
    MD5: 1a38d05f4e030fef0b9e0c80a6ffb7d4
yum-metadata-parser-1.1.2-2.el5.ppc.rpm
File outdated by:  RHBA-2012:1115
    MD5: 01483e4146d2e2082866691168b00490
yum-protect-packages-1.1.10-9.el5.noarch.rpm
File outdated by:  RHBA-2012:0281
    MD5: 15bbc917a09907da8877f61575e6702e
yum-protectbase-1.1.10-9.el5.noarch.rpm
File outdated by:  RHBA-2012:0281
    MD5: 5f069c474cba407a209dffff3cf493cb
yum-security-1.1.10-9.el5.noarch.rpm
File outdated by:  RHBA-2012:0281
    MD5: 320565b329244ba058ff33fbccec04ea
yum-skip-broken-1.1.10-9.el5.noarch.rpm     MD5: bbdea5d527acd086f716c8ab2ec164fe
yum-updateonboot-1.1.10-9.el5.noarch.rpm
File outdated by:  RHBA-2012:0281
    MD5: fcabb9597e9ffdd6f5a805dc7ae6ab13
yum-updatesd-0.9-2.el5.noarch.rpm
File outdated by:  RHBA-2013:0067
    MD5: 0704e36544d8c54cec1c06b9c6f93e21
yum-utils-1.1.10-9.el5.noarch.rpm
File outdated by:  RHBA-2012:0281
    MD5: ccc302a77c7885de39e4e82e301581b2
yum-versionlock-1.1.10-9.el5.noarch.rpm
File outdated by:  RHBA-2012:0281
    MD5: f94f1213e8351afcaa2e0fc2e282520c
 
s390x:
pirut-1.3.28-13.el5.noarch.rpm
File outdated by:  RHBA-2013:0069
    MD5: 2fa45476f48fc0ae963eee825fe47d75
yum-3.2.8-9.el5.noarch.rpm
File outdated by:  RHBA-2012:1117
    MD5: 9ae1f795d8c955719632429de7ce6959
yum-aliases-1.1.10-9.el5.noarch.rpm
File outdated by:  RHBA-2012:0281
    MD5: c44fa882a186b3c615207e645f26ae99
yum-basearchonly-1.1.10-9.el5.noarch.rpm     MD5: 1f8a11cc0823df404db240cc9e96abfe
yum-changelog-1.1.10-9.el5.noarch.rpm
File outdated by:  RHBA-2012:0281
    MD5: 57ae9ba8401d6435e5549eb54ddf910d
yum-downloadonly-1.1.10-9.el5.noarch.rpm
File outdated by:  RHBA-2012:0281
    MD5: 619c74872459d587e0d586a31b0c27db
yum-filter-data-1.1.10-9.el5.noarch.rpm
File outdated by:  RHBA-2012:0281
    MD5: d8d64c771ae0fbe8e44cab80f21dfa94
yum-kmod-1.1.10-9.el5.noarch.rpm
File outdated by:  RHBA-2012:0281
    MD5: ac1b30da6d8f22603cbb4042950c7a0e
yum-list-data-1.1.10-9.el5.noarch.rpm
File outdated by:  RHBA-2012:0281
    MD5: 1a38d05f4e030fef0b9e0c80a6ffb7d4
yum-metadata-parser-1.1.2-2.el5.s390x.rpm
File outdated by:  RHBA-2012:1115
    MD5: a155ad92c64c3493e233d5bed21bdcd7
yum-protect-packages-1.1.10-9.el5.noarch.rpm
File outdated by:  RHBA-2012:0281
    MD5: 15bbc917a09907da8877f61575e6702e
yum-protectbase-1.1.10-9.el5.noarch.rpm
File outdated by:  RHBA-2012:0281
    MD5: 5f069c474cba407a209dffff3cf493cb
yum-security-1.1.10-9.el5.noarch.rpm
File outdated by:  RHBA-2012:0281
    MD5: 320565b329244ba058ff33fbccec04ea
yum-skip-broken-1.1.10-9.el5.noarch.rpm     MD5: bbdea5d527acd086f716c8ab2ec164fe
yum-updateonboot-1.1.10-9.el5.noarch.rpm
File outdated by:  RHBA-2012:0281
    MD5: fcabb9597e9ffdd6f5a805dc7ae6ab13
yum-updatesd-0.9-2.el5.noarch.rpm
File outdated by:  RHBA-2013:0067
    MD5: 0704e36544d8c54cec1c06b9c6f93e21
yum-utils-1.1.10-9.el5.noarch.rpm
File outdated by:  RHBA-2012:0281
    MD5: ccc302a77c7885de39e4e82e301581b2
yum-versionlock-1.1.10-9.el5.noarch.rpm
File outdated by:  RHBA-2012:0281
    MD5: f94f1213e8351afcaa2e0fc2e282520c
 
x86_64:
pirut-1.3.28-13.el5.noarch.rpm
File outdated by:  RHBA-2013:0069
    MD5: 2fa45476f48fc0ae963eee825fe47d75
yum-3.2.8-9.el5.noarch.rpm
File outdated by:  RHBA-2012:1117
    MD5: 9ae1f795d8c955719632429de7ce6959
yum-aliases-1.1.10-9.el5.noarch.rpm
File outdated by:  RHBA-2012:0281
    MD5: c44fa882a186b3c615207e645f26ae99
yum-basearchonly-1.1.10-9.el5.noarch.rpm     MD5: 1f8a11cc0823df404db240cc9e96abfe
yum-changelog-1.1.10-9.el5.noarch.rpm
File outdated by:  RHBA-2012:0281
    MD5: 57ae9ba8401d6435e5549eb54ddf910d
yum-downloadonly-1.1.10-9.el5.noarch.rpm
File outdated by:  RHBA-2012:0281
    MD5: 619c74872459d587e0d586a31b0c27db
yum-filter-data-1.1.10-9.el5.noarch.rpm
File outdated by:  RHBA-2012:0281
    MD5: d8d64c771ae0fbe8e44cab80f21dfa94
yum-kmod-1.1.10-9.el5.noarch.rpm
File outdated by:  RHBA-2012:0281
    MD5: ac1b30da6d8f22603cbb4042950c7a0e
yum-list-data-1.1.10-9.el5.noarch.rpm
File outdated by:  RHBA-2012:0281
    MD5: 1a38d05f4e030fef0b9e0c80a6ffb7d4
yum-metadata-parser-1.1.2-2.el5.x86_64.rpm
File outdated by:  RHBA-2012:1115
    MD5: c3bfbb9a5c0a5555e8ccc1d3dd823ea1
yum-protect-packages-1.1.10-9.el5.noarch.rpm
File outdated by:  RHBA-2012:0281
    MD5: 15bbc917a09907da8877f61575e6702e
yum-protectbase-1.1.10-9.el5.noarch.rpm
File outdated by:  RHBA-2012:0281
    MD5: 5f069c474cba407a209dffff3cf493cb
yum-security-1.1.10-9.el5.noarch.rpm
File outdated by:  RHBA-2012:0281
    MD5: 320565b329244ba058ff33fbccec04ea
yum-skip-broken-1.1.10-9.el5.noarch.rpm     MD5: bbdea5d527acd086f716c8ab2ec164fe
yum-updateonboot-1.1.10-9.el5.noarch.rpm
File outdated by:  RHBA-2012:0281
    MD5: fcabb9597e9ffdd6f5a805dc7ae6ab13
yum-updatesd-0.9-2.el5.noarch.rpm
File outdated by:  RHBA-2013:0067
    MD5: 0704e36544d8c54cec1c06b9c6f93e21
yum-utils-1.1.10-9.el5.noarch.rpm
File outdated by:  RHBA-2012:0281
    MD5: ccc302a77c7885de39e4e82e301581b2
yum-versionlock-1.1.10-9.el5.noarch.rpm
File outdated by:  RHBA-2012:0281
    MD5: f94f1213e8351afcaa2e0fc2e282520c
 
Red Hat Enterprise Linux Desktop (v. 5 client)

SRPMS:
pirut-1.3.28-13.el5.src.rpm
File outdated by:  RHBA-2013:0069
    MD5: 2e196d707148dfdba6bf935c9b9b4e8f
yum-3.2.8-9.el5.src.rpm
File outdated by:  RHBA-2012:1117
    MD5: dd80281b10e3e70749654ff56ec0f4b5
yum-metadata-parser-1.1.2-2.el5.src.rpm
File outdated by:  RHBA-2012:1115
    MD5: 3663e7f48b4c276151526227bd51e812
yum-updatesd-0.9-2.el5.src.rpm
File outdated by:  RHBA-2013:0067
    MD5: c861511dce5fdee9253c0e475fcc0518
yum-utils-1.1.10-9.el5.src.rpm
File outdated by:  RHBA-2012:0281
    MD5: 32cb0f5fac42eb22512a0fe2c3e2ce5f
 
IA-32:
pirut-1.3.28-13.el5.noarch.rpm
File outdated by:  RHBA-2013:0069
    MD5: 2fa45476f48fc0ae963eee825fe47d75
yum-3.2.8-9.el5.noarch.rpm
File outdated by:  RHBA-2012:1117
    MD5: 9ae1f795d8c955719632429de7ce6959
yum-aliases-1.1.10-9.el5.noarch.rpm
File outdated by:  RHBA-2012:0281
    MD5: c44fa882a186b3c615207e645f26ae99
yum-basearchonly-1.1.10-9.el5.noarch.rpm     MD5: 1f8a11cc0823df404db240cc9e96abfe
yum-changelog-1.1.10-9.el5.noarch.rpm
File outdated by:  RHBA-2012:0281
    MD5: 57ae9ba8401d6435e5549eb54ddf910d
yum-downloadonly-1.1.10-9.el5.noarch.rpm
File outdated by:  RHBA-2012:0281
    MD5: 619c74872459d587e0d586a31b0c27db
yum-filter-data-1.1.10-9.el5.noarch.rpm
File outdated by:  RHBA-2012:0281
    MD5: d8d64c771ae0fbe8e44cab80f21dfa94
yum-kmod-1.1.10-9.el5.noarch.rpm
File outdated by:  RHBA-2012:0281
    MD5: ac1b30da6d8f22603cbb4042950c7a0e
yum-list-data-1.1.10-9.el5.noarch.rpm
File outdated by:  RHBA-2012:0281
    MD5: 1a38d05f4e030fef0b9e0c80a6ffb7d4
yum-metadata-parser-1.1.2-2.el5.i386.rpm
File outdated by:  RHBA-2012:1115
    MD5: 5b94e8688a78f4840a17e03338a5933d
yum-protect-packages-1.1.10-9.el5.noarch.rpm
File outdated by:  RHBA-2012:0281
    MD5: 15bbc917a09907da8877f61575e6702e
yum-protectbase-1.1.10-9.el5.noarch.rpm
File outdated by:  RHBA-2012:0281
    MD5: 5f069c474cba407a209dffff3cf493cb
yum-security-1.1.10-9.el5.noarch.rpm
File outdated by:  RHBA-2012:0281
    MD5: 320565b329244ba058ff33fbccec04ea
yum-skip-broken-1.1.10-9.el5.noarch.rpm     MD5: bbdea5d527acd086f716c8ab2ec164fe
yum-updateonboot-1.1.10-9.el5.noarch.rpm
File outdated by:  RHBA-2012:0281
    MD5: fcabb9597e9ffdd6f5a805dc7ae6ab13
yum-updatesd-0.9-2.el5.noarch.rpm
File outdated by:  RHBA-2013:0067
    MD5: 0704e36544d8c54cec1c06b9c6f93e21
yum-utils-1.1.10-9.el5.noarch.rpm
File outdated by:  RHBA-2012:0281
    MD5: ccc302a77c7885de39e4e82e301581b2
yum-versionlock-1.1.10-9.el5.noarch.rpm
File outdated by:  RHBA-2012:0281
    MD5: f94f1213e8351afcaa2e0fc2e282520c
 
x86_64:
pirut-1.3.28-13.el5.noarch.rpm
File outdated by:  RHBA-2013:0069
    MD5: 2fa45476f48fc0ae963eee825fe47d75
yum-3.2.8-9.el5.noarch.rpm
File outdated by:  RHBA-2012:1117
    MD5: 9ae1f795d8c955719632429de7ce6959
yum-aliases-1.1.10-9.el5.noarch.rpm
File outdated by:  RHBA-2012:0281
    MD5: c44fa882a186b3c615207e645f26ae99
yum-basearchonly-1.1.10-9.el5.noarch.rpm     MD5: 1f8a11cc0823df404db240cc9e96abfe
yum-changelog-1.1.10-9.el5.noarch.rpm
File outdated by:  RHBA-2012:0281
    MD5: 57ae9ba8401d6435e5549eb54ddf910d
yum-downloadonly-1.1.10-9.el5.noarch.rpm
File outdated by:  RHBA-2012:0281
    MD5: 619c74872459d587e0d586a31b0c27db
yum-filter-data-1.1.10-9.el5.noarch.rpm
File outdated by:  RHBA-2012:0281
    MD5: d8d64c771ae0fbe8e44cab80f21dfa94
yum-kmod-1.1.10-9.el5.noarch.rpm
File outdated by:  RHBA-2012:0281
    MD5: ac1b30da6d8f22603cbb4042950c7a0e
yum-list-data-1.1.10-9.el5.noarch.rpm
File outdated by:  RHBA-2012:0281
    MD5: 1a38d05f4e030fef0b9e0c80a6ffb7d4
yum-metadata-parser-1.1.2-2.el5.x86_64.rpm
File outdated by:  RHBA-2012:1115
    MD5: c3bfbb9a5c0a5555e8ccc1d3dd823ea1
yum-protect-packages-1.1.10-9.el5.noarch.rpm
File outdated by:  RHBA-2012:0281
    MD5: 15bbc917a09907da8877f61575e6702e
yum-protectbase-1.1.10-9.el5.noarch.rpm
File outdated by:  RHBA-2012:0281
    MD5: 5f069c474cba407a209dffff3cf493cb
yum-security-1.1.10-9.el5.noarch.rpm
File outdated by:  RHBA-2012:0281
    MD5: 320565b329244ba058ff33fbccec04ea
yum-skip-broken-1.1.10-9.el5.noarch.rpm     MD5: bbdea5d527acd086f716c8ab2ec164fe
yum-updateonboot-1.1.10-9.el5.noarch.rpm
File outdated by:  RHBA-2012:0281
    MD5: fcabb9597e9ffdd6f5a805dc7ae6ab13
yum-updatesd-0.9-2.el5.noarch.rpm
File outdated by:  RHBA-2013:0067
    MD5: 0704e36544d8c54cec1c06b9c6f93e21
yum-utils-1.1.10-9.el5.noarch.rpm
File outdated by:  RHBA-2012:0281
    MD5: ccc302a77c7885de39e4e82e301581b2
yum-versionlock-1.1.10-9.el5.noarch.rpm
File outdated by:  RHBA-2012:0281
    MD5: f94f1213e8351afcaa2e0fc2e282520c
 
(The unlinked packages above are only available from the Red Hat Network)

Bugs fixed (see bugzilla for more information)

237773 - pkgpolicy in yum.conf is not documented in online manual
238438 - yum installation of hts rpm fails with a traceback
240611 - yum not returning appropriate exit codes when listing packages
241182 - pirut crashes on empty group file
249085 - memory leak in yum-updatesd
249710 - RFE: Yum to understood rpms downloaded, when partial content requested
250231 - [pirut] [ko_KR] - Need some strings to be corrected in Pirut
309811 - Unable to upgrade from snapshot3 to snapshot4 using Virtualization key
339321 - Wrong dependency in libvirt-python
389611 - yum resolves full path requirements wrong and install wrong package.
391791 - yumdownloader Crashes When Using --resolve
426419 - yumdownloader does not support "--disablerepo" option
427987 - yum-changelog: TypeError: populateSack() got an unexpected keyword argument 'mdtype'
429346 - yum not returning appropriate exit codes when listing packages
429653 - yum-metadata-parser update
429737 - missing "import" causes adding repos during install to fail
429751 - Yum gives traceback
431073 - pirut crashs with german locale
431077 - Specified icons in .desktop file are missing
435474 - puplet never appears in notification tray
437127 - yum-filter-data uses incorrect options in examples
437429 - Multilib. install corner case error
438168 - man-page is incomplete
438169 - yum-aliases should contain man-page



These packages are GPG signed by Red Hat for security. Our key and details on how to verify the signature are available from:
https://www.redhat.com/security/team/key/#package

The Red Hat security contact is secalert@redhat.com. More contact details at http://www.redhat.com/security/team/contact/