Skip to navigation

Bug Fix Advisory MySQL-python bug fix update

Advisory: RHBA-2007:0295-2
Type: Bug Fix Advisory
Severity: N/A
Issued on: 2007-04-28
Last updated on: 2007-04-28
Affected Products: Red Hat Desktop (v. 4)
Red Hat Enterprise Linux AS (v. 4)
Red Hat Enterprise Linux ES (v. 4)
Red Hat Enterprise Linux WS (v. 4)

Details

Updated MySQL-python packages that fix various bugs are now available.

MySQL-python is an interface to the popular MySQL database server for Python.

This update replaces MySQL-python 1.0.0, which did not work well with MySQL
4.1, with a newer version that does. Relinking against the MySQL 4.1 client
libraries also resolves problems seen when both 3.x and 4.x MySQL client
libraries were loaded into the same application process, as sometimes
happened within Apache for instance.

Users of MySQL-python are advised to upgrade to these updated packages,
which resolve these issues.


Solution

Before applying this update, make sure all previously released errata
relevant to your system have been applied.

This update is available via Red Hat Network. To use Red Hat Network,
launch the Red Hat Update Agent with the following command:

up2date

This will start an interactive process that will result in the appropriate
RPMs being upgraded on your system.

Updated packages

Red Hat Desktop (v. 4)

SRPMS:
MySQL-python-1.2.1_p2-1.el4.1.src.rpm     MD5: a1a8d8b5bd9e246286dd49cf88fdb3b2
 
IA-32:
MySQL-python-1.2.1_p2-1.el4.1.i386.rpm     MD5: 184c4ee005a360c158576e44a47df9e1
 
x86_64:
MySQL-python-1.2.1_p2-1.el4.1.x86_64.rpm     MD5: faff5505bea5fbca9a65b2cc390334e7
 
Red Hat Enterprise Linux AS (v. 4)

SRPMS:
MySQL-python-1.2.1_p2-1.el4.1.src.rpm     MD5: a1a8d8b5bd9e246286dd49cf88fdb3b2
 
IA-32:
MySQL-python-1.2.1_p2-1.el4.1.i386.rpm     MD5: 184c4ee005a360c158576e44a47df9e1
 
IA-64:
MySQL-python-1.2.1_p2-1.el4.1.ia64.rpm     MD5: 426ad3e3250af3ebb295d2e4c3653436
 
PPC:
MySQL-python-1.2.1_p2-1.el4.1.ppc.rpm     MD5: 5b2fe1bd932b865f905225f88286da23
 
s390:
MySQL-python-1.2.1_p2-1.el4.1.s390.rpm     MD5: f509f9abc9280ba5f64455fb5cebab86
 
s390x:
MySQL-python-1.2.1_p2-1.el4.1.s390x.rpm     MD5: 957ef3137f1cfd12ec9684d44fdbab19
 
x86_64:
MySQL-python-1.2.1_p2-1.el4.1.x86_64.rpm     MD5: faff5505bea5fbca9a65b2cc390334e7
 
Red Hat Enterprise Linux ES (v. 4)

SRPMS:
MySQL-python-1.2.1_p2-1.el4.1.src.rpm     MD5: a1a8d8b5bd9e246286dd49cf88fdb3b2
 
IA-32:
MySQL-python-1.2.1_p2-1.el4.1.i386.rpm     MD5: 184c4ee005a360c158576e44a47df9e1
 
IA-64:
MySQL-python-1.2.1_p2-1.el4.1.ia64.rpm     MD5: 426ad3e3250af3ebb295d2e4c3653436
 
x86_64:
MySQL-python-1.2.1_p2-1.el4.1.x86_64.rpm     MD5: faff5505bea5fbca9a65b2cc390334e7
 
Red Hat Enterprise Linux WS (v. 4)

SRPMS:
MySQL-python-1.2.1_p2-1.el4.1.src.rpm     MD5: a1a8d8b5bd9e246286dd49cf88fdb3b2
 
IA-32:
MySQL-python-1.2.1_p2-1.el4.1.i386.rpm     MD5: 184c4ee005a360c158576e44a47df9e1
 
IA-64:
MySQL-python-1.2.1_p2-1.el4.1.ia64.rpm     MD5: 426ad3e3250af3ebb295d2e4c3653436
 
x86_64:
MySQL-python-1.2.1_p2-1.el4.1.x86_64.rpm     MD5: faff5505bea5fbca9a65b2cc390334e7
 
(The unlinked packages above are only available from the Red Hat Network)

Bugs fixed (see bugzilla for more information)

150828 - Apache crashes when mod_python and php both access MySQL
155341 - MySQL-python-1.0.0 is not compatible with MySQL 4.1



These packages are GPG signed by Red Hat for security. Our key and details on how to verify the signature are available from:
https://www.redhat.com/security/team/key/#package

The Red Hat security contact is secalert@redhat.com. More contact details at http://www.redhat.com/security/team/contact/